Results 1 to 10 of 10

Thread: OpenSuse 11 support for WPA-EAP-TLS

  1. #1

    Default OpenSuse 11 support for WPA-EAP-TLS

    Hi All,

    I just installed OpenSuse11, and the Network Manager does not let me configure wireless for WPA (enterprise)/EAP-TLS protocol. I mean, I cannot tell it to look for EAP TLS authentication method.

    I learnt that Network Manager 0.6.6 (older version) would allow this.

    And yeah, I am able to connect to unsecured networks via wireless. (although it seems to be too slow). Is this also a problem?

    I have Intel pro 3965ABG card.

    I certainly would not want to go to older version of Suse, or go to other distro. I am a newbie, wanting to migrate from Vista.

    Would really appreciate any help!

  2. #2
    Uwe Buckesfeld NNTP User

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    On 06/25/2008 devendra rai wrote:
    > I just installed OpenSuse11, and the Network Manager does not let me
    > configure wireless for WPA (enterprise)/EAP-TLS protocol. I mean, I
    > cannot tell it to look for EAP TLS authentication method.


    But it looks like mine does. Edit a connection, and when you select WPA Enterprise, click "Expert settings". Cannot test it myself, I only got mere SoHo WLAN around.

    Uwe

  3. #3

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    Hi

    Thanks for the help. I cannot find "expert mode" in my network manager! All I have is a set of configurations that runs as:

    Wireless Security: WPA & WPA Enterprise
    Authentication: PEAP | LEAP ...

    but no EAP method!

    I tried going to Yast and changing wireless card settings, but does not work (I see an option for WPA EAP though).

    I can connect to all other wireless networks painlessly!

    I have network manager 0.7 (shipped with SuseLinux 11)

    Thanks for any ideas!

  4. #4

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    I was asking the same question when 11 was in RC. My company uses PEAP with GTC, and that option has always been available in openSuSE, but the wireless options for 802.1x authentication in 11 seem to be lacking options for enterprise authentication. I filed a bug report, and I was told they would look at it.

  5. #5
    Uwe Buckesfeld NNTP User

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    * devendra rai,

    I have network manager 0.7 also. Step by step:

    Right click the network manager tray icon
    Edit connections
    New Connection (Wireless)
    Enter the SSID, next
    Use Wireless Security, WPA Enterprise
    Under that, there should now be a set of values for EAP, with a drop down for various methods.

    Uwe



  6. #6

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    Yes... that's always been there. The problem is if you use PEAP then select "inner authentication methods" the only choices are MSCHAPv2 and MD5. That is where the problem comes in because there are other missing authentication methods. In my case I need (and have been using with previous SuSE versions) GTC.

    Edit: GTC is a Cisco protocol, so it's not like some obscure authentication method. I'm actually on my third job where PEAP/GTC is used and required and openSuSE 11 is not showing me any love.

  7. #7
    Uwe Buckesfeld NNTP User

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    * bbilut,

    found the bug. Maybe you should ping Helmut again.

    Uwe

  8. #8

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    I can manage without wireless, so I didn't want to be a bother to him. I more or less just wanted to make sure they knew some authentication methods were missing.

    Thanks!

    Brad

  9. #9
    mpmcquade NNTP User

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    Has anyone found or received an answer to this issue? I too have installed OpenSUSE 11 (both 32 bit and 64 bit) and have the same need to use PEAP/GTC for wireless authentication to Microsoft AD.

  10. #10
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: OpenSuse 11 support for WPA-EAP-TLS

    * mpmcquade,

    check
    https://bugzilla.novell.com/show_bug.cgi?id=396347
    Looks like there's an experimental package in Helmut Schaa's repository.

    Uwe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •