Results 1 to 2 of 2

Thread: GRUB Ugh!!

  1. #1
    orchdork10159 NNTP User

    Exclamation GRUB Ugh!!

    Okay, here's the dealio.......

    I run OpenSUSE 10.3 on a Dell Inspiron 8500. I don't have Windows or anything else. However, I did get bored one day, and decided to install gOS. I just did the smallest version and made a little partition to install it on. I just made one partition for it, and used the same swap for both OS's. Once I realized that the version that I installed was the pity one, I decided to uninstall it. So I did, booted the OpenSUSE 10.3 Live CD, and undid the partition changes. (delete gOS, resize other partition). Then, when I booted it up again, I got something like this (didn't write it down).

    Grub loading...
    Step 1.5 (or whatever it's called)

    bla bla
    Error 22
    I looked up the error, and it means "Invalid Partition". I looked in the menu.lst file and the device.map file, and all of the partitions are named correctly.

    Below is my HD partitioning in and what not, along with my menu.lst and device.map files. Please help!! (I don't want to have to keep booting the Live CD because my wifi card doesn't work on it! Haha)

    Code:
    # fdisk -l
    
    Disk /dev/sda: 60.0 GB, 60011642880 bytes
    255 heads, 63 sectors/track, 7296 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000c6964
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        2611    20972826   83  Linux
    /dev/sda2            2612        6881    34298775   83  Linux
    /dev/sda3            6920        7296     3028252+  82  Linux swap / Solaris
    device.map:

    (hd0) /dev/sda
    menu.lst:

    # Modified by YaST2. Last modification on Sun Jun 8 21:08:55 CDT 2008
    default 0
    timeout 8
    gfxmenu (hd0,0)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 10.3 - 2.6.22.17-0.1
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/sda1 vga=0x314 splash=silent showopts
    initrd /boot/initrd-2.6.22.17-0.1-default

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    ### root (hd0,0)
    ### kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/sda1 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    ### initrd /boot/initrd-2.6.22.17-0.1-default
    I would really like to NOT have to re-partition my whole HD, and I'm almost positive that I don't really need to. Also, I really don't need the boot loader. If anyone knows how to just make it so it just boots the kernel, that'd be great. Just remember, I have no way to get into that kernel. I know I can do it in YaST2, but I can't get to YaST2 because the stupid bootloader doesn't work!! Haha.

    Anyways, thanks in advance!!

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: GRUB Ugh!!

    I take it you don't have the Suse 10.3 install DVD (full version) from which to boot to the installed Suse. If not you can boot from the super grub disk.

    Once your in, do this to restore Grub booting to the MBR:
    go to Yast --> System --> Boot Loader. The Grub configuration screen comes up with the Tab "Section Management" activated. In the lower right is a drop-down selector labelled "Other". Select from "Other" the option "Propose New Configuration" and then wait for Grub to analyse your partitions and display a new configuration. This may take a while. Important: When that finishes, activate the tab labelled "Boot Loader Installation" and select to "Boot from the Master Boot Record". [Yast will often default to booting from the root or boot partition rather than from the MBR but that's for experts only -- always choose the MBR.] Then click Finish to save the changes and install the reconfigured Grub into the hard drive's MBR. If you get a message that "The bootloader boot sector will be written to a floppy disk ......... don't bother with the floppy -- just click OK to proceed and install to the MBR. Reboot and you should be able to boot to openSUSE using the Grub menu screen.

    FFI: GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •