Results 1 to 6 of 6

Thread: SUSE 11.0 hard drive detection problems

  1. #1

    Default SUSE 11.0 hard drive detection problems

    ok heres the thing

    i downloaded the suse 64 bit dvd and tried to install it but it cannot pick up my hard drive on setup

    i know its not the computers fault because i had ubuntu and redhat enterprise linux 5 running on it just fine

    im thinking that its a kernel problem because ive had similar results with the newer kernels

    is there any way i can force the installation to recognize my hard drive or disable anything b4 installation, any help would be much appreciated

    heres my rig::
    AMD x2 4200+
    abit AN52 ATX mobo nForce520 chipset
    1 gb pc5300
    Disk Drive ST3320620AS (320 GB, 7200 RPM, SATA-II)
    nvidia 7600GT

  2. #2
    Join Date
    Jul 2008
    Location
    NJ, USA
    Posts
    43

    Default Re: SUSE 11.0 hard drive detection problems

    Can you please boot to another (Linux or LiveCD) OS and post the output of `lspci -v` and `lspci -n`.
    J. Antman
    Dedicated SuSE user since October, 2001 (7.3)
    http://www.jasonantman.com
    http://blog.jasonantman.com

  3. #3
    de_Selby NNTP User

    Default Re: SUSE 11.0 hard drive detection problems

    I've had what sounds like the exact same problem - I'm not able to boot to any version of the kernel after roughly 2.6.22.x. From what I can piece together from problems other people have been having I think it is related to AHCI and the nforce chipset causing an interrupt conflict - here's a thread about it

    Unable to boot from CD with AHCI enabled - Ubuntu Forums

    From what I've been reading you either need to pass the "pci=nomsi" argument to the kernel (which didn't seem to have any effect when I tried it) or disable AHCI altogether in the BIOS which would seem to be the right option, AHCI also causes a lot of problems with hard disk detection in windows vista. I tried passing "hwprobe=-modules.pata" too because that seemed to be suggested in most of the threads I've seen about this on forums without any explanation for what it acutally does.

    Turning off AHCI is a problem because it's not mentioned in any menus on the Phoenix bios that's on my Abit AN52 motherboard. I can't find any firmware updates for it either. Then I found this thread:

    Universal abit USA Forums - View Single Post - AN52 sata_ide deviceID (No AHCI)

    Where they say that the an52 doesn't acutally support AHCI at all.

    I'd really appreciate if someone could help here I really don't know how to get this working.

  4. #4
    de_Selby NNTP User

    Default Re: SUSE 11.0 hard drive detection problems

    Quote Originally Posted by tachyonX
    I think I know what's going on here, the drivers labeled 'sata-ide' in nforce520 (mcp65) package are actually for an AHCI controller, with device_id 044D. Even though an52 specs show it as an nforce520 board, the sata chip (or atleast the bios) doesn't support AHCI, only Raid (044C) & Ide (045D) modes . One might confuse sata-ide mode for ahci (as I did) but really this is just Legacy IDE emulation, with no support for sata features like only UDMA-5 (100MB/s instead of ~300MB/s ), no NCQ, no hotplug, etc, etc. Needless to say, this is awful.

    I wonder, does Abit have any NForce 5 mboard supporting ahci/sata-ide, or are they all crippled like this one ?
    that could explain the problem..

    So the linux kernel is trying to load a vanilla nforce 520 mcp65 driver for the controller, which doesn't work since that driver will try to use AHCI? Is there a way to explicity disable AHCI probing as a kernel parameter?

  5. #5

    Default Re: SUSE 11.0 hard drive detection problems

    i have a somewhat diff twist on this problem - on a clean installation of suse11 on an abit va-20 with western digital eide drive, the install detected the drive a /dev/sda rather than /hda.
    it works ok, and even fdisk -l thnks it's sda:
    # fdisk -l

    Disk /dev/sda: 320.0 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000152e8
    here's an excerpt from lspci:
    # lspci
    00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
    00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
    00:08.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev 81)
    00:09.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
    00:0a.0 Mass storage controller: Promise Technology, Inc. 20269 (rev 02)
    00:0f.0 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    no problems with previous 10.0,1 and 2.

    any thoughts?

  6. #6
    de_Selby NNTP User

    Default Re: SUSE 11.0 hard drive detection problems

    Ok, I finally got my installation working - the problem was actually that I was using a CD-RW as the boot cd, which causes problems when mounting - watch out for that one! A very confusing and frustrating problem. I still had to use the pci=nomsi kernel argument but everything went swimmingly after that

    wmmSuse your problem isn't actually a problem at all - the 'hdX' device naming convention was changed - now all hard disks are given /dev/sdX names. The convention is to label ide devices first so it goes like:

    sda = hda
    sdb = hdb
    sdc = hdc
    sdd = hdd

    and then if you have a SATA channel they are labeled from there. If there is no IDE channel as will happen in future they are just named normally.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •