Results 1 to 8 of 8

Thread: Lost audio along the way

  1. #1
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Lost audio along the way

    Hi all,

    I don't know where to look, but I lost all audio on my opensuse11.

    No bootup jingle, no music through amarok, nothing.

    Where can I look to fix this?

    I checked already the volume settings, and the mute too.

    Thanks.

    Heeter
    Linux Counter 475994

  2. #2
    Uwe Buckesfeld NNTP User

    Default Re: Lost audio along the way

    * Heeter,

    did you try configuring the sound card in Yast, or with "alsaconf" on the command line?

    Uwe

  3. #3
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: Lost audio along the way

    Well I am in Yast -> Hardware -> Sound -> Edit, but I don't kow what to do in there.

    I hit "reset" and rebooted, but nothing still happened

    Thanks,

    Heeter
    Linux Counter 475994

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: Lost audio along the way

    Quote Originally Posted by Heeter View Post
    I don't know where to look, but I lost all audio on my opensuse11. No bootup jingle, no music through amarok, nothing.
    Hey Heeter, try working your way through the openSUSE audio troubleshooting guide:
    SDB:AudioTroubleshooting - openSUSE

    if that doesn't work for you, please provide the output URL generated by copy and pasting this line into a terminal/xterm/konsole (this will run a diagnostic script):
    Code:
    wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh
    and also provide the output of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

  5. #5
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: Lost audio along the way

    Hi OldCPU

    Sorry it took so long to get back here.

    Here is the results of the first script: pastebin
    (You will have to scroll down a bit to see the results listed.)

    The next script: rpm -qa | grep alsa
    Code:
    alsa-utils-1.0.16-35.1
    alsa-plugins-1.0.16-57.1
    alsa-1.0.16-39.1
    alsa-oss-1.0.15-48.1
    alsa-firmware-1.0.16-24.1
    The next script: rpm -qa | grep pulse
    Code:
    libpulse0-0.9.10-0.pm.1
    The next script: rpm -q libasound2
    Code:
    libasound2-1.0.16-39.1
    The next script: uname -a
    Code:
    Linux linux 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 athlon i386 GNU/Linux
    The next script: cat /etc/modprobe.d/sound
    Code:
    options snd slots=snd-via82xx
    # Ssy1.g1iGDcBEfl1:VT8233/A/8235/8237 AC97 Audio Controller
    alias snd-card-0 snd-via82xx

    Thanks a million,

    Heeter
    Linux Counter 475994

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: Lost audio along the way

    Quote Originally Posted by Heeter View Post
    Sorry it took so long to get back here.

    Here is the results of the first script: pastebin
    I assume you still have no sound.

    Nothing obvious strikes me upon looking at that.

    What test were you using for the sound or no sound, criteria? Did you try the following as a test? (copy and paste it into an xterm/konsole):
    speaker-test -c2 -Ddefault -twav
    To "kill it" you need to press <CTRL><C> while its xterm/konsole has focus.

    Assuming no sound, some ideas, ... go into your mixer and try switching on Surround sound, moving associated volume bars up. ...Does that make a difference? If not, put the settings back to where they were.

    You could try remove libpulse0. ... and then reboot and test your sound.

    Did you try "alsaconf"? ie open up an xterm/konsole, and after typing "su" to get root permissions (entering root password), type: "alsaconf" (no quotes). Try to setup your sound. Then check your mixer and sound afterward.

    Finally, I noted you have dxs_support=5. You could try change that to 1 or some other value. Reference table is here:
    Code:
        dxs_support	- support DXS channels,
    		  0 = auto (default), 1 = enable, 2 = disable,
    		  3 = 48k only, 4 = no VRA, 5 = enable any sample
    		  rate and different sample rates on different
    		  channels
    		  [ VIA8233/C, 8235, 8237 only ]

  7. #7
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: Lost audio along the way

    Sorry OldCPU,

    I did forget to mention that there was still no sound.

    Before I continued checking what you told me to check, I downloaded a liveCD of Ubuntu, and ran that.

    There was no audio on that as well, which leads me to say that it is an actual hardware problem, not OpenSuse.

    At the moment, I do not have an extra audio card, to replace the onboard audio.

    I will be purchasing a new audio card tomorrow.


    Thanks an absolute million for sticking with me on this, OldCPU


    Heeter
    Linux Counter 475994

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: Lost audio along the way

    Quote Originally Posted by Heeter View Post
    There was no audio on that as well, which leads me to say that it is an actual hardware problem, not OpenSuse.
    Be certain to check the obvious solutions, like your cables.

    I've read of a user's sound stop working when the children were playing, pulled the cables out, and put them back in the wrong order, .... or the maid knocking the cables loose, ... etc ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •