Results 1 to 6 of 6

Thread: cant connect in opensuse 11 (gnome) and intel 3945

  1. #1

    Default cant connect in opensuse 11 (gnome) and intel 3945

    Hello everyone.

    I'm a newbie and I'm using adhoc mode with WEP encriptation, and I can find my network, but I cannot connect!

    It keeps asking me for the secret password. I use a 5 letters password, but when I set it to WEP 40/128 bits ASCII (which I think is correct - the adhoc uses WinXP, and in Windows it says only WEP, doesn't say if it's hexadecimal or whatever) it can't connect and when I try again it's always reset to WEP Hexadecimal, showing 10 numbers. Is it normal?

    I everytime reset it to ASCII, but it keeps changing back to hexadecimal, no matter what.

    Is there any way to fix this? I tried the solution using compat-wireless drivers, but it didn't work either. I used Ubuntu and it worked fine. So there must be a way...

    Thanks guys!

  2. #2
    techman2006 NNTP User

    Default Re: cant connect in opensuse 11 (gnome) and intel 3945

    Hi,

    Did you have enable the DHCP in your router or through whatever your connected to the internet as network manager try to connect using the DHCP mode only. Also what the tail -f /var/log/message ouytput is?
    Also try to connect using the auto mode so that the network manager to decide which mode to use.
    It may help you out.

  3. #3

    Default Re: cant connect in opensuse 11 (gnome) and intel 3945

    Hi techman2006, thanks for answering!

    Well, I don't know, I'll have to check that when I get home. I use a PC with Windows XP and a Encore ENLWI-G2 PCI card (in ad hoc mode). When I use Windows Vista my notebook connects normally. When I used Linux Mint 4.0 it connected perfectly too (I was using ipw drivers).

    The output of tail -f /var/log/messages is:
    Code:
    Senha: 
    Jun 25 18:11:43 suse-miguel kernel: atkbd.c: Use 'setkeycodes e006 <keycode>' to make it known.
    Jun 25 18:11:53 suse-miguel kernel: CPU0 attaching NULL sched-domain.
    Jun 25 18:11:53 suse-miguel kernel: CPU1 attaching NULL sched-domain.
    Jun 25 18:11:53 suse-miguel kernel: CPU0 attaching sched-domain:
    Jun 25 18:11:53 suse-miguel kernel:  domain 0: span 00000000,00000000,00000000,00000003
    Jun 25 18:11:53 suse-miguel kernel:   groups: 00000000,00000000,00000000,00000001 00000000,00000000,00000000,00000002
    Jun 25 18:11:53 suse-miguel kernel: CPU1 attaching sched-domain:
    Jun 25 18:11:53 suse-miguel kernel:  domain 0: span 00000000,00000000,00000000,00000003
    Jun 25 18:11:53 suse-miguel kernel:   groups: 00000000,00000000,00000000,00000002 00000000,00000000,00000000,00000001
    Jun 25 18:15:00 suse-miguel sudo:   miguel : TTY=pts/1 ; PWD=/home/miguel ; USER=root ; COMMAND=/usr/bin/tail -f /var/log/messages
    Thanks!

  4. #4

    Default Re: cant connect in opensuse 11 (gnome) and intel 3945

    Dude i'm having the same issue - but with an unsecured network. Sees it, but won't grab an IP and get me on. Very annoying. Same wireless card.

  5. #5
    Join Date
    Jun 2008
    Location
    Dublin, Ireland
    Posts
    298

    Default Re: cant connect in opensuse 11 (gnome) and intel 3945

    You could try the Traditional setup in YAST when setting up the network instead of KNetworkManager.. This will install KInternet. You will see a little plug icon on the taskbar. Then type the following commands as root:

    Open a terminal. Change to root access, type 'su' and password.
    Then do this:

    Bring up the network
    # ifconfig wlan0 up

    Scan for your wireless network.
    # iwlist wlan0 scan

    Associate your wireless network with the card
    # iwconfig wlan0 essid [your network name]

    Associate your WEP key
    # iwconfig wlan0 key [your key in hex]

    Try and connect
    # dhclient wlan0

    Try pinging Google
    If that works you should have a connection. You can also configure the network using KInternet.

    Hope this helps..
    /jlar

  6. #6

    Default Re: cant connect in opensuse 11 (gnome) and intel 3945

    Hi there!

    Well i tried it, and everything went fine, except for the last two parts... When I entered dhclient wlan0, it tried several adresses, but then it didn't connect (I'll put the full error message in a moment).

    It could find the adhoc, but it couldn't connect.

    Sigh, it's so frustrating =(

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •