Results 1 to 8 of 8

Thread: Numeric Keypad Broken

  1. #1

    Default Numeric Keypad Broken

    Installed OS 11.0 two days ago as upgrade from 10.3.
    Suddenly today my numeric keypad on my keyboard is dead (after working fine for years).
    I checked it on my old Window$ machine via KVM box and it works fine.

    Any suggestions?

    If I knew what the hardware profile is supposed to look like in Yast/x11 I could scout for the problem.
    BTW, this keyboard is listed as generic 104 key unit, which seems to have been fine in 10.2 and 10.3.

    Thanks in advance.

  2. #2
    grbaues NNTP User

    Default Re: Numeric Keypad Broken

    Hello

    I had exactly the same problem even worse as each time I
    touched the keypad gnome and the Xserver were crashing.
    What as working for me is the following :

    Open ControlCenter -> Hardware section -> Keyboard. This
    opens a window with multiple tabs

    Layout Tab :

    I have an non-listed IBM internet/multimedia type of keyboard
    but i don't care about the gimmicks so i choose as keyboard
    the generic 105 keys. But i don't think this is the important
    thing but the next one.

    Mouse Keys Tab :

    Uncheck "Allow to control the pointer using the keyboard"

    Once i made those changes i got my keypad back

    Hope this helps

    Bye

  3. #3

    Default Re: Numeric Keypad Broken

    Thanks for your response, grbaues.

    I cannot find a tab for "Allow to control the pointer using the keyboard" in the Keyboard Layout section of Yast.

    Mine only has two tabs "layout" and "Options".
    None of the Options includes the "Allow to control the pointer using the keyboard".

    I also looked in the Mouse section.
    No success there.

    Since my last post I have done a clean re-install of openSUSE 11.0. (that fixed a few things but not this)

    I again checked the keypad on my window$ machine - it works.
    Went into the BIOS on this machine (it is Linux only) numkeys is set to ON.
    I have been to the config files in this machine.
    Numkeys was set to AUTO.
    I set it to ON.
    Still no success.
    Set it back to AUTO.
    Still no success.

    So, am I in the right place?
    Or.... is this a difference between KDE and Gnome?

    Thanks.

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Numeric Keypad Broken

    Steve 45 wrote:

    >
    > Thanks for your response, grbaues.
    >
    > I cannot find a tab for "Allow to control the pointer using the
    > keyboard" in the Keyboard Layout section of Yast.
    >
    > Mine only has two tabs "layout" and "Options".
    > None of the Options includes the "Allow to control the pointer using
    > the keyboard".
    >
    > I also looked in the Mouse section.
    > No success there.
    >
    > Since my last post I have done a clean re-install of openSUSE 11.0.
    > (that fixed a few things but not this)
    >
    > I again checked the keypad on my window$ machine - it works.
    > Went into the BIOS on this machine (it is Linux only) numkeys is set to
    > ON.
    > I have been to the config files in this machine.
    > Numkeys was set to AUTO.
    > I set it to ON.
    > Still no success.
    > Set it back to AUTO.
    > Still no success.
    >
    > So, am I in the right place?
    > Or.... is this a difference between KDE and Gnome?
    >
    > Thanks.
    >
    >


    Option is found in KDE Control Center (PErsonal Settings)

    Hardware -> Mouse -> Mouse Navigation

    You can enable / disable it from there.

    There is also a hotkey to toggle it on and off, I find it annoying and usually
    remove the hot-key definition so I don't (somehow) accidently hit it.

    ALT-F12 will (by default install) toggle MouseKeys on/off

    To remove the hotkey definition, look in 'Regional & Accessibility' ->
    Keyboard Shortcuts -> Shortcut Schemes Tab, under 'Miscellaneous' section.

    --
    L R Nix
    lornix@lornix.com

  5. #5

    Talking Re: Numeric Keypad Broken

    L R Nix,

    The KDE config fixed the problem.
    1234567890 ! < with keypad.

    Thank you, Thank you, Thank you.

    I will have to cancel a bugzilla item.

    Best regards,

    Steve_45

  6. #6

    Default Re: Numeric Keypad Broken

    Quote Originally Posted by lornix View Post
    Option is found in KDE Control Center (PErsonal Settings)

    Hardware -> Mouse -> Mouse Navigation

    You can enable / disable it from there.

    There is also a hotkey to toggle it on and off, I find it annoying and usually
    remove the hot-key definition so I don't (somehow) accidently hit it.

    ALT-F12 will (by default install) toggle MouseKeys on/off

    To remove the hotkey definition, look in 'Regional & Accessibility' ->
    Keyboard Shortcuts -> Shortcut Schemes Tab, under 'Miscellaneous' section.
    Your advice helped, even after 2 years!

  7. #7
    Join Date
    Aug 2008
    Location
    Scotland, UK
    Posts
    242

    Default Re: Numeric Keypad Broken

    Quote Originally Posted by SergeniuS View Post
    Your advice helped, even after 2 years!
    Make it 3....
    Alastair Scott

    openSUSE LEAP

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Numeric Keypad Broken

    On 03/28/2011 08:36 AM, aescott wrote:
    >> Your advice helped, even after 2 years!

    >
    > Make it 3....


    i wish she (lornix) were still here, but alas she is not..
    because of her experience/knowledge i asked her to come back, but no
    dice..

    --
    CAVEAT: http://is.gd/bpoMD
    Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
    [NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •