Results 1 to 4 of 4

Thread: Running from BASH

  1. #1

    Default Running from BASH

    I have recently upgraded from SUSE 10.3 to 11 (fresh install, kept /home, created new home directory and moved across certain stuff from my old home directory, but maintaining my UID).

    When I try and run BOINC from a shell (in konsole) I get:

    Code:
    BOINC/run_client: line 1: /home/edw186/BOINC/boinc: cannot execute binary file
    I get the same if I try to run the boinc executable directly. Anyone know why?

    I does appear that some default bash settings have been changed because I have to hit tab twice to show up autocomplete options when there is more than one possibility (which is annoying too).

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Running from BASH

    Do a:

    mount

    and look at the options of the mount for the partition containing your home. They may include an explicit or more likely an implicit noexec option. You have to look at the man page to see which options imply noexec.

  3. #3
    ab@novell.com NNTP User

    Default Re: Running from BASH

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    What is the output of `ls -al /home/edw186/BOINC/boinc` ? What about
    `file /home/edw186/BOINC/boinc` ? What is on line 1 of run-boinc?

    Good luck.





    solanum wrote:
    | I have recently upgraded from SUSE 10.3 to 11 (fresh install, kept
    | /home, created new home directory and moved across certain stuff from
    | my old home directory, but maintaining my UID).
    |
    | When I try and run BOINC from a shell (in konsole) I get:
    |
    |
    | Code:
    | --------------------
    | BOINC/run_client: line 1: /home/edw186/BOINC/boinc: cannot execute
    binary file
    | --------------------
    |
    |
    | I get the same if I try to run the boinc executable directly. Anyone
    | know why?
    |
    | I does appear that some default bash settings have been changed because
    | I have to hit tab twice to show up autocomplete options when there is
    | more than one possibility (which is annoying too).
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIYefB3s42bA80+9kRApwvAJ4sdEK81cLz9R9W0hXLNMCQYVwDtwCfZiK6
    Y8Br2YgxIplE4qzhvm0mBQ4=
    =Bl2t
    -----END PGP SIGNATURE-----

  4. #4

    Default Re: Running from BASH

    Quote Originally Posted by ken_yap View Post
    Do a:

    mount

    and look at the options of the mount for the partition containing your home. They may include an explicit or more likely an implicit noexec option. You have to look at the man page to see which options imply noexec.
    Not in front of that PC right now, but I exec other binaries from /home (crossover) so I don't think this can be the case.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •