Results 1 to 10 of 10

Thread: Question regarding system Time

  1. #1
    viervonacht NNTP User

    Post Question regarding system Time

    Hello
    I'm kind of new to opensuse. I installed Opensuse 11 with KDE 4 along with Windows XP.

    Whenever I start Opensuse my System Time gets set +2h. I'm from germany so i set Berlin as lokal time zone.

    Does someone know how to get opensuse not to change the system time?

    mfg neyvin

  2. #2

    Default Re: Question regarding system Time

    On Tue, 24 Jun 2008 21:16:03 +0000, viervonacht wrote:

    > Hello
    > I'm kind of new to opensuse. I installed Opensuse 11 with KDE 4 along
    > with Windows XP.
    >
    > Whenever I start Opensuse my System Time gets set +2h. I'm from germany
    > so i set Berlin as lokal time zone.
    >
    > Does someone know how to get opensuse not to change the system time?
    >
    > mfg neyvin


    you set your time in bios correct ? then set to region europe and country
    germany and Hardware clock set to UTC ??

  3. #3
    Tilman Schmidt NNTP User

    Default Re: Question regarding system Time

    viervonacht schrieb:
    > I'm kind of new to opensuse. I installed Opensuse 11 with KDE 4 along
    > with Windows XP.
    >
    > Whenever I start Opensuse my System Time gets set +2h. I'm from germany
    > so i set Berlin as lokal time zone.
    >
    > Does someone know how to get opensuse not to change the system time?


    Don't set the "Hardware clock is UTC" option. Windows always treats the
    hardware clock as having local time, so if you want Linux to coexist
    with Windows you have to tell it to do the same.

    HTH
    T.

  4. #4
    viervonacht NNTP User

    Default Re: Question regarding system Time

    I didn't set the hardware clock is using UTC opotion. The hardware Clock is using local time. And now i found the Yast option to not change the hardware clock. So I'm still off 2h but the time in windows is correct.
    I think i have to tell opensuse the hardware clock is the local time so it won't add the 2h. But i have no idea how to do it.
    Witch configuration file keeps the time settings? Maybe there is something wrong...

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Question regarding system Time

    as stated: Windows ALWAYS assumes hardware clock is set to your local
    time....if you insist on using windows you _have_ to live with that...

    to tell SuSE v 10.3 (which i have, and maybe v 11 which you have) that
    you MUST set the hardware clock to local time (to keep Bill & Redmond
    happy):

    - open yast (give root pass)
    - select System > Date and Time
    - in the window that opens, select your region and time zone
    - then, near the bottom locate the place to select UTC *or* local time
    - set it to "Local Time" and press accept..
    - be happy Linux gives you the choice (and sad that Winders does not)

    DenverD

  6. #6
    viervonacht NNTP User

    Default Re: Question regarding system Time

    First of all thank you for all your help.
    But I couldnt solf my problem jet.

    I didn't put the cross at computer is using UTC so opensuse is using the hardware clock as local time.
    And my problem is that even with me setting the correct time every boot the system time is off by 2 hours. So my system time is always my hardware time + 2h.

    So my question is were can i change the settings besides using yast.

    @DenverD
    I'm a great fan of Guild Wars and my system is unfortunately not able to run it sufficient under wine so i have to keep xp

  7. #7
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Question regarding system Time

    have you tried using an NTP server to help keep the correct time ?

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  8. #8
    Tilman Schmidt NNTP User

    Default Re: Question regarding system Time

    viervonacht schrieb:
    > I didn't put the cross at computer is using UTC so opensuse is using
    > the hardware clock as local time.
    > And my problem is that even with me setting the correct time every boot
    > the system time is off by 2 hours. So my system time is always my
    > hardware time + 2h.
    >
    > So my question is were can i change the settings besides using yast.


    Have a look at the file /etc/sysconfig/clock. It's pretty well commented.
    Also try running the commands "hwclock --utc" and "hwclock --localtime"
    from a command line as root. Which one gives the correct time?

    HTH
    T.

    --
    Tilman Schmidt t.schmidt@phoenixsoftware.de
    Phoenix Software GmbH www.phoenixsoftware.de
    Adolf-Hombitzer-Str. 12 Amtsgericht Bonn HRB 2934
    53227 Bonn, Germany Geschftsfhrer: W. Griel

  9. #9
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Question regarding system Time

    On 06/25/2008 viervonacht wrote:
    > And my problem is that even with me setting the correct time every
    > boot the system time is off by 2 hours. So my system time is always
    > my hardware time + 2h.


    Wrong time zone configured? Compare the output of "date" with your timezone.

    Uwe

  10. #10
    Join Date
    Mar 2008
    Location
    Toronto, Canada
    Posts
    305

    Default Re: Question regarding system Time

    viervonacht wrote:

    > And my problem is that even with me setting the correct time every boot
    > the system time is off by 2 hours. So my system time is always my
    > hardware time + 2h.
    >
    > So my question is were can i change the settings besides using yast.


    I'm in a similar boat, if it makes you feel any better.

    I'm Toronto, Canada, and my time was always off by -4h when booting. Seems to me that there is something wrong with process for managing time zones, given the similarity to your problem. Never experienced this in any previous version of openSUSE. I got around it by enabling NTP, but that's not really a fix. I have to admit that I've been lazy and haven't opened a bug report yet, but it's on my ever-increasing list of things-to-do...

    Cheers,
    KV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •