Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: No sound through Headphone output

  1. #1

    Unhappy No sound through Headphone output

    Hi,

    I have an Asus laptop (A6Va) with an Intel Sound Card.

    The sound card works well with the snd-hda-intel driver.

    When I plug a headset in the headphone jack output the sound from the built-in speakers is muted but there is no sound into the headset.

    I manage to get sound through the headset with this :
    In Yast sound configuration :
    - I edit the sound card line
    - Set "auto" in the "model" option (previously empty)
    - Then I press "Next"
    - I reboot the sound system (choose "Yes" to the question I was asked)

    At this stage the jack output works well

    But if I press "Finish" (to save the parameters I just set) the problems come back ! (and when I came back to the Yast Configuration Panel the "auto" parameter I just set is gone...)

    What's the matter ? What do I do wrong ?

    Thanks for your help

    PS: excuse my poor English, I'm French
    PPS: I use OpenSUSE 11.0
    Last edited by strash; 24-Jun-2008 at 14:08. Reason: add some details

  2. #2
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    29

    Post Re: No sound through Headphone output

    This is a bug in Yast, you have to add a line to /etc/modules.d/sound by hand:

    open a konsole and enter:

    Code:
    su (and give root password)
    echo "options snd-hda-intel model=auto" >> /etc/modules.d/sound
    rcalsasound restart
    after that (if you're using KDE) press alt+F2 and enter "KMix" to restart the mixer tray applet.

  3. #3

    Thumbs up Re: No sound through Headphone output

    It's working well, thanks !

    I come from Ubuntu and I found that a gui to solve this (recurrent) problem on my laptop was a good + for OpenSUSE... but unfortunately it was buggy... Hope this bug will be solved soon !

  4. #4
    Areldyb NNTP User

    Default Re: No sound through Headphone output

    Sorry to revive such an old thread, but I figured it was better than starting another one on the same topic.

    I have the same problem, but following the above steps don't help. For some reason, the directory /etc/modules.d doesn't exist on my system (the equivalent directory, as far as I can tell, is /etc/modprobe.d), but manually adding the line to /etc/modprobe.d/sound has no effect.

    Can anyone help me out?

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: No sound through Headphone output

    You need to be sure of your model before adding any module parameters. From a console, execute these commands:

    cat /etc/modprobe.d/sound
    hwinfo --sound (you need to be root to execute this one)

    Copy/paste output here if you need more help.

    Did you hand edit the file as root?

  6. #6
    Areldyb NNTP User

    Default Re: No sound through Headphone output

    I tried going through YaST first, but it still has that bug in it, so yes, I edited it manually as root. The changes show up in YaST, as expected, but the problem's still there.

    cat /etc/modprobe.d/sound returns:
    Code:
    options snd slots=snd-hda-intel
    # GA8e.OxOKbkWU0j9:VIA High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=auto
    The fourth line was what I added in, per the instructions above.

    hwinfo --sound returns:
    Code:
    09: PCI 201.0: 0403 Audio device                                
      [Created at pci.310]
      UDI: /org/freedesktop/Hal/devices/pci_1106_3288
      Unique ID: GA8e.OxOKbkWU0j9
      Parent ID: HSco.OEBK5K+PTbB
      SysFS ID: /devices/pci0000:00/0000:00:13.0/0000:02:01.0
      SysFS BusID: 0000:02:01.0
      Hardware Class: sound
      Model: "VIA High Definition Audio Controller"
      Vendor: pci 0x1106 "VIA Technologies, Inc."
      Device: pci 0x3288 "VIA High Definition Audio Controller"
      SubVendor: pci 0x1509 "FIRST INTERNATIONAL Computer Inc"
      SubDevice: pci 0x2f07 
      Revision: 0x10
      Driver: "HDA Intel"
      Driver Modules: "snd_hda_intel"
      Memory Range: 0xd1000000-0xd1003fff (rw,non-prefetchable)
      IRQ: 17 (19674 events)
      Module Alias: "pci:v00001106d00003288sv00001509sd00002F07bc04sc03i00"
      Driver Info #0:
        Driver Status: snd_hda_intel is active
        Driver Activation Cmd: "modprobe snd_hda_intel"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #12 (PCI bridge)

  7. #7
    Areldyb NNTP User

    Default Re: No sound through Headphone output

    Replacing "auto" with the model name listed by hwinfo doesn't work either, if that's what I'm supposed to pick up on. This is embarrassing...

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound through Headphone output

    Quote Originally Posted by Areldyb View Post
    Sorry to revive such an old thread, but I figured it was better than starting another one on the same topic.

    I have the same problem, but following the above steps don't help. For some reason, the directory /etc/modules.d doesn't exist on my system (the equivalent directory, as far as I can tell, is /etc/modprobe.d), but manually adding the line to /etc/modprobe.d/sound has no effect.

    Can anyone help me out?
    I too do not have an /etc/modules.d directory. Makes me think its a typo.

    I also confess this is the first I've read of putting "rcalsasound restart" in the /etc/modprobe.d/sound file. If rcalsasound restart helps, then the place I typically recommend for it is in the /etc/init.d/boot.local file.

    I also find "hwinfo --sound" falls short of providing the information I like to have when helping a user with their sound. ... I like to know
    * mixer settings
    * kernel information
    * opensuse version information
    * hardware audio codec information
    * various software configuration information
    ... and I find the easiest way to get that is to run either of the scripts from here: openSUSE - Scripts_to_run_to_obtain_detailed_information on sound
    ... I think its possible the alsainfo.sh script may even find its way to be included with future versions of alsa.

    Anyway, I would like to try help here (if moving the location of "rcalsasound restart" doesn't help), but can you please run this tsalsa script (with your PC connected to the internet copy and paste this line into an xterm/konsole):
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    when it prompts for a password, enter the root password. When it is complete, it will also give you a URL. Please post that URL here.

    .... please also provide output of running the following one line at a time in an xterm/konsole:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2


    are you a KDE4, KDE-3.5x, or Gnome user?

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: No sound through Headphone output

    I also confess this is the first I've read of putting "rcalsasound restart" in the /etc/modprobe.d/sound file. If rcalsasound restart helps, then the place I typically recommend for it is in the /etc/init.d/boot.local file.
    I don't think anyone suggested this. The following was suggested a few posts back:

    su (and give root password)
    echo "options snd-hda-intel model=auto" >> /etc/modules.d/sound
    rcalsasound restart

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound through Headphone output

    Quote Originally Posted by deano_ferrari View Post
    I don't think anyone suggested this. The following was suggested a few posts back:
    Code:
    su (and give root password)
    echo "options snd-hda-intel model=auto" >> /etc/modules.d/sound
    rcalsasound restart
    True, but never-the-less, the way I read this thread, it was attempted! I also am not aware of an /etc/modules.d directory on openSUSE-10.3 nor 11.0.

    I only have KDE, is this Gnome specific? or is it a typo? [ we all make typos ]

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •