Results 1 to 9 of 9

Thread: Language Keyboard Layouts

  1. #1

    Default Language Keyboard Layouts

    I am using Opensuse 11.0 KDE and in OOo I am unable to access and use foreign language keyboards. With Ubuntu Gnome OOo it was done by going to System/Preferences/Keyboards/Layouts. I have right clicked at the bottom of the page on English and obtained a window which looks like it is intended for the purpose of changing the language keyboard, but it doesn't work for me. I have added the names of several languages there but I still get only English when I type. I get a similar window when I click on Tools/Language, but that doesn't work either. Please note that this is not an issue of spellchecking; I want to be able to type foreign characters like the German umlaut.
    Help please.

  2. #2

    Default Re: Language Keyboard Layouts

    I have gone to Applications/System/Language and made German, French, and Greek secondary languages. The computer then downloaded about 100 files, but I still cannot type in any language other than English.

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Language Keyboard Layouts

    Go to Control Centre -> Regional -> Keyboard settings and install the languages there.

    A flag will appear in the system tray. Clicking on it will cycle through your chosen languages.

  4. #4
    aristocats NNTP User

    Thumbs up Re: Language Keyboard Layouts

    I had the same problem and I solved it by accident, by right clicking on the panel/(task bar in Win), chose Add to Panel/Keyboard Indicator. I'm on Gnome Desktop, Opensuse 11.0.

    BTW, could you add more than 4 keyboard layouts? I need to have 7!

  5. #5

    Default Re: Language Keyboard Layouts

    I have an another problem. My Old files on a reiser partition created by a Suse 9.0 cant be open in OpenSuse 11.0 when some // are in the name. i can only del with root.

    how can i rename all files in readable files?

  6. #6

    Default Re: Language Keyboard Layouts

    Quote Originally Posted by john_hudson View Post
    Go to Control Centre -> Regional -> Keyboard settings and install the languages there.

    A flag will appear in the system tray. Clicking on it will cycle through your chosen languages.
    I read somewhere about Control Center but have not been able to find it in KDE. Does it only exist in Gnome?
    What I have done is to go to Administrator Settings/System/Language and then selected a primary language and 3 secondary languages, but this has not allowed me to type in these secondary languages. Please let me know how to get to Control Center if there is one in 11.0KDE.

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Language Keyboard Layouts

    The Control Centre may not have been ported to KDE 4; if not, log out and select a KDE 3.5 session and log in again. (If you haven't installed KDE 3.5, you may need to in order to access the Keyboard Layouts - I don't know as I haven't installed the SUSE 11 KDE 4 option).

    Once you have used the KDE 3.5 Control Centre, you can close the session and log into a KDE 4 session where you should find the flag in the system tray. (Possibly two as two show up in KDE 4 on my (earlier) setup - however, one will work as expected and the other will nearly work - you will soon find out which one to use).

    It is recommended that you only have three keyboard layouts installed at any one time because they take up memory. However, I currently have five installed and it doesn't seem to cause any problems.

    It is possible you can economise; for example, the Polish keyboard is so similar to the English keyboard, if you have Polish as one of your languages, you could probably do without the English keyboard.

  8. #8

    Default Re: Language Keyboard Layouts

    I gave up on KDE and installed 11.0 Gnome and am using that now, but with no more success than before. I have gone to control center and language, set the primary language to English and chosen 3 secondary languages, but I still cannot type in these secondary languages. Or rather I can type in them only if I make them the primary language which is what I have done now with German . I can get by with just 3 keyboards, but it is essential that I be able to toggle through them somehow quickly, and not have to change the primary language setting. I am thinking of switching to 10.3 Gnome. But so far I am very dissatisfied with Opensuse. I may have to go back to Ubuntu 8.04 in which the language keyboards (4 of them) worked quite well: that is, one can easily toggle through them.

    I would like to hear from someone using Opensuse 11.0 Gnome who has successfully installed several language keyboards and who can toggle through by using the language setting in OOo at the bottom of the page or by clicking on Tools-Languages at the top of the page. My understanding is that that was possible with 10.3 Gnome and should be possible with 11.0 Gnome.

  9. #9

    Default Re: Language Keyboard Layouts

    Quote Originally Posted by aristocats View Post
    I had the same problem and I solved it by accident, by right clicking on the panel/(task bar in Win), chose Add to Panel/Keyboard Indicator. I'm on Gnome Desktop, Opensuse 11.0.

    BTW, could you add more than 4 keyboard layouts? I need to have 7!
    Ι think you have just solved my problem: adding the Keyboard indicator is the solution. 4 is probably the maximum you can have at any one time; it was with Ubuntu 8.04, but it's not that hard to change your secondary languages. Do you really need 7 at the same time? Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •