Results 1 to 9 of 9

Thread: Amarok cannot fetch covers from Amazon

  1. #1

    Question Amarok cannot fetch covers from Amazon

    Hello everybody,
    I have a problem here, amarok fetches no covers from Amazon..
    My albums are tagged correctly.
    I read somewhere that Amarok had such a problem but it was fixed.
    So, how can I fix it? Any ideas?

    Thanks a lot in advance

  2. #2
    Uwe Buckesfeld NNTP User

    Default Re: Amarok cannot fetch covers from Amazon

    * geo909,

    try the Amarok from the Packman repository. That's the one I use and it downloads covers just fine.

    Uwe

  3. #3
    Join Date
    Jun 2008
    Location
    Boston MA area
    Posts
    61

    Default Re: Amarok cannot fetch covers from Amazon

    Yeah, Amarok v. 1.4.8 (I think) could fetch covers due to a change in the Amazon API. Make sure you have 1.4.9 at least.

  4. #4

    Default Re: Amarok cannot fetch covers from Amazon

    Hi, thanks for answering.

    Well, is that a different version from the one that came with 10.3?!

    Hmm..
    Actually I cannot remember.. Amarok comes by default in 10.3, right? I cannot remember installing it..

  5. #5
    Uwe Buckesfeld NNTP User

    Default Re: Amarok cannot fetch covers from Amazon

    On 06/24/2008 geo909 wrote:
    > Well, is that a different version from the one that came with 10.3?!


    Not sure about the version, but it *is* different :-)

    > Hmm.. Actually I cannot remember.. Amarok comes by default in 10.3,
    > right? I cannot remember installing it..


    Yes.

    Uwe

  6. #6
    Join Date
    Jun 2008
    Location
    Bowling Green, KY
    Posts
    157

    Default Re: Amarok cannot fetch covers from Amazon

    Reading what you posted here Amarok probably got updated to 1.4.8 two months ago when you did your last update, because if memory serves, that was around the time the bugged version of Amarok was out. Once you get amarok updated, all should be fine.

    Out of curiosity, could you post what version of amarok you are using by going to the help menu in amarok, and clicking about amarok?
    lysdestic@suseforums:~>make install --not-war

  7. #7
    il_volpe NNTP User

    Thumbs up Re: Amarok cannot fetch covers from Amazon

    I had exactly the same issue. As recommended, I used smart to install the "amarok-packman" meta package from the Packman repo, and all is working fine now.

    Thanks Uwe, for posting the fix

  8. #8

    Default Re: Amarok cannot fetch covers from Amazon

    Hi again,
    the package management fails again on this.
    Here's what I do
    Code:
    jorge@linux-kupy:~> sudo zypper install amarok-packman
    root's password:
    * Reading repository 'X11:XGL' cache
    * Reading repository 'Main Repository (OSS)' cache
    * Reading repository 'openSUSE:Factory' cache
    * Reading repository 'openSUSE-10.3-Updates' cache
    * Reading repository 'WINE' cache
    * Reading repository 'openSUSE BuildService - Mozilla' cache
    * Reading repository 'Main Repository (NON-OSS)' cache
    * Reading repository 'Packman Repository' cache
    * Reading repository 'openSUSE BuildService - KDE:Community' cache
    * Reading repository 'openSUSE:10.3' cache
    * Reading repository 'openSUSE BuildService - OpenOffice.org' cache
    * Reading installed packages [100%]
    
    
    Problem: amarok-packman cannot be installed due to missing dependencies
      There are no installable providers of amarok-libvisual == 1.4.9.1-103.pm.1 for amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
    === amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] ===
        amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] will be installed by the user.
        bundle-lang-kde-ru-11.0-125.noarch[openSUSE:Factory] is needed by amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (amarok-lang == 1.4.9.1-103.pm.1)
    
     Solution 1: Install amarok-libvisual although it would change the vendor
      amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] provides this dependency, but would change the vendor of the installed item
     Solution 2: do not install amarok-packman
      do not install amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
     Solution 3: Ignore this requirement just here
    number, (r)etry or (c)ancel> 1
    Applying solution 1
    2 Problems:
    Problem: amarok-libvisual cannot be installed due to missing dependencies
    Problem: amarok-packman cannot be installed due to missing dependencies
    
    Problem: amarok-libvisual cannot be installed due to missing dependencies
      There are no installable providers of amarok == 1.4.9.1-103.pm.1 for amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
    === amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] ===
        amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] is needed by amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (amarok-libvisual == 1.4.9.1-103.pm.1)
        xorg-x11-libX11-7.2-75.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libX11.so.6)
        libstdc++42-4.2.1_20070724-17.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libstdc++.so.6(GLIBCXX_3.4))
        xorg-x11-libxcb-7.2-51.2.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libxcb.so.1)
        xorg-x11-libXau-7.2-54.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libXau.so.6)
        libgcc42-4.2.1_20070724-17.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libgcc_s.so.1)
        SDL-1.2.12-26.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libSDL-1.2.so.0)
        ncurses-5.6-41.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libncurses.so.5)
        aalib-1.4.0-385.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libaa.so.1)
        gpm-1.20.1-388.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libgpm.so.1)
        libvisual-0.4.0-85.i586 is needed by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libvisual-0.4.so.0)
        atom:amarok-libvisual-1.4.7-37.4.i586 will be evaluated for installation (freshened) by amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (amarok-libvisual == 1.4.9.1-103.pm.1)
    
     Solution 1: Install amarok although it would change the vendor
      amarok-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] provides this dependency, but would change the vendor of the installed item
     Solution 2: do not install amarok-libvisual
      do not install amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
     Solution 3: Ignore this requirement just here
    number, (r)etry or (c)ancel> 1
    Applying solution 1
    
    Problem: amarok-packman cannot be installed due to missing dependencies
      There are no installable providers of amarok-xine == 1.4.9.1-103.pm.1 for amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
    === amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] ===
        amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] will be installed by the user.
        bundle-lang-kde-ru-11.0-125.noarch[openSUSE:Factory] is needed by amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (amarok-lang == 1.4.9.1-103.pm.1)
        amarok-libvisual-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] is needed by amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (amarok-libvisual == 1.4.9.1-103.pm.1)
    
     Solution 1: Install amarok-xine although it would change the vendor
      amarok-xine-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] provides this dependency, but would change the vendor of the installed item
     Solution 2: do not install amarok-packman
      do not install amarok-packman-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
     Solution 3: Ignore this requirement just here
    number, (r)etry or (c)ancel> 1
    Applying solution 1
    3 Problems:
    Problem: No valid solution found with just resolvables of best architecture.
    Problem: libtunepimp5-mad cannot be installed due to missing dependencies
    Problem: libtunepimp5-mp4 cannot be installed due to missing dependencies
    
    Problem: No valid solution found with just resolvables of best architecture.
      With this run only resolvables with the best architecture have been regarded.
    Regarding all possible resolvables takes time, but can come to a valid result.
     Solution 1: Make a solver run with ALL possibilities.
      Regarding all resolvables with a compatible architecture.
    number, (r)etry or (c)ancel> 1
    Applying solution 1
    
    Problem: libtunepimp5-mad cannot be installed due to missing dependencies
      There are no installable providers of libtunepimp5 == 0.5.3-100.pm.7 for libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
    === libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] ===
        libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] is needed by amarok-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libtunepimp5-mad)
        libexpat1-2.0.1-24.i586 is needed by libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libexpat.so.1)
        libcurl4-7.16.4-16.2.i586 is needed by libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libcurl.so.4)
        fftw3-3.1.2-62.i586 is needed by libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libfftw3.so.3)
        libmusicbrainz4-2.1.5-3.i586 is needed by libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libmusicbrainz.so.4)
        libofa-0.9.3-60.i586 is needed by libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libofa.so.0)
    
     Solution 1: Install libtunepimp5 although it would change the vendor
      libtunepimp5-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] provides this dependency, but would change the vendor of the installed item
     Solution 2: do not install libtunepimp5-mad
      do not install libtunepimp5-mad-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
     Solution 3: Ignore this requirement just here
    number, (r)etry or (c)ancel> 1
    Applying solution 1
    
    Problem: libtunepimp5-mp4 cannot be installed due to missing dependencies
      There are no installable providers of libtunepimp5 == 0.5.3-100.pm.7 for libtunepimp5-mp4-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
    === libtunepimp5-mp4-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] ===
        libtunepimp5-mp4-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] is needed by amarok-1.4.9.1-103.pm.1.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] (libtunepimp5-mp4)
    
     Solution 1: Install libtunepimp5 although it would change the vendor
      libtunepimp5-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] provides this dependency, but would change the vendor of the installed item
     Solution 2: do not install libtunepimp5-mp4
      do not install libtunepimp5-mp4-0.5.3-100.pm.7.i586[http://ftp.skynet.be/pub/packman/suse/10.3/]
     Solution 3: Ignore this requirement just here
    number, (r)etry or (c)ancel> 1
    Applying solution 1
    As you can see I have chosen 1 for all the questions.

    After the last line, zyppers stays like that for ages... Nothing happens.

  9. #9
    il_volpe NNTP User

    Default Re: Amarok cannot fetch covers from Amazon

    I now have the same issue with dependencies for the packman version using OpenSuSE 11.0
    Still fine on my laptop using 10.3, unfortunately I haven't been able to install the packman meta-package using YAST or smart under 11.0 due to similar if not identical dependancy issues. I'm not very good at resolving them however, and personally am considering wiping my desktop and sticking with 10.3 for now, which is very good and easier to resolve problems with at the moment. I guess my technical knowledge is insufficient for bleeding edge...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •