Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: smb protocol unexpectedly stopped

  1. #1

    Unhappy smb protocol unexpectedly stopped

    Can't browse smb schares with konqueror. I have a disk connectted to my router, when i browse with smb://192.x.x.x i see the two folders on my disk but when accessing them i get the message : The process for the protocol smb: / / 192.x.x.x stopped unexpectedly. I get this in suse 11 in 10.3 no problem. I see in other treads this is a common problem for suse 11 but i haven't found any solution yet. I realy need this to work, everything else is just working fine. Tried downgrading samba but i get an error saying something about an invalid key.
    No solution for this ?

  2. #2
    Join Date
    Jun 2008
    Location
    Bowling Green, KY
    Posts
    157

    Default Re: smb protocol unexpectedly stopped

    Similar issue here. If I try to browse the samba shares in konqueror I get a firewall error, even though samba is allowed in the firewall. When I disable the firewall (which I shouldn't have to do) it actually shows me the workgroup, but I get a server timeout when I try to browse the workgroup.

    The odd thing is, if I type smb://[share ip] I can browse just fine, whether the firewall is on or not.
    lysdestic@suseforums:~>make install --not-war

  3. #3

    Default Re: smb protocol unexpectedly stopped

    I upgraded 10.3 to 11 and i have te same problem. I think it its something to do with Kde4. Can't even mount my drive with the mount command.
    This makes me sad...is there nothing to fix this or should i want for some upgrade ?

  4. #4

    Default Re: smb protocol unexpectedly stopped

    I've just make a fresh install of suse 11 with Kde3 and the problem is still there. So nothing to do with Kde4. No one to help please ?

  5. #5
    Join Date
    Jun 2008
    Location
    Bangalore, India
    Posts
    20

    Default Re: smb protocol unexpectedly stopped

    Guess what? Even I have face the same SMB problem!

    I too did not have a problem using 10.2 office network. But now that I have installed openSUSE 11 (KDE4) I'm facing "timeout" issues for my network. Earlier in KDE4 I couldn't even see my office network through SAMBA, but once I installed KDE 3.5 and I could finally SEE the network and even got access to it once.

    But then, whenever I logged-on to the server, I kept getting the dreaded "Timeout on server" message. I still see my network folders, but I can't use them. I have installed almost every recommended samba file I should (except cifs_mount, which I can't seem to find)

    But to be honest, in openSUSE 10.2, sometimes I would get the message "Timeout on server" which would go away when I restarted. No such luck here.

    I only just figured out how to print on openSUSE 11, and I have no problem using the internet, so I can connect to the network,it's just that I can't use the data foldes.

    I've also "unwisely" disabled my firewall (because that's what I had to do in openSUSE 10.2 to get it to work). But even now there's no luck.

    Would love some help here as well.

    http//alternativenayk.wordpress.com
    Last edited by nayk92; 26-Jun-2008 at 21:30. Reason: typo and added information

  6. #6
    Join Date
    Jun 2008
    Location
    Bangalore, India
    Posts
    20

    Default Re: smb protocol unexpectedly stopped

    OK, that's strange. I just wrote the previous post after going through Swerdna's how-to... which was quite complex and perhaps not all relevant to me, because I could already "SEE" the network and had been able to browse, it's just that I was "kicked out" by the timeout message.

    Anyway, I tried to logging in again, this time changing my login from WORKGROUP/myname and PASSWORD to myname and PASSWORD and guess what, it worked. After putting Swerdna's how-to in action, I had changed the workgroup to the right name of workgroup so I guess in the SMB login/ password I didn't need to put the workgroup in.

    But I'm not sure whether my problem is solved... because I dread the timeout message popping up again; but if it comes up again or not, I'll post it here.

    I think the command... "rcnmb restart" and "rcsmb restart" as root ("su") (all these commands without the quotes) may actually help the timeout thing).

    Let's see, let's see... hopefully there's either no problem, or an easy fix.

    http:alternativenayk.wordpress.com
    Last edited by nayk92; 26-Jun-2008 at 22:48. Reason: my website link was pointing to the forum, so I just removed the hyperlink... you can copy/paste if you're interested.

  7. #7
    Join Date
    Jun 2008
    Location
    Bangalore, India
    Posts
    20

    Default Re: smb protocol unexpectedly stopped

    OK, good news (For me). I restarted my computer and my office network is working, even through the bookmark (in the network folder). Yaaa! (hope it lasts)

  8. #8

    Unhappy Re: smb protocol unexpectedly stopped

    To Nayk92, ok thats good news for you !
    Only my problem still exists. Tried everything: setting up samba, run levels diabled firewall... nothing helps.I think i do a (again) fresh install, this thime from cd rather than dvd. If i still van't connect to my nas then i stick to 10.3

  9. #9
    Join Date
    Jun 2008
    Location
    Bangalore, India
    Posts
    20

    Default Re: smb protocol unexpectedly stopped

    Quote Originally Posted by Linux-jan View Post
    I think i do a (again) fresh install, this thime from cd rather than dvd. If i still van't connect to my nas then i stick to 10.3
    No, no, no, no... don't do that. Don't install through the CD, because that's what I did and really struggled. The CD is almost like a economy version (CD) of a luxury car (DVD)... it hardly has anything. I don't think that would help at all. I would better recommend a fresh openSUSE 11 install through DVD... and ensuring that both KDE4 and KDE3.5 are installed with everything resembling SAMBA... and drivers for your router.

    All I can suggest is

    1. if you have all the SAMBA's installed (according the to Swerdna's post) then you have everything you need to get started.

    2. I worked only with KDE3.5 (after I had only installed KDE4. Are you working with KDE3.5 as your default desktop manager?

    I'm sure that's everything you need... but perhaps it's a router driver clash... ok, ok... I'm a beginner... so I admit I have no clue... so I should just stop guessing.

    Sorry about your struggles... hope it works out soon for you.

  10. #10
    Join Date
    Jun 2008
    Posts
    22

    Default Re: smb protocol unexpectedly stopped

    I have almost the same problem: If I try to connect to smb://guest@192.168.123.201/PUBLIC I get the error message "The process for the smb://192.168.123.201 protocol died unexpectedly".

    What could be causing this? Via the command-line I have no problem connecting provided I use the "echo 0 > /proc/fs/cifs/LinuxExtensionsEnabled" trick.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •