Hi,

I'm using Suse 9.3 on a IBM Thinkpad R51 with
Intel Corporation PRO/Wireless 2200BG WLAN chip.

I've set the ESSID in ifcfg-wlan-id-<mac-addr> to
"myWLAN", and everything works fine. After restarting my network cards I get:

# iwconfig eth1 | egrep "ESSID|Access"
eth1 IEEE 802.11g ESSID:"udo-b29" Nickname:"tp-r51"
Mode:Managed Frequency:2.457 GHz Access Point: 00:09:5B:CC:AF:4A

After some time later, the ESSID is modified somehow, and even in ifcfg-wlan-id-... the line
containing the ESSID is modified to 'any'.

I've checked this with iwevent, and e.g. at
18:28 o'clock both entries were modified:

18:15:33.256099 eth1 New Access Point/Cell address:00:00:00:00:00:00
18:15:33.276928 eth1 New Access Point/Cell address:00:09:5B:CC:AF:4A
18:17:43.023269 eth1 New Access Point/Cell address:00:09:5B:CC:AF:4A
18:28:23.101877 eth1 New Access Point/Cell address:00:00:00:00:00:00
18:28:23.738263 eth1 Set Mode:Managed
18:28:23.750504 eth1 Set Encryption key: off
18:28:23.764973 eth1 Set ESSID: off/any
18:28:24.429790 eth1 New Access Point/Cell address:00:1E:58:09:3C:58
18:28:58.516083 eth1 Set ESSID:"myWLAN"
18:28:58.518155 eth1 New Access Point/Cell address:00:00:00:00:00:00
18:28:59.853309 eth1 New Access Point/Cell address:00:09:5B:CC:AF:4A
18:29:51.877141 eth1 Set Mode:Managed
18:29:51.883494 eth1 Set Encryption key: off
18:29:51.886095 eth1 Set ESSID: off/any
18:35:12.385667 eth1 New Access Point/Cell address:00:1E:58:09:3C:58
18:35:38.051824 eth1 New Access Point/Cell address:00:00:00:00:00:00
18:35:38.053855 eth1 Set ESSID:"myWLAN"
18:35:38.341819 eth1 New Access Point/Cell address:00:09:5B:CC:AF:4A
18:41:38.543939 eth1 New Access Point/Cell address:00:09:5B:CC:AF:4A

At 18:29 the ESSID on the WLAN card is modified,
and at 18:35 a new (false) access point is chosen. Quite strange !!

So any hints are welcome.

Udo

NB: I've inserted some spaces to circumvent these silly smileys, e.g. <colon><o>=