Results 1 to 3 of 3

Thread: Massive upgrade causing dependency issues

  1. #1
    Join Date
    Jun 2008
    Location
    Boston MA area
    Posts
    61

    Default Massive upgrade causing dependency issues

    I usually try to stay on top of this, but it has slid for a while and now my latest attempt at "Packates -> All Packages -> Update if Newer Available" is failing miserably. It is trying to update nearly 200 packages and this just art working out for it. I have seen this before, where previously installed applications are complaining because other packages they are depending on are getting deleted, probably because they are getting upgraded. It looks like some big upgrade of GNOME and GTK has happened that is breaking install apps like Abiword.

    So I was wondering what would be a good strategy for getting this update to work. Maybe break it into smaller pieces?

  2. #2

    Default Re: Massive upgrade causing dependency issues

    Did you try to upgrade an older version to OpenSuSE 11.0?

  3. #3
    Join Date
    Jun 2008
    Location
    Boston MA area
    Posts
    61

    Default Re: Massive upgrade causing dependency issues

    Sorry, I forgot to add some important info. I have openSUSE 10.3 and am just upgrading packages. I think a lot of these problems might have to do with my cutting back on repositories when I upgraded from 10.2 to 10.3, so I have some packages that are showing newer versions than are available in my current repositories, so I'm not sure where the newer versions came from. For instance:

    alacarte has missing dependencies
    There are no installable providers of python-gnome for alacarte-0.11.3-76.i586
    === alacarte-0.11.3-76.i586 ===
    python-gnome-2.20.0-3.i586 provides python-gnome == 2.20.0-3, but is scheduled to be uninstalled.
    python-gnome-2.20.0-3.i586[NYI_OSS] provides python-gnome == 2.20.0-3, but it is uninstallable. Try installing it on its own for more details.
    alacarte-0.11.3-76.i586 depends on python-gnome
    alacarte-0.11.3-76.i586 is lacking the requirement python-gnome

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •