Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: ATI Driver Problem

  1. #1

    Exclamation ATI Driver Problem

    Hello,
    Sorry for my bad english but i'm German.
    I'm new in openSUSE.

    If got a Sapphire ATI Radeon X1650 Series PRO (AGP)
    but the Drivers are the same as the normal ones of the ATI Radeon X1650 Series.

    I installed the new openSUSE 11.0 yesterday.
    openSUSE does not integrate ATI Drivers, so I didn't got a 3D Funktion.

    I've found this driver from Advanced Micro Devices, AMD - Homepage for normal 86/32 Bit Systems from the 18 June:

    ATI Catalyst 8.6 Proprietary Linux x86 Display Driver

    Now I tried to install the Driver on my self with this tutorial:

    ATI-Treiber unter openSUSE 10.2 installieren - openSUSE (DE)

    The Tutorial is only for 10.3.
    After I've done it i had to reboot but after LogIn the Screen became black and nothing happened anymore.

    Then I took a view on the english version and i noticed that it was a newer version then the german. There was something with an automatic installer.

    ATI - openSUSE (EN/US)

    How can I install the driver correctly so that i can aktivate the 3D funktion?

    Thanks for Help

    greetings Cedric

  2. #2
    Join Date
    Jun 2008
    Location
    Hamburg, Germany
    Posts
    21

    Default Re: ATI Driver Problem

    There exists a repository, which includes the newest driver. You could add this within yast or you could use the ATI-current one-click from openSUSE-Community.org
    Last edited by Sir_Tyrann; 24-Jun-2008 at 05:58. Reason: typo

  3. #3

    Unhappy Re: ATI Driver Problem

    Hello,
    So at first I installed the (community) repository with YaST, but it don't work. After that I installed the drivers with the 1-Klick-easy-install-file, but it still don't work. Both have installed successfully, but I can't activate the 3D funktion.

    greetings Cedric

  4. #4

    Default Re: ATI Driver Problem

    After the ati driver has installed, assuming you used the repository method,

    boot into run level 3,
    login as root or normal user and become root by typing "su -"

    now type "sax2 -r"

    after the sax2 config has finished, type

    "reboot"

    3d acceleration should work after this.

  5. #5

    Default Re: ATI Driver Problem

    Hello,
    Sorry for this simply question but i'm new to openSUSE.
    How can I switch to runlevel 3?

    Maybe with typing in '# init 3' as root?

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30

    Default Re: ATI Driver Problem

    The drivers are easily configured if you use the factory settings ATI 'aticonfig --initial --output=/etc/X11/xorg.conf' command, reboot machine, followed by the the ATI control panel, reboot machine, followed by resolution setting using the 'screen resolution' applet [which magically appears on your GNOME panel] and you're set.

    Note key problems with:

    1) combined desktop settings
    2) suse graphics control panel
    3) proper graphics initialisation


    To enable dual screen another screen on one big desktop you have to use the ATI control panel combined with manually editing the xorg.conf file which is definitely not advisable. On Suse 11.0 you may also notice that the screen resets so even if you have a 75Hz setting it reverts back to 60Hz regardless of suse graphics configuration. The initialisation is also problematic and there is no safe default to allow you to fallback and configure your visual.

    Does anyone have a solution to the desktop-, panel-, reset- and init problems?

  7. #7

    Default Re: ATI Driver Problem

    Hello,

    If installed both - the repository and the 1KlickInstall file.

    At first i tried FizzyFanta's idea:
    -Changed to runelevel 3 (# init 3)
    -Used "sax2 -r" successfully
    -rebooted

    But nothing changed. I couldn't activate the 3D Acceleration.

    After that i tried the other idea from herbievantetering:
    -Logged in as root
    -used "aticonfig --initial --output=/etc/X11/xorg.conf" successfully

    After that i rebooted openSUSE did nothing after loading up.The screen remained black. The Computer isn't frozen - but the screen keeps on staying black.

    Now it seems like i have to re-install openSUSE

    Do I have to note something special with my ATI Radeon X1650 Series?

    What can i try else?

    Cedric

  8. #8
    dgrat NNTP User

    Default Re: ATI Driver Problem

    install the kernel-source, run the installer and add in xorg.conf in the device-called section fglrx as driver.

  9. #9

    Default Re: ATI Driver Problem

    Hi ...
    I still have the same problem - Ati 1950 pro on agp, and if i activate the fglrx-driver, i get black screen.

    I tried everything i found here, on the howtos etc - no success yet.

    But err... you don't have to reinstall!
    On bootmenu just delete the vga-parameter and enter "init 3" - then you go into console-mode... login as root + password. Then type
    Code:
    sax2 -r -m 0=vesa
    After this reboot...

    it sets the driver to the default-vesa-driver, wich has no 3d or accelleration for your card, but displays the rest...

  10. #10

    Default Re: ATI Driver Problem

    Hello,
    Today I re-installed openSUSE 11.0. Now with the KDE 3.5 Desktop. I think the 3.X version is much better then the 4.
    I tried all ideas again, but the same problems. At first i couldn't aktivate the 3D Acceleration and aftet that the screen remained black.

    It's very disapointing...

    Has Nobody got a Idea?

    Cedric

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •