Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

  1. #1
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    After trying all the 10.3 tricks and failing to get my VirtualBox usb hardware up on 11.0, I finally stumbled on a process that works. Here is my howto/workaround:

    1st I am talking of the "VirtualBox-1.6.2-Linux_amd64.run" install, not the rpm (which is OSE and usb won't work by design).

    2nd you have to add your username to the vboxuser group in Yast.

    Then, do:
    Code:
    grep vboxuser /etc/group
    that will yield something like:
    Code:
    vboxusers:!:114:john
    Yours will be different!

    Now we must edit /etc/fstab to include:
    Code:
     /sys/bus/usb/drivers /proc/bus/usb usbfs devgid=xxx,devmode=664 0 0
    Where xxx is the number from the grep above.
    Mine looks like this:
    Code:
    /dev/disk/by-id/scsi-SATA_ST3500320AS_5QM02D0H-part3 swap                 swap       defaults              0 0
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1MP885841-part3 swap                 swap       defaults              0 0
    /dev/disk/by-id/scsi-SATA_ST3500320AS_5QM02D0H-part5 /                    ext3       acl,user_xattr        1 1
    /dev/disk/by-id/scsi-SATA_ST3500320AS_5QM02D0H-part2 /data                ext3       defaults              1 2
    /dev/disk/by-id/scsi-SATA_ST3500320AS_5QM02D0H-part6 /home                ext3       acl,user_xattr        1 2
    /dev/disk/by-id/scsi-SATA_Maxtor_6Y080M0_Y2G4VQ6E-part1 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_Maxtor_6Y080M0_Y2G4VQ6E-part5 /windows/D           vfat       users,gid=users,umask=0002,utf8=true 0 0
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1MP885841-part5 /windows/E           vfat       users,gid=users,umask=0002,utf8=true 0 0
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    /sys/bus/usb/drivers  /proc/bus/usb       usbfs      devgid=115,devmode=664  0 0
    # usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    Note that I commented out the original usbfs statement.

    Now we must edit " /etc/init.d/boot.local" to include "mount -a" ( to make it active at boot) else we have to manually mount it each time we use it.

    If you have started VirtualBox before, it may be wise to do:
    Code:
    rm -r /tmp/.vbox-yourname-ipc/
    as user
    to clean up the previous entries; it will rebuild just fine

    "Reboot" to make the new "fstab" active.

    Now I have my usb printer & usb-HDD available in winxp guest on 11.0 x86-64 host

    Have fun
    Last edited by snakedriver; 24-Jun-2008 at 05:54.
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  2. #2

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    You're the second one to advocate this method. On my system the only thing that works is to leave the original usbfs ftab entry alone and add the mount statement to by boot.local file.

    Allan

  3. #3

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    I'm doing what they advocated on the VirtualBox FAQ, and it seems to work with no problems. It also gets around the need to do anything in boot.local.

    USB on openSUSE: Add the following entry to /etc/fstab:

    none /proc/bus/usb usbfs auto,busgid=XXX,busmode=0775,devgid=XXX,devmode=0664 0 0


    Replace XXX by the group ID of the group vboxusers. You can determine this value by executing

    grep vboxusers /etc/group
    A fresh OpenSUSE 11 install seems to have 1000 as the group id, just for reference.

    I also left the original usbfs fstab entry intact.

  4. #4
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    Quote Originally Posted by Trauts View Post
    I'm doing what they advocated on the VirtualBox FAQ, and it seems to work with no problems. It also gets around the need to do anything in boot.local.



    A fresh OpenSUSE 11 install seems to have 1000 as the group id, just for reference.

    I also left the original usbfs fstab entry intact.
    Good to know Though, I didn't find that in the -1.6.2 manual which is the 1st place I usually look for help with problems; probably better than my workaround too.
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  5. #5
    Join Date
    Jun 2008
    Location
    Santiago, Chile
    Posts
    18

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    Quote Originally Posted by snakedriver View Post
    Now we must edit " /etc/init.d/boot.local" to include "mount -a" ( to make it active at boot) else we have to manually mount it each time we use it.
    can you explain a little more this point ??? where should I include "mount -a" in boot.local file ?? in what line ???

    greetings !!!

  6. #6
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    Quote Originally Posted by metalklesk View Post
    can you explain a little more this point ??? where should I include "mount -a" in boot.local file ?? in what line ???

    greetings !!!
    My /etc/init.d/boot.local
    Code:
    #! /bin/sh
    #
    # Copyright (c) 2002 SuSE Linux AG Nuernberg, Germany.  All rights reserved.
    #
    # Author: Werner Fink <werner@suse.de>, 1996
    #         Burchard Steinbild, 1996
    #
    # /etc/init.d/boot.local
    #
    # script with local commands to be executed from init on system startup
    #
    # Here you should add things, that should happen directly after booting
    # before we're going to the first run level.
    #
    mount -a
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  7. #7
    FlLlP NNTP User

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    I followed instructions, and usb support really works. However, if I detach usb stick, or usb camera during session in VM, and put it back again, then instead VM - suse detects the new media. Normaly, in this case new media for VM doesn't exist at all.

    Any ideas to avoid this?

    F.

  8. #8
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    Quote Originally Posted by FlLlP View Post
    I followed instructions, and usb support really works. However, if I detach usb stick, or usb camera during session in VM, and put it back again, then instead VM - suse detects the new media. Normaly, in this case new media for VM doesn't exist at all.

    Any ideas to avoid this?

    F.
    We were talking VBox in this thread

    Have you added VM tools?

    Try seeing how it comes up in "My Computer" & maybe right click & mount
    or
    mount it from the command line
    then
    refresh VM devices in settings outside windows then refresh explorer
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  9. #9
    FlLlP NNTP User

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    I was talking about vbox, but by mistake I used "vm" thinking about virtual machine...

    So, the problem stays, mount -a does not do a trick. Again, I did step by step everything you advised in post, and everything works except the situation I mentioned before:

    its not possible to mount same usb controller (stick or camera in my case) twice per vbox session.

    If I use usb memory stick on vbox, after removing it (safely, or brutally, never mind second attempt of plugging it (on my computer) ends with opensuse's pop-up about new media detected, and vbox with XP ignores it. I am very new in suse, so I don't know how to restart vbox driver, the only solution for me is complete restart of computer (logof->login does not help).

    I can live with the only one possibility to mount usb into vbox per session, but I have a feeling that there is some catch how to order suse to ignore usb each time while vbox is running.

    Thanks, F.

  10. #10
    Join Date
    Jun 2008
    Location
    Sunset Valley, Tejas, USA
    Posts
    278

    Default Re: 11.0, VirtualBox-1.6.2 non-OSE and USB Success

    Quote Originally Posted by snakedriver View Post
    After trying all the 10.3 tricks and failing to get my VirtualBox usb hardware up on 11.0, I finally stumbled on a process that works. Here is my howto/workaround:

    1st I am talking of the "VirtualBox-1.6.2-Linux_amd64.run" install, not the rpm (which is OSE and usb won't work by design).



    Now I have my usb printer & usb-HDD available in winxp guest on 11.0 x86-64 host

    Have fun
    Hei Snake,
    You are da man. After following your instructions I NOW have a printer that works in Vbox.

    Now to get Win4Lin to print.

    Many Thanks,
    Ron

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •