Results 1 to 2 of 2

Thread: cannot change network card in yast

  1. #1
    Join Date
    Jun 2008
    Location
    Cape Town South Africa
    Posts
    92

    Default cannot change network card in yast

    I have installed 11.0 and cannot configure the wired network card in yast2. Under network settings it lists the card as RTL-8139/8139C/8139C+

    After install it detected the card and allowed me to configure it successfully, when I configured it the module name was 8139too, I could not get an Internet connection, so I tried changing the module name to 8139cp(the other option) since then I cannot edit this card anymore.

    I get the following message in the network settings tab-

    Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

    when I run lscpi -v in Konsole under ethernet controller I get-

    02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    Subsystem: Micro-Star International Co., Ltd. Device 0161
    Flags: bus master, medium devsel, latency 64, IRQ 5
    I/O ports at e800 [size=256]
    Memory at fbfffc00 (32-bit, non-prefetchable) [size=256]

    If i run dmesg I found the following-

    8139cp 0000:02:03.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
    8139cp 0000:02:03.0: Try the "8139too" driver instead.
    Expansion ROM at 70000000 [disabled] [size=64K]
    Capabilities: [50] Power Management version 2
    Kernel modules: 8139cp, 8139too

    and further on in the dmesg output-

    ADDRCONF(NETDEV_UP): eth0: link is not ready

    can somebody help me to configure this card back to module 8139too

    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Cape Town South Africa
    Posts
    92

    Default Re: cannot change network card in yast

    ok got it worked out
    I had to delete the wireless card then yast let me add a new card and change the module name to 8139too it then detected the card and configured it correctly

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •