Results 1 to 4 of 4

Thread: CPU Scaling

  1. #1

    Default CPU Scaling

    I did a little research and found that my machine runs cooler when i set the cpu scaling governor to conservative instead of ondemand. Everything is fine after I type 'echo "conservative" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor' until I reboot the machine and the governor is automatically set back to ondemand. I can't seem to find where to change what is the default governor. Is it maybe somewhere in the boot scripts? If so I don't know where. It is a lenovo t61p laptop. Any help would be greatly appreciated

    mike

  2. #2
    Uwe Buckesfeld NNTP User

    Default Re: CPU Scaling

    Mike,

    try /etc/sysconfig/powersave/cpufreq
    Note that for this setting to take effect, you need to disable the powersave demon running on top of your GUI, like kpowersave.

    Uwe

  3. #3

    Smile Re: CPU Scaling

    Thanks, I set CPUFREQ_CONTROL="userspace". It set the governor to "userspace" but it seems to be behaving the same way as "conservative" because HAL is controling the cpu speed.


    thanks
    Mike

  4. #4
    Join Date
    Jun 2008
    Location
    Davenport, IA
    Posts
    17

    Default Re: CPU Scaling

    Mike,

    I had a problem with cpu scaling using gnomes cpufreq-applet yesterday. Here is a how-to post I made on how to fix it:
    [How to fix gnomes cpufreq-applet]

    Just for reference, this is on a Dell Latitude D620 with an Intel Core Duo Processor.

    Hope this helps,
    Antiparadigm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •