Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: SuSe 11 Wacom Graphire4 absolute mode

  1. #1

    Default SuSe 11 Wacom Graphire4 absolute mode

    Hello everyone,

    I've a problem with setting my Graphire4 tablet to absolute mode.
    It is recognized by the system, and all required options are turned on in SaX2, but still it works just like an ordinary mouse.

    Everything is ok on the second computer with SuSe 10.3 installed. It goes smoothly with sax2 - enable tablet - restart xserver. I've compared "yast2 hardware information" output and xorg.conf contents on both computers and they're pretty much the same.

    Also, in SuSe 11 there seems to be a slight difference between the names of the device in hwinfo and xorg.conf (/dev/input/event# against /dev/input/event0), but if i edit the latter manually, after Xserver restart the screen just goes flashing forever, until reboot - and it remains so until, as i can see, event# changes.

    I've experimented for a while with sax2, sax2 -r, xorg.conf editing, tried to install drivers from 10.3 DVD, but as for now have achieved nothing.

    I'd be grateful if anyone at least dropped a hint on where to look for a solution, 'cause the option of switching back to 10.3 on the main comp seems quite unpleasant for me.

    Thanks in advance, Kore.

  2. #2

    Default Re: SuSe 11 Wacom Graphire4 absolute mode

    Well, i did some more research on the matter and stumbled upon the following in Xorg.0.log:

    Code:
    (II) LoadModule: "wacom"
    (II) Loading /usr/lib/xorg/modules//input/wacom_drv.so
    (II) Module wacom: vendor="X.Org Foundation"
    	compiled for 4.3.99.902, module version = 1.0.0
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 0.5
    (EE) module ABI major version (0) doesn't match the server's version (2)
    (II) UnloadModule: "wacom"
    (II) Unloading /usr/lib/xorg/modules//input/wacom_drv.so
    (EE) Failed to load module "wacom" (module requirement mismatch, 0)
    Don't really know what it means, but it seems that wacom driver needs to be rebuilt. I followed linuxwacom instructions, ./configure gave this output:

    Code:
     BUILD ENVIRONMENT:
           architecture - i586-suse-linux
           linux kernel - yes 
      module versioning - no 
          kernel source - yes /lib/modules/2.6.25.5-1.1-pae/source
         XFree86 source - no 
               Xorg SDK - yes /usr/include/xorg
              XSERVER64 - no
               dlloader - yes
                   XLib - yes /usr/lib
                    TCL - yes /usr/include
                     TK - yes /usr/include
                ncurses - yes
    
      BUILD OPTIONS:
                wacom.o - no
                wacdump - yes 
                 xidump - yes 
            libwacomcfg - yes
             libwacomxi - yes
              xsetwacom - yes
                  hid.o - no 
             usbmouse.o - no
                evdev.o - no
             mousedev.o - no
                input.o - no
           wacom_drv.so - yes /usr/lib/xorg/modules/input 
            wacom_drv.o - no
      wacom*_drv quirks - IsXExtensionPointer key-events
    And then make output looks like this:

    Code:
    ---
    some warnings and errors similar to the ones below
    ---
    ./xf86Wacom.c:475: error: expected ) before local
    ./xf86Wacom.c:517: error: expected ) before local
    ./xf86Wacom.c:762: error: expected ) before pWcm
    ./xf86Wacom.c:819: error: expected ) before local
    ./xf86Wacom.c:844: error: expected ) before local
    ./xf86Wacom.c:920: error: expected ) before device
    ./xf86Wacom.c:928: error: expected ) before local
    ./xf86Wacom.c:951: error: expected ) before pWcm
    ./xf86Wacom.c:1023: error: expected =, ,, ;, asm or __attribute__ before xf86WcmDevConvert
    ./xf86Wacom.c:1101: error: expected =, ,, ;, asm or __attribute__ before xf86WcmDevReverseConvert
    make[2]: *** [xf86Wacom.o] Error 1
    make[2]: Leaving directory `/node/loaded/linuxwacom-0.8.0-3/src/xdrv'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/node/loaded/linuxwacom-0.8.0-3/src'
    make: *** [all-recursive] Error 1
    Now i'm completely stuck. Anyone, help?

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, The Netherlands
    Posts
    58

    Default Re: SuSe 11 Wacom Graphire4 absolute mode

    Same issues here, didn't manage to install the latest driver from the The Linux Wacom Project (0.8.0-3) due to the same configure-problems. Also using the driver supplied with OpenSUSE 11.0 (0.7.9-50.1) gives problems!

    With 10.3 everything worked perfectly (absolute/relative, pressure, gimp's extended inputs, etc) aslo in combination with my other mouse, a Logitech MX Laser.

    With 11.0 my Wacom Graphire4 6x8 is kind of "worthless" so far.

    Although there seem no severe problems in the Xorg.0.log:
    Code:
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 25 08:49:11 2008
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) ServerLayout "Layout[all]"
    (**) |-->Screen "Screen[0]" (0)
    (**) |   |-->Monitor "Monitor[0]"
    (**) |   |-->Device "Device[0]"
    (**) |-->Input Device "Keyboard[0]"
    (**) |-->Input Device "Mouse[3]"
    (**) |-->Input Device "Mouse[5]"
    (**) |-->Input Device "Mouse[7]"
    (**) |-->Input Device "Mouse[9]"
    (**) Option "ZapWarning" "on"
    (**) Option "AllowMouseOpenFail" "on"
    (**) Option "Xinerama" "off"
    ...
    
    (**) Option "CoreKeyboard"
    (**) Keyboard[0]: always reports core events
    (**) Option "Protocol" "Standard"
    (**) Keyboard[0]: Protocol: Standard
    (**) Option "AutoRepeat" "500 30"
    (**) Option "XkbRules" "xfree86"
    (**) Keyboard[0]: XkbRules: "xfree86"
    (**) Option "XkbModel" "microsoftpro"
    (**) Keyboard[0]: XkbModel: "microsoftpro"
    (**) Option "XkbLayout" "us"
    (**) Keyboard[0]: XkbLayout: "us"
    (**) Option "CustomKeycodes" "off"
    (**) Keyboard[0]: CustomKeycodes disabled
    (II) evdev brain: Rescanning devices (1).
    (**) Option "CorePointer"
    (**) Mouse[3]-: always reports core events
    (II) Mouse[3]-: Found 5 absolute axes.
    (II) Mouse[3]-: Configuring as pointer.
    (II) Mouse[3]-: Found 1 relative axes.
    (II) Mouse[3]-: Configuring as pointer.
    (**) Mouse[3]-: WHEELRelativeAxisButtons: 4 5.
    (II) Mouse[3]-: Found 77 mouse buttons
    (**) Mouse[3]-: Configuring 5 absolute axes.
    (II) Mouse[3]-: Checking button DIGI_STYLUS (330)
    (II) Mouse[3]-: Checking bit 330
    (EE) Mouse[3]-: Button: 74.
    (EE) Mouse[3]-: state->btn: 0x9c9d60.
    (**) Mouse[3]-: Configuring in Absolute mode.
    (**) Mouse[3]-: AbsoluteScreen: 0.
    (**) Mouse[3]-: Configuring 3 relative axes.
    (II) Mouse[3]-: Configured 79 mouse buttons
    (**) Option "CorePointer"
    (**) Mouse[3]-usb-0000:00:02.0-7/input0: always reports core events
    (II) Mouse[3]-usb-0000:00:02.0-7/input0: Found 4 relative axes.
    (II) Mouse[3]-usb-0000:00:02.0-7/input0: Configuring as pointer.
    (**) Mouse[3]-usb-0000:00:02.0-7/input0: HWHEELRelativeAxisButtons: 6 7.
    (**) Mouse[3]-usb-0000:00:02.0-7/input0: WHEELRelativeAxisButtons: 4 5.
    (II) Mouse[3]-usb-0000:00:02.0-7/input0: Found 16 mouse buttons
    (**) Mouse[3]-usb-0000:00:02.0-7/input0: Configuring 4 relative axes.
    (II) Mouse[3]-usb-0000:00:02.0-7/input0: Configured 20 mouse buttons
    (**) Option "SendCoreEvents"
    (**) Mouse[5]: always reports core events
    (**) Mouse[5] device is /dev/input/event0
    (**) Mouse[5] is in absolute mode
    (**) WACOM: suppress value is 2
    (**) Option "USB" "on"
    (**) Mouse[5]: reading USB link
    (**) Option "BaudRate" "9600"
    (**) Option "SendCoreEvents"
    (**) Mouse[7]: always reports core events
    (**) Mouse[7] device is /dev/input/event0
    (**) Mouse[7] is in absolute mode
    (**) WACOM: suppress value is 2
    (**) Option "USB" "on"
    (**) Mouse[7]: reading USB link
    (**) Option "BaudRate" "9600"
    (**) Option "SendCoreEvents"
    (**) Mouse[9]: always reports core events
    (**) Mouse[9] device is /dev/input/event0
    (**) Mouse[9] is in absolute mode
    (**) WACOM: suppress value is 2
    (**) Option "USB" "on"
    (**) Mouse[9]: reading USB link
    (**) Option "BaudRate" "9600"
    (II) evaluating device (Mouse[9])
    (II) XINPUT: Adding extended input device "Mouse[9]" (type: Wacom Eraser)
    (II) evaluating device (Mouse[7])
    (II) XINPUT: Adding extended input device "Mouse[7]" (type: Wacom Stylus)
    (II) evaluating device (Mouse[5])
    (II) XINPUT: Adding extended input device "Mouse[5]" (type: Wacom Cursor)
    (II) evaluating device (Mouse[3]-usb-0000:00:02.0-7/input0)
    (II) XINPUT: Adding extended input device "Mouse[3]-usb-0000:00:02.0-7/input0" (
    type: MOUSE)
    (II) evaluating device (Mouse[3]-)
    (II) XINPUT: Adding extended input device "Mouse[3]-" (type: MOUSE)
    (II) evaluating device (evdev brain)
    (II) XINPUT: Adding extended input device "evdev brain" (type: evdev brain)
    (II) evaluating device (Keyboard[0])
    (II) XINPUT: Adding extended input device "Keyboard[0]" (type: KEYBOARD)
    (**) Option "Device" "/dev/input/event0"
    Mouse[9] Wacom X driver grabbed event device
    WACOM: unable to ioctl max values.
    (**) Option "Device" "/dev/input/event0"
    Mouse[7] Wacom X driver grabbed event device
    WACOM: unable to ioctl max values.
    (**) Option "Device" "/dev/input/event0"
    Mouse[5] Wacom X driver grabbed event device
    WACOM: unable to ioctl max values.
    (**) Mouse[3]-usb-0000:00:02.0-7/input0: 4 valuators.
    (**) evdev_btn.c (166): Registering 20 buttons.
    (II) Mouse[3]-usb-0000:00:02.0-7/input0: Init
    (**) Mouse[3]-: 5 valuators.
    (**) evdev_btn.c (166): Registering 79 buttons.
    (II) Mouse[3]-: Init
    (II) Mouse[3]-usb-0000:00:02.0-7/input0: On
    (II) Mouse[3]-: On
    (II) evdev brain: Rescanning devices (2).
    Could not init font path element /usr/share/fonts/TTF/, removing from list!
    Could not init font path element /usr/share/fonts/OTF, removing from list!
    SetClientVersion: 0 9
    SetGrabKeysState - disabled
    SetGrabKeysState - enabled
    SetClientVersion: 0 9
    SetGrabKeysState - disabled
    SetGrabKeysState - enabled
    SetClientVersion: 0 9
    SetGrabKeysState - disabled
    SetGrabKeysState - enabled
    wacomcpl gives no devices...

    More information:

    Code:
    /dev/input/by-id # l
    total 0
    drwxr-xr-x 2 root root 140 2008-06-25 18:55 ./
    drwxr-xr-x 4 root root 280 2008-06-25 18:55 ../
    lrwxrwxrwx 1 root root   9 2008-06-25 10:48 usb-Logitech_HID_compliant_keyboard-event-kbd -> ../event3
    lrwxrwxrwx 1 root root   9 2008-06-25 10:48 usb-Logitech_USB_Receiver-event-mouse -> ../event6
    lrwxrwxrwx 1 root root   9 2008-06-25 10:48 usb-Logitech_USB_Receiver-mouse -> ../mouse1
    lrwxrwxrwx 1 root root   9 2008-06-25 18:55 usb-WACOM_CTE-640-U_V4.0-3-event-mouse -> ../event4
    lrwxrwxrwx 1 root root   9 2008-06-25 18:55 usb-WACOM_CTE-640-U_V4.0-3-mouse -> ../mouse0
    Code:
    lsusb
    Bus 002 Device 003: ID 046d:c50e Logitech, Inc. MX-1000 Cordless Mouse Receiver
    Bus 002 Device 002: ID 046d:c30e Logitech, Inc. UltraX Keys (X)
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 009: ID 056a:0016 Wacom Co., Ltd
    Bus 001 Device 006: ID 1307:0330 Transcend Information, Inc.
    Bus 001 Device 003: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    When I use my 10.3 version of the xorg.conf X does'nt start and I get a FATAL error message about module evdev which cannot be found?

    While trying to compile the newer Linux Wacom Project Driver I've got exactly the same compilation errors and after the "prebuilt"-installation it gave the same flickering and looping of a starting and killing X-server... had to go to another terminal to kill it...

    So something's not right... gimp's extended inputdevices are gone but they seem normally added in the Xorg.0.log?

    Hopefully there's somebody with more luck and/or brains!

    I want to use my tablet again!!!
    Last edited by flark; 25-Jun-2008 at 10:18. Reason: Additional info

  4. #4

    Default Re: SuSe 11 Wacom Graphire4 absolute mode

    Have you tried wacdump? If it reacts to your tablet, the problem can probably be smth like this:
    When you use the mouse1 input device, the data flows from the USB wacom kernel driver, through the event subsystem, down into the mousedev driver, out the /dev/input/mouse0 device, and finally into the XInput mouse driver. You effectively lose all your absolute positioning information because the mousedev driver converts it into relative data. Additionally, the XFree86 wacom driver does not get control of the cursor because mouse1 is providing those events.
    there are two solutions here for you: you may either change your mouse1 or PS/2 InputDevice section to something other than /dev/input/mice or build mousedev.o from this project for your kernel, which will ignore Wacom tablets as USB mice. The wacom tablet appears as a mouse to the Linux kernel, and consequently, the "mice" device combines the input from all your mice, including the tablet.
    Full text here: The Linux Wacom Project

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, The Netherlands
    Posts
    58

    Thumbs down Re: SuSe 11 Wacom Graphire4 absolute mode

    wacdump -c usb -f gr4 /dev/input/event4

    Code:
    wacdump v0.7.4
    
    MODEL=Wacom Graphire4 6x8               ROM=4.0-3
    CLS=USB  VNDR=Wacom  DEV=Graphire4  SUB=CTE_640
    
    
    
    
    TOOLTYPE=NONE                             SERIAL=0x00000000
     IN_PROX=out                              BUTTON=+00000 (+00000 .. +00000)
       POS_X=+00000 (+00000 .. +16704)         POS_Y=+00000 (+00000 .. +12064)
    DISTANCE=+00000 (+00000 .. +00063)      PRESSURE=+00000 (+00000 .. +00511)
    RELWHEEL=+00000 (-00001 .. +00001)
    
        LEFT=             MIDDLE=              RIGHT=              EXTRA=
        SIDE=              TOUCH=             STYLUS=            STYLUS2=
         BT0=                BT1=                BT2=                BT3=
         BT4=                BT5=                BT6=                BT7=
         BT8=                BT9=               BT10=               BT11=
        BT12=               BT13=               BT14=               BT15=
        BT16=               BT17=               BT18=               BT19=
        BT20=               BT21=               BT22=               BT23=
    So wacdump doesn't react...

    I do not use the mice-option in xorg.conf:
    Code:
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mouse0"
      Option       "Name" "Wacom CTE-640-U V4.0-3"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
      Driver       "evdev"
      Identifier   "Mouse[3]"
      Option       "InputFashion" "Mouse"
      Option       "Name" "Logitech Media Play Mouse"
      Option       "Pass" "3"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
      Option       "evBits" "+1-2"
      Option       "keyBits" "~272-287"
      Option       "relBits" "~0-2 ~6 ~8"
    EndSection
    
    Section "InputDevice"
      Driver       "wacom"
      Identifier   "Mouse[5]"
      Option       "Device" "/dev/input/event0"
      Option       "InputFashion" "Tablet"
      Option       "Mode" "Absolute"
      Option       "Name" "GRAPHIRE v1-4 (USB)"
      Option       "SendCoreEvents" "on"
      Option       "Type" "cursor"
      Option       "USB" "on"
      Option       "Vendor" "WACOM"
    EndSection
    Section "InputDevice"
      Driver       "wacom"
      Identifier   "Mouse[7]"
      Option       "Device" "/dev/input/event0"
      Option       "InputFashion" "Pen"
      Option       "Mode" "Absolute"
      Option       "Name" "GRAPHIRE v1-4 Stylus (USB)"
      Option       "Protocol" "Auto"
      Option       "SendCoreEvents" "on"
      Option       "Type" "stylus"
      Option       "USB" "on"
      Option       "Vendor" "WACOM"
    EndSection
    
    Section "InputDevice"
      Driver       "wacom"
      Identifier   "Mouse[9]"
      Option       "Device" "/dev/input/event0"
      Option       "InputFashion" "Eraser"
      Option       "Mode" "Absolute"
      Option       "Name" "GRAPHIRE v1-4 Eraser (USB)"
      Option       "Protocol" "Auto"
      Option       "SendCoreEvents" "on"
      Option       "Type" "eraser"
      Option       "USB" "on"
      Option       "Vendor" "WACOM"
    EndSection

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, The Netherlands
    Posts
    58

    Default Problems solved using udev!



    Everything is working -using the "standard" wacom driver that comes with OpenSUSE 11- after I applied the following:

    1) Look at the output of your lsub:
    Code:
    flark@flarkbox:/dev/input> lsusb
    Bus 002 Device 002: ID 046d:c30e Logitech, Inc. UltraX Keys (X)
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 006: ID 056a:0016 Wacom Co., Ltd
    Bus 001 Device 005: ID 1307:0330 Transcend Information, Inc.
    Bus 001 Device 004: ID 04a9:10a2 Canon, Inc. iP4200
    Bus 001 Device 003: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    The output is read as: Bus number device number VendorIDroductID Description.
    So the VendorID for wacom is 056a, and the product ID for my graphire 4 tablet is 0016.

    I created a "local rules file" for udev, so it will know that our wacom attaches to the right link. (This was the main problem in the first place!)
    Code:
    cd /etc/udev/rules.d/
    flark@flarkbox:/etc/udev/rules.d> ls
    10-local.rules                     60-vboxdrv.rules
    40-alsa.rules                      61-persistent-storage-edd.rules
    40-bluetooth.rules                 64-device-mapper.rules
    40-lomoco.rules                    64-md-raid.rules
    40-suse.rules                      70-kpartx.rules
    40-zaptel.rules                    70-persistent-cd.rules
    41-soundfont.rules                 70-persistent-net.rules
    45-hpdjconsole.rules               75-cd-aliases-generator.rules
    50-udev-default.rules              75-persistent-net-generator.rules
    51-lirc.rules                      77-network.rules
    52-usx2yaudio.rules                79-yast2-drivers.rules
    55-libsane.rules                   80-drivers.rules
    56-idedma.rules                    90-hal.rules
    56-sane-backends-autoconfig.rules  95-udev-late.rules
    60-cdrom_id.rules                  99-pcsc_lite.rules
    60-persistent-input.rules          kino.rules
    60-persistent-storage.rules        midishare-udev.rules
    60-persistent-storage-tape.rules
    I added the following to 10-local.rules:
    Code:
    KERNEL=="event*", SYSFS{idVendor}=="056a", NAME="input/%k", SYMLINK="input/wacom"
    Now, every time the tablet is plugged in, it gets linked to /dev/input/wacom instead of /dev/input/eventX... This is what we want!

    Now change your device-section in /etc/X11/xorg.conf file accordingly:
    Code:
    Section "InputDevice"
      Driver       "wacom"
      Identifier   "cursor"
      Option       "Device" "/dev/input/wacom"
      Option       "InputFashion" "Tablet"
      Option       "Mode" "Relative"
      Option       "Name" "GRAPHIRE v1-4 (USB)"
      Option       "SendCoreEvents" "on"
      Option       "Type" "cursor"
      Option       "USB" "on"
      Option       "Vendor" "WACOM"
    EndSection
    
    Section "InputDevice"
      Driver       "wacom"
      Identifier   "stylus"
      Option       "Device" "/dev/input/wacom"
      Option       "InputFashion" "Pen"
      Option       "Mode" "Absolute"
      Option       "Name" "GRAPHIRE v1-4 Stylus (USB)"
      Option       "Protocol" "Auto"
      Option       "SendCoreEvents" "on"
      Option       "Type" "stylus"
      Option       "USB" "on"
      Option       "Vendor" "WACOM"
    EndSection
    
    Section "InputDevice"
      Driver       "wacom"
      Identifier   "eraser"
      Option       "Device" "/dev/input/wacom"
      Option       "InputFashion" "Eraser"
      Option       "Mode" "Absolute"
      Option       "Name" "GRAPHIRE v1-4 Eraser (USB)"
      Option       "Protocol" "Auto"
      Option       "SendCoreEvents" "on"
      Option       "Type" "eraser"
      Option       "USB" "on"
      Option       "Vendor" "WACOM"
    EndSection
    Found this in A Gentoo Linux Wiki on Wacom Tablets...

    Hope this works for more people!

  7. #7

    Default Re: Problems solved using udev!

    This is *THE* correct answer.

    All other Wacom related threads should be considered for deletion. Seriously. Better to start from a relatively clean slate. I've spent two *years* looking for this.

  8. #8

    Default Wacom post-mortem (Intuos, Cintiq, Bamboo, Graphire, etc)

    A few bits of amplification . . .

    The udev rule You don't have to reboot for any of this. To load the udev rule:

    Code:
    # udevadm control --reload_rules
    To reload xorg.conf Either switch sessions, which will start a second X server (and your computer will probably noticably slow down) or just close your session and login again. (Ubuntu Forums HOWTO)

    Keys and Scroll Bars (Cintiq, Intuos, etc) The Gentoo Wiki article flark found also points to ExpressKeys, which can enable the keys and scroll bars on the Intuos3 series and other tablets and screens with them.

    GIMP You will also need to configure GIMP to recognize each of the InputDevice elements you add to xorg.conf. Short answer:

    1) Preferences->Input devices->Configure Extended input devices
    2) Set each of the devices (stylus, etc) to Screen, except pad. Leave pad disabled.

    Long answer: here.

    ====Second half====

    Threads I would recommend for deletion:

    Gimp has no access to wacom
    Wacom Intuos 3 install (follows the classic forum form: aching effort followed by demoralizing ambiguity)
    Wacom Bamboo fun - Got to be a simple way to set this up (Selage offers help, but the novice can't quite get there with only his directions, and his solution isn't as robust as flark's)
    Wacom Bamboo Fun
    Wacom tablet under openSUSE 11.0. VladimirSavic's tutorial predates flark's but suggests the user will need external packages and tells the reader to reboot, both of which are unnecessary.
    Installing the Wacom Bamboo Driver is, again, aching effort followed by demoralizing ambiguity.
    Wacom Bamboo is a 64 bit thread, which again leads nowhere. And, after reading all these threads, I'm pretty sure the driver isn't the issue. It's the config.
    Do Wacom Tablets Work in Suse?. This thread actually highlights a nomenclature issue. Most people are writing in about Wacom USB devices, which are sold as tablets, which creates some ambiguity for the technical differences between a USB device and a TabletPC, so oldcpu keeps referring people to TabletPCs - openSUSE and User : Dkukawka - openSUSE, which are absolutely *not* the pages a Wacom USB person should be reading.
    Wacom Intuos 3 problem in OpenSuse11 is another effort-to-ambiguity thread. Again, 64 bit, but same difference, IMHO.
    LinuxWacom 8 help. Again, effort-to-ambiguity.
    Kernel Module Support. Follows the theme. They almost all follow the same theme.
    There are other threads, even older, that should also be deleted, but I really need to get to work. Just search the forums for "wacom" and most of those threads should be deleted (all except the clearly TabletPC threads, and this thread).

    Flark's last post in this thread, and the first half of this post, have all the information all the people in these threads were looking for.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: SuSe 11 Wacom Graphire4 absolute mode

    Quote Originally Posted by niels olson
    A few bits of amplification . . .

    *The udev rule* You don't have to reboot for any of this. To load the
    udev rule:


    Code:
    --------------------
    # udevadm control --reload_rules
    --------------------


    *To reload xorg.conf* Either switch sessions, which will start a second
    X server (and your computer will probably noticably slow down) or just
    close your session and login again. ('Ubuntu Forums HOWTO'
    (http://ubuntuforums.org/showthread.php?p=4211618))

    *Keys and Scroll Bars (Cintiq, Intuos, etc)* The Gentoo Wiki article
    flark found also points to 'ExpressKeys'
    (http://freshmeat.net/projects/wacomexpresskeys/), which can enable the
    keys and scroll bars on the Intuos3 series and other tablets and screens
    with them.

    [GIMP] You will also need to configure GIMP to recognize each of the
    InputDevice elements you add to xorg.conf. Short answer:

    1) Preferences->Input devices->Configure Extended input devices
    2) Set each of the devices to (stylus, etc) to Screen, except pad.
    Leave pad disabled.

    Long answer: 'here'
    (http://www.gimptalk.com/forum/viewtopic.php?t=17992).

    ====Second half====

    Threads I would recommend for deletion:

    'Gimp has no access to wacom' (http://tinyurl.com/4u6rfn)
    'Wacom Intuos 3 install' (http://tinyurl.com/4vhjq8) (follows the
    classic forum form: aching effort followed by demoralizing ambiguity)
    'Wacom Bamboo fun - Got to be a simple way to set this up'
    (http://tinyurl.com/4dsy6l) (Selage offers help, but the novice can't
    quite get there with only his directions, and his solution isn't as
    robust as flark's)
    'Wacom Bamboo Fun'
    (http://forums.opensuse.org/hardware/...amboo-fun.html)
    'Wacom tablet under openSUSE 11.0' (http://tinyurl.com/595tf2).
    VladimirSavic's tutorial predates flark's but suggests the user will
    need external packages and tells the reader to reboot, both of which are
    unnecessary.
    'Installing the Wacom Bamboo Driver' (http://tinyurl.com/4c2mej) is,
    again, aching effort followed by demoralizing ambiguity.
    'Wacom Bamboo'
    (http://forums.opensuse.org/hardware/...om-bamboo.html) is
    a 64 bit thread, which again leads nowhere. And, after reading all these
    threads, I'm pretty sure the driver isn't the issue. It's the config.
    'Do Wacom Tablets Work in Suse?' (http://tinyurl.com/4j53fr). This
    thread actually highlights a nomenclature issue. Most people are writing
    in about Wacom USB devices, which are sold as tablets, which creates
    some ambiguity for the technical differences between a USB device and a
    TabletPC, so oldcpu keeps referring people to 'TabletPCs - openSUSE'
    (http://en.opensuse.org/TabletPCs) and 'User : Dkukawka - openSUSE'
    (http://en.opensuse.org/Userkukawka#Tablet_PCs), which are absolutely
    *not* the pages a Wacom USB person should be reading.
    'Wacom Intuos 3 problem in OpenSuse11' (http://tinyurl.com/3rd3rw) is
    another effort-to-ambiguity thread. Again, 64 bit, but same difference,
    IMHO.
    'LinuxWacom 8 help'
    (http://forums.opensuse.org/hardware/...om-8-help.html).
    Again, effort-to-ambiguity.
    'Kernel Module Support' (http://tinyurl.com/3ftqdj). Follows the theme.
    They almost all follow the same theme.

    Flark's last post in this thread, and the first half of this post, have
    all the information all the people in these threads were looking for.
    Hi
    Might I suggest you do a short howto on your results, then add a
    pointer to the posts you have identified pointing to the howto

    As an nntp user, the posts won't get deleted (if they do?) from my
    system

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 2:51, 0 users, load average: 0.03, 0.27, 0.40
    GPU GeForce 6600 TE/6200 TE - Driver Version:


  10. #10

    Default Re: SuSe 11 Wacom Graphire4 absolute mode

    I would agree if this fixes everything, but that not true

    As of now my Wacom is working correctly, a least as i can see it replacing my mouse activity.

    The one thing thats holding me back is GIMP.

    if i go to add devices, there is no stylus, eraser,cursor or pad...

    There is only linux input, and Gimp has no access to it...
    So no wacom glory for me.

    Has anyone any clue of what could be doing this? and how to fix it?

    Thank you

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •