Results 1 to 9 of 9

Thread: OpenSUSE 11.0 on EeePC ...

  1. #1
    paleheretic NNTP User

    Default OpenSUSE 11.0 on EeePC ...

    Hi Folks,

    OK. OpenSUSE 11 installed and working on my EeePC 900.

    I'm putting together an updated how-to, but wanted to check a couple of my experiences and see if anyone else has the same...

    Once installed you have no network. I copied the Appleonkel Madwifi and Atheros kernel drivers and hand installed them - worked perfectly!

    Set up repositories, sort things out, run updates ... and wireless breaks. It seems that the Atheros Kernel drivers update needs Kernel(vmlinux) and says it isn't provided by any of the repos I have set up.

    Has anyone else had this? Going back to the original AppleOnkle .rpms fixes everything again, but I have lost the little sys tray applet that allows me to easily switch wireless networks (anyone know what it's called so I can turn it on?).

    As it goes, all I have left to do id sort out the rest of the hot keys (wifi, volume, lcd/crt not yet working) but everything else is great!

    Love OpenSUSE ... and interested to note that 11 starts in about half the time that 10.3 did on this EeePC.

    Thanks!

  2. #2
    davesurrey NNTP User

    Default Re: OpenSUSE 11.0 on EeePC ...


    "paleheretic" <paleheretic@no-mx.forums.opensuse.org> wrote in message
    newsaleheretic.3bgio2@no-mx.forums.opensuse.org...
    >
    > Hi Folks,
    >
    > OK. OpenSUSE 11 installed and working on my EeePC 900.
    >
    > I'm putting together an updated how-to, but wanted to check a couple of
    > my experiences and see if anyone else has the same...
    >
    > Once installed you have no network. I copied the Appleonkel Madwifi and
    > Atheros kernel drivers and hand installed them - worked perfectly!
    >
    > Set up repositories, sort things out, run updates ... and wireless
    > breaks. It seems that the Atheros Kernel drivers update needs
    > Kernel(vmlinux) and says it isn't provided by any of the repos I have
    > set up.
    >
    > Has anyone else had this? Going back to the original AppleOnkle .rpms
    > fixes everything again, but I have lost the little sys tray applet that
    > allows me to easily switch wireless networks (anyone know what it's
    > called so I can turn it on?).
    >
    > As it goes, all I have left to do id sort out the rest of the hot keys
    > (wifi, volume, lcd/crt not yet working) but everything else is great!
    >
    > Love OpenSUSE ... and interested to note that 11 starts in about half
    > the time that 10.3 did on this EeePC.
    >
    > Thanks!
    >
    >
    > --
    > paleheretic
    > ------------------------------------------------------------------------

    Hi,
    Would be really interetsted to read your how-to when you have it all
    completed. Currently running Mandriva 2008 on my eee701 but would like to
    go over to openSUSE to match my desktop.
    I guess you will post it here?
    Cheers
    Dave



  3. #3
    paleheretic NNTP User

    Default Re: OpenSUSE 11.0 on EeePC ...

    Hi there,

    Yes - I'll be posting it here and blogging it at Pale Heretic.

    I ended up going or a clean reinstall last night and I think I have a 95% completed install (just a few of the minor tweaks left to do) within about 2 hours.

    The OpenSUSE 11 install was much easier than the 10.3 for some reason and the 10.3 eeepc repositories now mostly have 11.0 versions in place.

    Before you start, go to the AppleOnkel repository at
    Index of /repositories/home:/appleonkel:/EEE/openSUSE_11.0/i586
    And download the MadWifi and Athero kernel drivers rpms and put them on a USB stick
    madwifi-kmp-default-ng_r3366+ar5007_2.6.25.5_1.1-1.4.i586.rpm
    madwifi-ng_r3366+ar5007-1.4.i586.rpm

    An outline of the process is:

    1. Install from the OpenSUSE 11 live CD (using a USB external CD-ROM drive)

    2. Modify xorg.conf in line with the changes listed in OpenSUSE on the EeePC - openSUSE

    If you (like me) have a 900, you'll need to modify the 1024x768 entries in xorg.conf to read 1024x600. You will also need to run yast from a root commandline and modify the system >> sysconfig editor >> desktop >> display manager >> displaymanager_randr_mode_auto value and change it to:
    1024X600_60 48.96 1024 1064 1168 1312 600 601 604 622 -hsync -vsync

    There may be another way to change this value but this is the only method I have found that works.

    3. Use the USB stick with the Madwifi / Drivers RPMs and install them with the package installer. You should then be able to configure your wireless and things get easier at this point.

    4. Add the Appleonkel, Seife, Schmolle 1980 and Rusjako repositories as detailed in the 10.3 wiki entry (linked above). I also added a few others at this point: packman, vlc, mozilla, gnome stable, wine - but that's personal preference.

    5. Add the eeepc packages and you should find you have a working system after the reboot.

    All that remains is the tweaks outlined in the 10.3 post.

    If I've missed anything let me know, or if anyone has any other useful tricks then please post them!

    Thanks!

  4. #4
    davesurrey NNTP User

    Default Re: OpenSUSE 11.0 on EeePC ...


    "paleheretic" <paleheretic@no-mx.forums.opensuse.org> wrote in message
    newsaleheretic.3bi7bg@no-mx.forums.opensuse.org...
    >
    > Hi there,
    >
    > Yes - I'll be posting it here and blogging it at 'Pale Heretic'
    > (http://paleheretic.blogspot.com).
    >
    > I ended up going or a clean reinstall last night and I think I have a
    > 95% completed install (just a few of the minor tweaks left to do)
    > within about 2 hours.
    >
    > The OpenSUSE 11 install was much easier than the 10.3 for some reason
    > and the 10.3 eeepc repositories now mostly have 11.0 versions in place.
    >
    >
    > Before you start, go to the AppleOnkel repository at
    > 'Index of /repositories/home:/appleonkel:/EEE/openSUSE_11.0/i586'
    > (http://tinyurl.com/685fk6)
    > And download the MadWifi and Athero kernel drivers rpms and put them on
    > a USB stick
    > madwifi-kmp-default-ng_r3366+ar5007_2.6.25.5_1.1-1.4.i586.rpm
    > madwifi-ng_r3366+ar5007-1.4.i586.rpm
    >
    > An outline of the process is:
    >
    > 1. Install from the OpenSUSE 11 live CD (using a USB external CD-ROM
    > drive)
    >
    > 2. Modify xorg.conf in line with the changes listed in 'OpenSUSE on the
    > EeePC - openSUSE' (http://en.opensuse.org/OpenSUSE_on_the_EeePC)
    >
    > If you (like me) have a 900, you'll need to modify the 1024x768 entries
    > in xorg.conf to read 1024x600. You will also need to run yast from a
    > root commandline and modify the system >> sysconfig editor >> desktop
    >>> display manager >> displaymanager_randr_mode_auto value and change

    > it to:
    > 1024X600_60 48.96 1024 1064 1168 1312 600 601 604 622 -hsync -vsync
    >
    > There may be another way to change this value but this is the only
    > method I have found that works.
    >
    > 3. Use the USB stick with the Madwifi / Drivers RPMs and install them
    > with the package installer. You should then be able to configure your
    > wireless and things get easier at this point.
    >
    > 4. Add the Appleonkel, Seife, Schmolle 1980 and Rusjako repositories as
    > detailed in the 10.3 wiki entry (linked above). I also added a few
    > others at this point: packman, vlc, mozilla, gnome stable, wine - but
    > that's personal preference.
    >
    > 5. Add the eeepc packages and you should find you have a working system
    > after the reboot.
    >
    > All that remains is the tweaks outlined in the 10.3 post.
    >
    > If I've missed anything let me know, or if anyone has any other useful
    > tricks then please post them!
    >
    > Thanks!


    Hi,
    Really grateful for the above. I'll be trying it out latter this week when
    another 8GB SD card comes.

    JFYI I have an EEE 701 (waiting for the 901) with 2GB ram and 4GB SSD and an
    8GB SDHC card that currently has Puppy and Mandriva 2008.1 spring (gnome) on
    it.
    I haven't played with Puppy much but it has the advantage of being very very
    quick (not surprising) and small.

    Mandriva however takes a good while to boot but I have to say it installed
    just about perfectly, with all the Fn keys working as well as lan, wifi and
    camera and both Compiz and Metisse!
    That will be a very hard act to follow. But I do like the look and feel of
    openSuse_11 and am going towards it on my desktop so will have to see if I
    can get it up and running on the EEE.
    Thanks again and enjoy
    Dave



  5. #5

    Default Re: OpenSUSE 11.0 on EeePC ...

    I'd be very interested in hearing about your experiences of installing and using SuSE on the eeepc. I have tried to install with two USB drives, and I installed to a SDHC, not the interior SSD. Interestingly, a first attempt to install 11 RC-1 worked, and after some minor snags, I was able to update it to the current version. OTOH, an attempt to install the official release ended in an installation which would hang at the initial boot. I know I'm not alone with this problem; see here: EeeUser ASUS Eee PC Forum / Interest in Open Suse 11.0 Wiki Entry? and here: EeeUser ASUS Eee PC Forum / OpenSuse 11.0

    OpenSuSE 11 looks great on the eeepc, and I really like this distro, but I would welcome if more of the eeepc stuff were supported out of the box.

  6. #6

    Exclamation Re: OpenSUSE 11.0 on EeePC ...

    I would recommend that if you install OpenSuse on the EEEPC you install it on an SD card or USB key on which you boot (I did that - using an USB key - for a communications security oriented mini-distro, the "Backtrack 3").

    Why ? Because the BIOS allows to to that easily (just specify you want to boot on the USB key), and if by mistake you forget one of the parameters (remember that flash memory is designed for 10 000 to 100 000 writes before it wears out, so better have NO swap file AND use NO ext3 AND specify no last-read-date update), you lose just an USB key in the following year(s), not your EEEPC itself
    Last edited by Paganel75; 31-Jul-2008 at 18:21. Reason: typo

  7. #7
    Waldwutz NNTP User

    Default Re: OpenSUSE 11.0 on EeePC ...

    NO swap file AND use NO ext3 AND specify no last-read-date update
    Good Point!
    Being happy with swap and ext3, I am puzzeling where to configure this last read update thing?

  8. #8

    Default Re: OpenSUSE 11.0 on EeePC ...

    In your /etc/fstab it'll have mount instructions for each partition (or filesystem) mounted at boot. For each filesystem, after the filesystem type (e.g. "ext3") and before the two numbers there'll be some options (it might say "defaults").

    Add "noatime" to these options, making sure you separate each option with a comma but no space. Only lines not preceded by a # are read, and noatime is very unlikely to break anything, but you perhaps might make a backup of the file first - or make sure you have a Live USB / CD handy in case of disaster.

    Here's a (slightly messy ) example from the Ubuntu I've got booted - it shouldn't be drastically different.

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'vol_id --uuid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sdb1 during installation
    UUID=6482beac-6cdb-4f4f-a628-8c423cd0677f /               ext4    noatime,errors=remount-ro 0       1
    # /home was on /dev/sdb2 during installation
    UUID=465cd5a3-46c2-491b-ba1c-644c10fd6457 /home           ext3    noatime         0       2
    tmpfs     /var/tmp     tmpfs     noatime,size=256M    0    0
    tmpfs     /tmp         tmpfs     noatime,size=256M    0    0
    # UUID=7956bc53-e0be-45a5-b8ec-1a383a8cdf06 /mnt/home ext3 defaults,noatime,users 0 0

  9. #9

    Default Re: OpenSUSE 11.0 on EeePC ...

    Just to clarify - for each line you put 'noatime' in, if it says 'atime' or 'relatime', remove those.

    These are different options for the same thing - putting more than one in is unlikely to cause problems, but likely whichever one is last will take effect.

    Google 'noatime' for more information.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •