Results 1 to 5 of 5

Thread: Error when upgrading optional packages using the KDE updater

  1. #1

    Default Error when upgrading optional packages using the KDE updater

    I am running KDE 4.1 and I have installed PackageKit and set the updater applet to use that backend. However, when I "show available upgrades when backend provides for them" in the applet configuration dialog and attempt to install the listed upgrades, I get this error:
    Code:
    DBus error : org.freedesktop.PackageKit.Transaction.RefusedByPolicy : org.freedesktop.packagekit.update-package auth_admin_keep_always
    What's going on? It can install regular updates, just not these "optional packages".

  2. #2
    mauwii NNTP User

    Exclamation Re: Error when upgrading optional packages using the KDE upd

    Having the exact same problem but I get it on KDE 3.5.9.
    First i thought it was happening cause it didn't ask for a root password. But then i started opensuseupdater-kde from root but got the exact same error.

    I get an error with the zypp backend as well:
    Refresh failed:

    But no further reason. I can refresh all repo's from commandline by doing zypper refresh.

    Anyone knows what's going on here?
    Thanks in advance!

    EDIT: Also on 11.0 btw

  3. #3

    Default Re: Error when upgrading optional packages using the KDE upd

    Quote Originally Posted by mauwii
    I get an error with the zypp backend as well:
    Refresh failed:
    I get that error too after I gave up on PackageKit and decided to go back to Zypp. However, I rebooted, switched to Zypp, refreshed the applet two times (quite odd, but it worked) and then now its installing the updates. I still like PackageKit better though, cuz you don't have to manually refresh two times, but its still giving me that error.

  4. #4

    Default Re: Error when upgrading optional packages using the KDE upd

    Okay so I figured out why zypp fails after using the packagekit backend. When you try to install the updates using packagekit and it returns the auth_admin error, the packagekitd process is still locking the packages from any modification. It doesn't automatically close. Killing this process or rebooting fixes this and allows the Zypp backend to work. But now zypp is telling me that the kdesu daemon is not responding. Agh this is frustrating!

    Someone please help with the packagekit error!

  5. #5
    tbgreve NNTP User

    Angry Re: Error when upgrading optional packages using the KDE upd

    Same here. I swtched from ZYpp Backend, because it was stuck in a loop and will not install the updates, to PackageKit Backend and now I get this:
    DBus error : org.freedesktop.PackageKit.Transaction.RefusedByPolicy : org.freedesktop.packagekit.update-package auth_admin_keep_always


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •