Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Can't get 1440x900 resolution in Suse 11

  1. #1
    gark NNTP User

    Default Can't get 1440x900 resolution in Suse 11

    On a fresh install of Suse 11, I cannot get correct resolution.
    My monitor is Hanns-G JW199D, graphics card is ATI X550.
    I have installed the latest driver from the ATI repository.
    The monitor is not in the included list.

    Setting monitor to LCD or VESA, and manually entering in the resolution and refresh rates gets me either an out of range message from the monitor, or no change.
    I have tried several edits of my xorg.conf file based on others I have found on Suse and Ubuntu forums, most of which ended with X unable to start, and I have to restore to the original xorg.conf file (I keep a backup each time I try an edit, thankfully.)

    Any help will be greatly appreciated.

  2. #2
    google01103 NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    gark wrote:

    >
    > On a fresh install of Suse 11, I cannot get correct resolution.
    > My monitor is Hanns-G JW199D, graphics card is ATI X550.
    > I have installed the latest driver from the ATI repository.
    > The monitor is not in the included list.
    >
    > Setting monitor to LCD or VESA, and manually entering in the resolution
    > and refresh rates gets me either an out of range message from the
    > monitor, or no change.
    > I have tried several edits of my xorg.conf file based on others I have
    > found on Suse and Ubuntu forums, most of which ended with X unable to
    > start, and I have to restore to the original xorg.conf file (I keep a
    > backup each time I try an edit, thankfully.)
    >
    > Any help will be greatly appreciated.
    >
    >

    welcome to the club - perhaps my unfortune can be your fortune

    I have a hanns-g hw173D and was having the exact (yes, exact, same issue -
    the problem I believe is potentially 2 fold
    1) you should use the ati config program if 1 is provided when you
    got/compiled the drivers (I have an Nvidia card and sax2 would not provide
    the right resolutions, just about anything above or below 1440x900 worked
    but 14400 gave a 640x480 or similar display). But the nvidia-settings
    program id's the lcd as a lcd (and the correct model no less) and voila!
    2) I had an additional issue because I used the vga connector on the lcd
    (had no dvi cable) and it was seen as a crt not an lcd. So you might want
    to make sure you use the lcd's dvi connector. Interesting aside my igp
    connected to the vga port of the lcd was correctly read as an lcd, so for
    the time being the graphics card sits idle - weird

    good luck,


    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

  3. #3
    mrbiggs NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    I have the same thing with my nvidia card I installed the drivers and I can set the 1440x900 with the software but when I reboot it is gone ?

  4. #4
    google01103 NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    mrbiggs wrote:

    >
    > I have the same thing with my nvidia card I installed the drivers and I
    > can set the 1440x900 with the software but when I reboot it is gone ?
    >
    >

    did you click "save to x configuration file"? in the "x server display
    config" tab? It requires you to be root 'cause it writes to xorg.conf


    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

  5. #5
    mrbiggs NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    how do I get into root to save in I new to linux ?

  6. #6
    google01103 NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    mrbiggs wrote:

    >
    > how do I get into root to save in I new to linux ?
    >
    >

    you can use su to run the command as root "su -c "nvidia-settings"
    it will ask you for root password
    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

  7. #7
    gark NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    Quote Originally Posted by google01103 View Post
    [color=blue]


    2) I had an additional issue because I used the vga connector on the lcd
    (had no dvi cable) and it was seen as a crt not an lcd. So you might want
    to make sure you use the lcd's dvi connector. Interesting aside my igp
    connected to the vga port of the lcd was correctly read as an lcd, so for
    the time being the graphics card sits idle - weird

    good luck,


    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly
    Well, that ended up being (almost...) stupid easy. I switched from the D-sub cable to a DVI, set the resolution, and rebooted. Voila! everything is crisp and beatiful!
    Of course now I can't use my KVM, as it only has D-sub connector, but at least that isn't a Suse problem.
    Thanks for pointing me in the right direction.

  8. #8
    google01103 NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    gark wrote:
    [color=blue]
    >
    > google01103;1823594 Wrote:
    >>
    >>
    >>
    >>
    >> 2) I had an additional issue because I used the vga connector on the
    >> lcd
    >> (had no dvi cable) and it was seen as a crt not an lcd. So you might
    >> want
    >> to make sure you use the lcd's dvi connector. Interesting aside my igp
    >> connected to the vga port of the lcd was correctly read as an lcd, so
    >> for
    >> the time being the graphics card sits idle - weird
    >>
    >> good luck,
    >>
    >>
    >> --
    >> Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

    > Well, that ended up being (almost...) stupid easy. I switched from the
    > D-sub cable to a DVI, set the resolution, and rebooted. Voila!
    > everything is crisp and beatiful!
    > Of course now I can't use my KVM, as it only has D-sub connector, but
    > at least that isn't a Suse problem.
    > Thanks for pointing me in the right direction.
    >
    >
    >

    I haven't tested this but it might work - if'n your 2nd pc connected to the
    kvm is a vga (which it is?) you might be able to connect it to the Hanns-g
    directly with the vga cable and using the monitor's menu switch between
    digital and vga inputs
    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

  9. #9
    gark NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    Quote Originally Posted by google01103 View Post
    gark wrote:
    [color=blue]
    >
    > google01103;1823594 Wrote:
    >>
    >>
    >>
    >>
    >> 2) I had an additional issue because I used the vga connector on the
    >> lcd
    >> (had no dvi cable) and it was seen as a crt not an lcd. So you might
    >> want
    >> to make sure you use the lcd's dvi connector. Interesting aside my igp
    >> connected to the vga port of the lcd was correctly read as an lcd, so
    >> for
    >> the time being the graphics card sits idle - weird
    >>
    >> good luck,
    >>
    >>
    >> --
    >> Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

    > Well, that ended up being (almost...) stupid easy. I switched from the
    > D-sub cable to a DVI, set the resolution, and rebooted. Voila!
    > everything is crisp and beatiful!
    > Of course now I can't use my KVM, as it only has D-sub connector, but
    > at least that isn't a Suse problem.
    > Thanks for pointing me in the right direction.
    >
    >
    >

    I haven't tested this but it might work - if'n your 2nd pc connected to the
    kvm is a vga (which it is?) you might be able to connect it to the Hanns-g
    directly with the vga cable and using the monitor's menu switch between
    digital and vga inputs
    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly
    The second machine attached to the KVM is a G4 Mac, which only has VGA output.
    The KVM I have is supposed to support hot-key switching, so I *should* be able to plug the Mac directly into the monitor as you suggested, then use hot-key switching instead of the actual buttons on the KVM. Of course the monitor may not handle two simultaneous inputs well, but I guess I'll find out.
    Thanks again for the help.

  10. #10
    google01103 NNTP User

    Default Re: Can't get 1440x900 resolution in Suse 11

    gark wrote:

    >
    > google01103;1823947 Wrote:

    <snip>
    >
    > The second machine attached to the KVM is a G4 Mac, which only has VGA
    > output.
    > The KVM I have is supposed to support hot-key switching, so I *should*
    > be able to plug the Mac directly into the monitor as you suggested,
    > then use hot-key switching instead of the actual buttons on the KVM.
    > Of course the monitor may not handle two simultaneous inputs well, but
    > I guess I'll find out.
    > Thanks again for the help.
    >
    >

    assuming it works what would be nice would be some way to swith between dvi
    and vga inputs without using the monitors menu - let me know as my dvi
    cable is on order

    thanks,
    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •