Results 1 to 6 of 6

Thread: Beeping insanity

  1. #1
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Beeping insanity

    ALT CTRL BACKSPACE. Why oh why was this feature reworked? I've read somewhere that you have to hit alt ctrl bs twice to logout of X, but I never get to that second hit because the first one emits a long shrill beep. It's annoying enough to wake the dead, so I don't dare do it twice.

    I've tweaked the kde4 notification options in systemsettings, but it has no effect on the beep. Also, console login beeps each time you do anything. Can somebody please tell me how to disable the bleeping sounds? I am this close to ripping out my eardrums because alt f1 and alt ctrl bs are shortcuts I use very often.

  2. #2
    Join Date
    Jun 2008
    Location
    Albuquerque, NM, USA
    Posts
    87

    Default Re: Beeping insanity

    You should read the release notes.

    openSUSE 11.0 Release Notes


    Press Ctrl-Alt-Backspace Twice to Terminate the X Server

    Pressing Ctrl-Alt-Backspace on GNOME, KDE, or any other graphical desktop does not terminate the X server any longer. If you press Ctrl-Alt-Backspace within 2 seconds again, it terminates the X server. On most hardware you hear a beep after the first Ctrl-Alt-Backspace press.

    In the past it was possible to accidentally terminate an X server using this key combination. Nevertheless, if you want to continue to use this key combination to terminate your X server, remove the following line from the ServerFlags section of the /etc/X11/xorg.conf file:

    Option "ZapWarning" "on"

    For more information, see the xorg.conf manpage.
    It's really that much fun!
    Geeko Samurai (cc)
    My Recent Tracks

  3. #3
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: Beeping insanity

    Awesome. Thank you. You just solved the first half of my problem with this release. On a side note, did the beep reeeally have to be that long, that loud and at such a high frequency? A short and sweet ogg file would have sufficed - gods know kde has plenty of them to spare.

    The beeps in console login still exists. Anyone know how I can disable this? Thanks.

  4. #4
    Marco Munderloh NNTP User

    Default Re: Beeping insanity

    coomac wrote:
    > Awesome. Thank you. You just solved the first half of my problem with
    > this release. On a side note, did the beep reeeally have to be that
    > long, that loud and at such a high frequency? A short and sweet ogg
    > file would have sufficed - gods know kde has plenty of them to spare.


    On my hardware, its a short, normal frequency, nearly audible little beep.

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Beeping insanity

    Normally you just have to add an entry in your profile file : ~/.profile
    Code:
    #silence beep
    setterm -blength 0
    In the GUI versions of a terminal (e.g. KTerm , GNOME Terminal, etc you have a setting to disable terminal bells).

    Also see this archive post : Can't Stop System Beep On Dell D620 - openSUSE Forums

    Hope that helps,
    Wj
    Have a lot of fun!

  6. #6
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: Beeping insanity

    Setting the beeplength to 0 worked wonders. Thanks. I remember being able to disable system bell sounds in the kde 3 version of konsole, but the kde 4 version doesn't have the feature (..yet I hope).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •