Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: SMB Problem in OpenSuse 11 with KDE 3 or 4

  1. #1
    LouisRoederer NNTP User

    Default SMB Problem in OpenSuse 11 with KDE 3 or 4

    I have a Linksys NSLU2 device with a USB drive on my network. I have always been able to connect to it with smb:. I just did a clean install of OpenSuse 11, and it will not connect to my smb share on the device. My previous installs have all been able to, and my Windows machine can connect to it. The share has "everyone" permissions, so there is no login required. The error that I get when trying to connect is "File does not exist: smb://10.10.220.77/Musi". It will continue, and sees all the files in the root of the share, except the last character of every file is missing. It does not see any folders. This happens in either KDE 3 or 4, and I've reinstalled to make sure it's not a random error. This is a real showstopper for me, since all my backup files are on that drive. Any ideas would be appreciated. Thanks.

  2. #2
    LouisRoederer NNTP User

    Default Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    As a follow up, I tried mounting the share with the command line:

    sudo mount -t cifs "//10.10.220.1/DISK 2" "/home/louis/USB Drive"

    ...which returned the error:

    mount error 111 = Connection refused

    Again, any help or ideas are greatly appreciated. Thanks.

  3. #3
    Join Date
    Jun 2008
    Location
    Friesland
    Posts
    207

    Default Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    i know you said you have everyone permission on the share but just to exclude permission issues do you have a username/password you can try this with?

    for me a cifs mount on OS11 KDE4 works fine like this:

    Code:
    mount -t cifs //192.168.1.X/{SHARENAME} /home/{USERNAME}/Shared/ -o username={USERNAME},password={PASSWORD}
    it also works okay for me when I try to connect the system through dolphin as a SSH share but it will not keep my credentials that way

    stefan
    "The day Microsoft makes something that doesn't suck is the day they make a vacuum cleaner"
    OS: Fedora9, RHEL5, CENTOS5, Arch, OpenSuSe11
    Hardware: Dell Precision M65

  4. #4
    LouisRoederer NNTP User

    Default Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    I need to correct my previous post. It does work with the mount command (I was typing the wrong IP address). Anyone know why this doesn't work with smb: anymore? Did SUSE change the way this works?

  5. #5
    royqh1979 NNTP User

    Default Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    Quote Originally Posted by LouisRoederer View Post
    I have a Linksys NSLU2 device with a USB drive on my network. I have always been able to connect to it with smb:. I just did a clean install of OpenSuse 11, and it will not connect to my smb share on the device. My previous installs have all been able to, and my Windows machine can connect to it. The share has "everyone" permissions, so there is no login required. The error that I get when trying to connect is "File does not exist: smb://10.10.220.77/Musi". It will continue, and sees all the files in the root of the share, except the last character of every file is missing. It does not see any folders. This happens in either KDE 3 or 4, and I've reinstalled to make sure it's not a random error. This is a real showstopper for me, since all my backup files are on that drive. Any ideas would be appreciated. Thanks.
    Seems there's sth wrong with the new samba-client and libsmbclient0.
    try degrade them using package inIndex of /repositories/network:/samba:/STABLE/openSUSE_11.0/i586

  6. #6

    Default Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    I am running in to this exact same problem. smb:// syntax works great in openSuse 10.3/KDE3, fails in 11.0/KDE3, with the odd symptom of the missing final character of the filename. I found that mount.cifs and the newer smb4k command work fine, so I am not running back to 10.3. But, strange behavior; and a real time-waster to troubleshoot.
    HTH

  7. #7

    Default Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    I Have the same problem when trying to reach a windows share using Dolphin on KDE4

  8. #8

    Default Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    I can also confirm this, using the Dolphin/Konqueror with KDE 4.x displays this error message when displaying a folder/file on a Samba share with an internation character/s in the name of that file/folder. It prevents viewing/copying of that file.

    It seems to be an issue with either Konqueror/Dolphin or Samba (more likely the KDE4 apps since if it was Samba then using the mount would not work) not recognising the cifs characters. I have reported the bug to Novell's Bugzilla so hopefully it will be fixed soon

  9. #9

    Smile Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    I have a very similar situation. In openSUSE 10.3 and previous, I had to use the smb4k to get my Buffalo NAS drive to mount in order to work with the files as if it was a local drive. This has always worked fine.

    I switched to openSUSE 11, with KDE4. I have attempted all the processes as mentioned above. None appear to be working. In smb4k I can see the share folders via the search and browser, but they refuse to mount. I've tried configuring the mounts manually via smb4k, with no luck.

    What's even more strange, is that this only is a problem on my laptop - my desktop machine mounts the shares without any issues, and is using the 2.3.2-0 version (not the 2.3.2-1.1 that has been recommended as an degrade). All the setting in smk4k are the same except that the laptop doesn't auto remount. I use the laptop for work as well, which has a different NAS drive set-up.

    Any ideas? And any help would be great. Thanks.

    Regards

  10. #10
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    52

    Default Re: SMB Problem in OpenSuse 11 with KDE 3 or 4

    I have the same nas device in the OP and I can connect.

    Here is the relevant line from my /etc/fstab:

    //192.168.123.135/share /media/nas1 cifs username=guest,password=password 0 0

    make sure you have cifs/samba etc etc installed

    I seem to recall we could use "smb" not "cifs" in suse 10.3.

    Good Luck

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •