Results 1 to 9 of 9

Thread: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

  1. #1

    Question Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    I have been having some issues with my sound card since the past, but since yesterday, when I decided to apply the latest updates to OS 10.3 (it updated kernel to 2.6.22.18-0.2-default x86_64), now everytime I boot OS and log into my account, if I want to have sound, I have to run always the command:

    Code:
    alsaconf
    it was not like that before, I had issues with the sound from time to time, but since yesterday, the problem is permanent.

    What can I do so the OS will remember/set whatever is needed everytime it boots ?

    This is the way my files looks like:

    /etc/modprobe.d/sound
    Code:
    alias snd-card-0 snd-emu10k1
    alias sound-slot-0 snd-emu10k1

    /etc/modprobe.conf
    http://sourcepost.sytes.net/sourcepo...ource_id=30351

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    Quote Originally Posted by katana75 View Post
    now everytime I boot OS and log into my account, if I want to have sound, I have to run always the command:

    Code:
    alsaconf
    If instead of "alsaconf", does running "rcalsasound restart" do the same?

    When you run "alsaconf", do you have to change a mixer setting? ... If it is a mixer setting then you may be able to save the setting by running (with root permissions, with the correct function settings in place): alsactl store

  3. #3

    Default Re: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    nope... I have already tried that before running the command alsaconf, but it's useless. The service is restarted:
    Code:
    Dixie7:~ # service alsasound restart
    Shutting down sound driver                                           done
    Starting sound driver:  emu10k1                                      done
    ... but the sound never come back until I run, alsaconf

    Just after running the commmand alsaconf, when it finish of doing "its thing", a sound test is performed, returning me this:

    Code:
    Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
    
    ===============================================================================
    
     Now ALSA is ready to use.
     For adjustment of volumes, use your favorite mixer.
    
    Have a lot of fun!
    ... and the sound is played loud and clear, then I know that my sound returned.

    PD: Dear oldcpu, I was the user rax369, to whom you kindly helped in the past, so I continue dealing with the same old issue about my sound .

    Cheers!
    openSUSE 10.3 x64

    Mainboard: MSI P6N Diamond, Intel Quad Core 2 Q6600 @ 2.40 GHz, RAM: 2 GB DDR2. Creative Audigy 2 Platinum, GeForce 8800 GT, Monitor: Samsung SyncMaster 1100p Plus, Network Pipe: 1024 Kbps

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    Quote Originally Posted by katana75 View Post
    nope... I have already tried that before running the command alsaconf, but it's useless. T

    ok, but how about my other question ?
    Quote Originally Posted by oldcpu View Post
    then you may be able to save the setting by running (with root permissions, with the correct function settings in place): alsactl store


    Also, did you look at this post:
    [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums
    ie. ... Maybe this is a simple mixer setting that you forgot to set. I asked you to check your mixer settings ...

  5. #5

    Default Re: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    Quote Originally Posted by oldcpu View Post
    ok, but how about my other question ?
    I have to run by myself kmix after running alsaconf, none mixer is set by default. So all what I do is to launch kmix. I dont understand your question when you say:
    Quote Originally Posted by oldcpu
    with root permissions, with the correct function settings in place): alsactl store
    What would be those correct function settings???

    Quote Originally Posted by oldcpu View Post
    Also, did you look at this post:
    [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums
    ie. ... Maybe this is a simple mixer setting that you forgot to set. I asked you to check your mixer settings ...
    No I didnt know about the existence of that thread, I only have 1 sound card here, well I have actually 2, but the other has been permantly disabled on BIOS. Anyway I had not checked in the mixer the option "Audigy Analog/Digital Output Jack (in the Switches section)", as indicated @ that thred. Will try to reboot and check if I have sound after rebooting, and tell you how it went, in case it's useful ok?
    openSUSE 10.3 x64

    Mainboard: MSI P6N Diamond, Intel Quad Core 2 Q6600 @ 2.40 GHz, RAM: 2 GB DDR2. Creative Audigy 2 Platinum, GeForce 8800 GT, Monitor: Samsung SyncMaster 1100p Plus, Network Pipe: 1024 Kbps

  6. #6

    Default Re: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    * UPDATE *
    Alright, no luck! And 1 more thing. After performing the reboot I realized that the sound had gone again. So before booting I ran again alsaconf, and after checking everything was playing loud and clear I issued the command alsactl store.

    After rebooting I heard a little hit on my speakers, so I thought the problem had been solved, but when I logged in, I had no sound again.
    openSUSE 10.3 x64

    Mainboard: MSI P6N Diamond, Intel Quad Core 2 Q6600 @ 2.40 GHz, RAM: 2 GB DDR2. Creative Audigy 2 Platinum, GeForce 8800 GT, Monitor: Samsung SyncMaster 1100p Plus, Network Pipe: 1024 Kbps

  7. #7

    Default Re: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    BTW... the last time I ran alsaconf, it finished returning this:
    Code:
    Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
    underrun!!! (at least 1214174446900.123 ms long)
    underrun!!! (at least 1214174446900.110 ms long)
    The sound played very bad after the test, repeating the sound pattern over and over, until at last it finish.
    openSUSE 10.3 x64

    Mainboard: MSI P6N Diamond, Intel Quad Core 2 Q6600 @ 2.40 GHz, RAM: 2 GB DDR2. Creative Audigy 2 Platinum, GeForce 8800 GT, Monitor: Samsung SyncMaster 1100p Plus, Network Pipe: 1024 Kbps

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    Quote Originally Posted by katana75 View Post
    BTW... the last time I ran alsaconf, it finished returning this:
    Code:
    Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
    underrun!!! (at least 1214174446900.123 ms long)
    underrun!!! (at least 1214174446900.110 ms long)
    The sound played very bad after the test, repeating the sound pattern over and over, until at last it finish.
    Try removing pulse audio, if you have it installed. Make note of the EXACT pulse audio applications that you remove, in case you decided to re-install it.

  9. #9

    Default Re: Issue with soundcard (SoundBlaster Audigy 2 Platinum)

    I booted my computer into my windows partition, and I notice I didn't have sound there neither, then I new it was a hardware issue.

    So I removed the sound card from its slot, cleaned it with contact cleaner, and tryed to boot again into OS 10.3, after I logged in I heard the sound launched by KDE after you get logged in, then I new everything was working nice again.

    This is the 2nd. time it happens to me, it's very strange since all my HW here is new, it has been around 6 or 7 months since I assembled this new PC and put it to work. But from time to time, this strange issue happens with my sound card. I'm really out of clues, what could be leading to this.

    Thanks again for your help oldcpu. Cheers!
    openSUSE 10.3 x64

    Mainboard: MSI P6N Diamond, Intel Quad Core 2 Q6600 @ 2.40 GHz, RAM: 2 GB DDR2. Creative Audigy 2 Platinum, GeForce 8800 GT, Monitor: Samsung SyncMaster 1100p Plus, Network Pipe: 1024 Kbps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •