Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: xinetd not working

  1. #1

    Default xinetd not working

    I am using Opensuse 11.0 in text mode. I've added mldonkey services to xinetd and then i tried to reboot xinetd ( /etc/init.d/xinetd restart ) and i get:
    Shutting down xinetd:
    done
    Starting INET services. (xinetd) failed

    So i deleted my service ( mldonkey ) and tried again, same error.. Can't get xinetd working.. ideas?

  2. #2

    Default Re: xinetd not working

    mldonkey gives problem: here is /etc/xinetd.d/mldonkey:
    GNU nano 2.0.7 File: mldonkey

    service mldonkey
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = marco
    server = /usr/bin/mldonkey
    }

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,530

    Default Re: xinetd not working

    Is there an entry for mldonkey in your /etc/services?
    Henk van Velden

  4. #4

    Default Re: xinetd not working

    No, there isn't.. What should i add to it?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,530

    Default Re: xinetd not working

    Well, mldonkey is only the name of the port to be used. The real portnumber is in /etc/services. You can e.g. see:
    Code:
    http             80/tcp    # World Wide Web HTTP
    http             80/udp    # World Wide Web HTTP
    that http uses the (well known) port 80. I do not know which port is normaly to be used with your product (mldonkey). That should be somewhere in the documentation.

    You could asign any port not used on your system (above 1025 when the server is to be run by a normal user), but as the client will try to connect to that port the client must know about it.

    I could e.g. use a different port than 80 for http (you will see e.g. 8080 used), but then the browser must specifie "http://host.domain.name:8080/", because normaly a browser will try 80 as the default for http.
    Henk van Velden

  6. #6

    Default Re: xinetd not working

    No way to start xinetd... same problem..

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,530

    Default Re: xinetd not working

    I suppose you solved the portnumber question? Else all is in vaine.

    Then I go a little bit backwards. Was xinetd running before you started adding mldonkey to it?

    When no then first try this with the default configuration. So first undo all you did on xinetd.conf (probably nothing) and inside xinetd.d (I suppose you put the mldonkey file in there, so mv it to a save place.

    Now goto YaST > System > System Services (Runlevel) select xinetd in the list, click Enable ands then Finish.

    Now check if it runs with ps -ef | grep xinetd
    Look with dmesg for errors.

    When this is OK put the mldonkey file into /etc/xinetd.d and try the restart as you did earlier.
    Henk van Velden

  8. #8

    Default Re: xinetd not working

    xinetd was not running.. so i stared it ( without adding nothing ) I had activate some simple service like vsftpd.. In this way start.. Mldonkey send xinetd in troubles..

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,530

    Default Re: xinetd not working

    What is the portnumberr you gave mldonkey in /etc/services?
    Henk van Velden

  10. #10

    Default Re: xinetd not working

    I tried with 80 tcp

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •