Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Compiz window decoration troubles.

  1. #1
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    28

    Default Compiz window decoration troubles.

    I used to use fedora and compiz fusion worked fine there on my hardware. I decided to give openSUSE a try and everything works great excepting the compiz. I have a very slow selection rectangle when selecting the desktop items and some nasty things happening to my window decorations. Here is the screenshot:


    I have the Geforce 8600M on my laptop. Thanx for any suggestions and sorry for my ugly English

  2. #2
    Niclas Ekstedt NNTP User

    Default Re: Compiz window decoration troubles.

    Nwlvl,

    Be sure to enable the Windows Decoration plugin in Compiz, using
    the 'compizconfig-settings-manager'

    I assume you're using the GTK Window Decorator, this really works best
    with the OpenSuse 11 Gilloucge Theme. If you don't like that, you can either
    select another Theme in Gnome Control Center or switch to Emerald as your
    Window Decorator.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer/NSC Sysop
    Telindus Sweden AB

  3. #3
    Join Date
    Jun 2008
    Location
    Rotterdam, Port to Europe
    Posts
    207

    Default Re: Compiz window decoration troubles.

    I have had the same. There are two things you can do;
    1. in a terminal type: emerald --replace &
    2. start fusion icon or emerald and change to the window decoration of your choice
    For a more permanent solution do this:
    3. If you are using KDE go to ~/home/yourname/.kde and add a file like this:

    Code:
    #! /bin/sh
    sleep 5
    emerald --replace ccp &
    This should start emerald when you start KDE.
    Make sure you select compiz & emerald in the fusion -icon options.

    Works fine for me
    OpenSuSE Leap 42.3 / KDE 5.8 | Intel i7 3770 | 16GBRam | 120 + 80GB SSD's | Benq 27" | DVD | PhilipsToUcam 740 | HPpsc2355p | Logitech KB & mouse | 320 +160 + 80 + 80 GB USB HDD's | Fritz!Box Fon WLAN 7360 | (V)DSL 12 MB/s | SuSE since 2001

  4. #4
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    28

    Default Re: Compiz window decoration troubles.

    Window decorations plugin is enabled and I use gtk-window-decorator and want to set it up right somehow =)

  5. #5
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    28

    Default Re: Compiz window decoration troubles.

    Sorry for double posting. It's forbidden to edit the mesage after 10 minutes from the time it was posted.
    The thing is that I cannot find gtk-window-decorator config files anywhere in my home folder.

  6. #6
    luisczul NNTP User

    Angry Re: Compiz window decoration troubles.

    I have the same video card as you, i am using the emerald window decorator but it still looks very laggy. I have 256 mb of ram, nvidia, 3 gs of ram ddr2 and 2.0 core 2 duo. Any suggestions because this is way too laggy

  7. #7
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    28

    Default Re: Compiz window decoration troubles.

    I've googled this stuff and the problem looks common. It seems that drvers are buggy. Maybe we should install another one from the nvidia off. site...

  8. #8

    Default Re: Compiz window decoration troubles.

    I have a geforce 8800 GTS card and a similar problem all the window borders in background windows (all windows apart from the foreground 'live' one) have missing window borders until I bring them to the front. I also have very slow scrolling but not sure if this is a related problem.

  9. #9

    Default Re: Compiz window decoration troubles.

    Same problem with a GeForce 8500 GT here. Using Emerald instead of Gtk Window Decorator 'fixes' the problem for me, except window shadows won't show. Seams to be an NVIDIA specific driver issue other distros faced too.
    Okay, you're starting to compile this code here, let's see some skill rolls!

  10. #10

    Default Re: Compiz window decoration troubles.

    Got a Ti4600 and everytime I enable desktop effects, my window decorations disappear. The plugin is enabled in CCSM so its not that. Ubuntu Hardy had the same problem and it turned out to be a line of code the user had to add to the xorg.conf but it was fixed before Hardy went final.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •