Results 1 to 6 of 6

Thread: No sound: OS11|KDE3.5 Realtek HD

  1. #1
    Reavie NNTP User

    Default No sound: OS11|KDE3.5 Realtek HD

    After a fresh install of OpenSuSE 11.0 with KDE 3.5, I have no sound.

    I'm using an USB logitech headset, and the system certainly picks it up. It even goes as far as enabling the volume control that's located on the cord of the headset, but no dice.

    I'm new to openSuSE and linux all together, having a little prior knowledge in Ubuntu.

    Any help is greatly appreciated : )

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound: OS11|KDE3.5 Realtek HD

    Reavie, thank you for participating in our forum.

    Quote Originally Posted by Reavie View Post
    After a fresh install of OpenSuSE 11.0 with KDE 3.5, I have no sound. I'm using an USB logitech headset, and the system certainly picks it up. It even goes as far as enabling the volume control that's located on the cord of the headset, but no dice.
    Please, can you work your way through the audio troubleshooting guide, and see if it can help you solve your problem.
    SDB:AudioTroubleshooting - openSUSE

    Please pay attention to the need to install alsa-firmware and also check your mixer settings thoroughly.

    If that does not work for you, then please can you post the output of:
    a. the URL(s) provided by running the two diagnostic scripts recommended by the audio troubleshooting guide. Scripts_to_run_to_obtain_detailed_information

    b. the output of running in a terminal/xterm/konsole:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

  3. #3
    Reavie NNTP User

    Default Re: No sound: OS11|KDE3.5 Realtek HD

    I went through the guide prior to posting, and it didn't work
    >: (

    Here's the script's output:

    linux-ntgq:/home/jeremy # rpm -qa | grep alsa

    alsa-plugins-1.0.16-57.1
    alsa-oss-32bit-1.0.15-48.1
    alsa-1.0.16.92.git20080617-1.1
    alsa-firmware-1.0.16.92.git20080617-1.1
    alsa-oss-1.0.15-48.1
    alsa-utils-1.0.16.92.git20080617-1.1
    alsa-tools-1.0.16.91.git20080610-1.1

    linux-ntgq:/home/jeremy # rpm -qa | grep pulse
    linux-ntgq:/home/jeremy # rpm -q libasound2

    libasound2-1.0.16.92.git20080617-1.1
    linux-ntgq:/home/jeremy # uname -a
    Linux linux-ntgq 2.6.25.5-1.1-default #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x8 6_64 x86_64 GNU/Linux

    linux-ntgq:/home/jeremy # cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # FVI2.l+m4jtQBEVE:VIA High Definition Audio Controller
    alias snd-card-0 snd-hda-intel



    I'm running AMD64 x2, the "intel" portion of "snd-hda-intel" threw up a flag for me but I have no idea what to do.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound: OS11|KDE3.5 Realtek HD

    Quote Originally Posted by Reavie View Post
    Here's the script's output:
    ... thanks , but there was no URL there.

    The scripts will tell me:
    a. what hardware audio codec you have, and
    b. if you have misconfigured your mixer.
    ... typically over 50% of new users misconfigure their mixer.

    Hence I really need you to paste here the output URLs created by at least one (and preferably both) of those scripts.

    Please, can you download the script alsa-info.sh: http://hg.alsa-project.org/alsa/raw-...p/alsa-info.sh to your hard drive. And also download the script tsalsa: http://home.cfl.rr.com/infofiles/tsalsa to your hard drive.

    You can run alsa-info.sh by opening a terminal/xterm/konsole, and change to the directory where that is located, and type:
    bash alsa-info.sh

    You can run the script tsalsa from a terminal/xterm/konsole (type "su" first, enter root password to get root permissions first) and then type:
    bash tsalsa

    Sometimes just typing (with root permissions):
    cat /proc/asound/cards
    will give the codec, but not always. Hence the scripts are essential.

    Armed with that information, I can likely make a good recommendation. Without it, I don't think I can help.

    Good luck!

  5. #5
    Reavie NNTP User

    Default Re: No sound: OS11|KDE3.5 Realtek HD

    TALSA:
    ALSA Info:
    cat /proc/asound/cards
    0 [VT82xx ]: HDA-Intel - HDA VIA VT82xx
    HDA VIA VT82xx at 0xbfffc000 irq 17

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No sound: OS11|KDE3.5 Realtek HD

    Thanks for that, .... it is a bit puzzling ... it looks like you did an update between the two.

    The first script you ran "talsa" @ 15:31:50 ETD did not detect your driver/card, and your PC appeared to be missing the alsa driver. The second script you ran "alsa-info.sh" @ 16:46:16 ETD detected your card/driver (1.0.16RC2) and your utilities (1.0.17RC2). It also detected your hardware codec as an ALC883.

    Also, 1.0.17RC2 of your utilities is inconsistent with:
    alsa-utils-1.0.16.92.git20080617-1.1
    that you posted above. So clearly I have a moving target here.

    Also, the tsala script asks how many plugs/jacks on the back of your PC. You filled in 0. I don't believe that. It asks how many speakers, you filled in 0. I don't believe that. It asks if you have model options (which you don't according to the /etc/modprobe.d/sound file you posted) yet you filled in YES. Is there any chance of getting accurate information there? That information is needed to try select a model option for your /etc/modprobe.d/sound file.

    I lost my crystal ball in the last stock market crash (it wasn't a very good crystal ball ) so I am not able to provide/fill in the correct information on your PC.

    Please, if you change the alsa rpms you have installed, you need to rerun "rpm -qa | grep alsa" and tell me what that gives. Else any recommendation I give could be off the mark, and not help.

    Anyway, when I do a search on the alsa web site for the ALC883, I note item-19 reflects an update to the ALC883 in v. 1.0.17RC1 of alsa.
    Search results - AlsaProject

    So its possible an update to the alsa-driver may be needed. If you tried to do that, the alsa-info.sh script clearly indicates you did not succeed.

    Given you have been changing your configuration in the middle of my trying to help, and given I no longer know your configuration as it is a moving target, I am reluctant to spend much time on this, until your configuration settles down. The problem is any recommendation I give could be configuration specific, and hence out of date before you get it. So there is not much point for me in this ..

    Anyway, you should look at your mixer IEC958 setting. You have that ON. Should it be ON? For some users who do not have digital audio setup, switching it ON will mute their sound. Try switching it OFF.

    You could try editing your /etc/modprobe.d/sound file, with options from the ALSA-Configuration.txt file, of which I have posted the salient information here: general pastebin - Anonymous - post number 1053088

    for example, if you have 3-jacks on the back of your PC sound device, you could try:
    Code:
    options snd slots=snd-hda-intel model=3stack-dig
    # FVI2.l+m4jtQBEVE:VIA High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    and then restart alsa from a konsole with root permissions with: rcalsasound restart and then check your mixers and your sound.

    If that doesn't work, try that again and again with each of the model options in the pastebin URL I posted general pastebin - Anonymous - post number 1053088
    , 'til you find one that works. But be certain to check your mixer each time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •