Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

  1. #1
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    I've gotten a lot of questions at #suse as of late due to "No sound with Audigy" cards and openSUSE 11.0 and the culprit partially for these issues has been the new PulseAudio / ALSA system that defaults to outputting to Optical / SPDIF Passthrough instead of Analog which a lot of folks use.

    To fix THIS issue with GNOME + Audigy 1/2 + PulseAudio, please take the guided tour:

    First click on Computer and More Application, then type Volume into the Filter and choose Volume Control under System, presented on the bottom right in this picture:


    If you have more than one device (like I do) choose Audigy from the File / Change Device:


    Finally, if you are not using SPDIF / Optical Passthrough, uncheck this:

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    KDE3

    First right click on the Mixer button on the bottom right corner of the KDE3 taskbar, if you do not have a mixer button there, you can press ALT+F2 and run kmix.


    If you have more than one audio device in your computer, choose Audigy from the dropdown menu:


    Finally navigate to Switches and click on Audigy Analog / Digital Out

  3. #3
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    KDE4

    Left click on the Mixer icon on your taskbar, like this and if you have more than one audio device, choose Audigy:


    Digital Output button is not normally shown, so navigate to Settings / Configure Channels.


    Scroll down until you find Audigy Analog/Digital Output Jack:


    The button will now appear in the mixer and you can use it to toggle / enable the SPDIF / Digital/Analog output:


    Have a lot of fun.

  4. #4
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    < Shameless self bump in case people don't know how to use search >

    Yes I'll have to upgrade this and perhaps add SE+A4/XFi guide+issues to it someday.

  5. #5

    Unhappy Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    Hi , i have the same problem with creative audigy soundcard .
    I use kde, but in Kmix , output i don't have that field to chose the sound card and nowere is displayed the audigy card. Seem like it's not even recognised by the system.
    What can i do in this case?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    Quote Originally Posted by pindordan View Post
    Hi , i have the same problem with creative audigy soundcard . I use kde, but in Kmix , output i don't have that field to chose the sound card and nowere is displayed the audigy card. Seem like it's not even recognised by the system.
    What can i do in this case?
    Please, only one thread on a problem. Please, users, reply to user pindordan's post on the linked post below:
    Problem installing creative audigy soundcard - openSUSE Forums

  7. #7

    Smile Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    I finally solved sound problem :
    even that still adudigy was no where listed in the mixers
    analog / digital outputs , i just had to apply (by trying dif. vol. panels) volume to 'Analog front' vol panel and sound was on. The problem was simple as that...

  8. #8

    Default Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    Alrighty, I've got a problem too.

    I've got a SB Audigy SE with Logitech X-530 5.1 Surround Sound speakers. I only get sound out of the front left speaker and the subwoofer. I did the troubleshooting thing and got the latest ALSA stuff and nothing's changed. I went through this thread but it doesn't seem to help. In my KMix mixer I don't have the option to select my card and I don't have a configure channels option in my menu.

    I'm using KDE 3.5.9 (or is that 3.9.5).

    I have noticed something odd though. When I go to the sound setup in YaST it says I have a SB Audigy LS but I have an SB Audigy SE.

    The SE isn't in the list of cards to add. Could this be the problem?

  9. #9

    Default Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA


  10. #10

    Default Re: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA

    Actually, I should add one more thing.

    I just installed my openSUSE 11.0 yesterday and I keep getting this little red triangle saying I have automitc updates. So I click on it and it says:

    New software for your system is available

    38 security updates are available

    [x] install 42 recommended updates additionally
    [ ] Don't install updates that require a restart

    [Details] [ Install] [x Close]

    I check the first box and hit install. It asks for the root pass and I give it and then two seconds later it says I need updates again; and gives me the exact same window. Over and over and over.

    Should I worry about this before messing more with the audio?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •