Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: gnome panel sensors applet

  1. #1

    Default gnome panel sensors applet

    I installed the gnome panel sensors applet for openSUSE 11 x86_64, but it isn't in the "add to panel" list. I checked to see where it was installed: /usr/lib/sensors-applet. Do I still need to compile it using ./configure --prefix=/usr?

  2. #2

    Default Re: gnome panel sensors applet

    I used YaST to install the applet, but when I was looking for where it was installed, I found a readme file in /usr/share/doc/packages/sensors-applet that said :
    "Debian, Fedora, Ubuntu and most standard distro users will need to do a

    ./configure --prefix=/usr

    to ensure proper installation within the correct path."

    The readme file also said :
    "Requirements

    * GNOME 2.8 desktop environment, with GTK >=2.4.0 and libpanelapplet-2"
    ....so I installed GNOME Panel development to provide libpanelapplet-2.

  3. #3

    Default Re: gnome panel sensors applet

    Are there any sensors detected?

  4. #4

    Default Re: gnome panel sensors applet

    Yes, I ran sensors-detect as root and loaded the dme1737-i2c-0-2e module. The XFCE sensors applet works just fine.

  5. #5

    Default Re: gnome panel sensors applet

    Did you install any other gnome applets that work?

  6. #6

    Default Re: gnome panel sensors applet

    Yes, the Netspeed and Deskbar applets, and they both show up on the "Add to panel" list

  7. #7

    Default Re: gnome panel sensors applet

    This is the list of files installed by YaST:
    /usr/lib/libsensors-applet-plugin.la
    /usr/lib/libsensors-applet-plugin.so.0.0.0
    /usr/lib/sensors-applet
    /usr/lib/sensors-applet/sensors-applet
    /usr/lib/sensors-applet/plugins
    /usr/lib/sensors-applet/plugins/libpmu-sys.la
    /usr/lib/sensors-applet/plugins/libi2c-proc.la
    /usr/lib/sensors-applet/plugins/libacpi.a
    /usr/lib/sensors-applet/plugins/libacpi.la
    /usr/lib/sensors-applet/plugins/libhddtemp.so
    /usr/lib/sensors-applet/plugins/libhddtemp.la
    /usr/lib/sensors-applet/plugins/libibm-acpi.a
    /usr/lib/sensors-applet/plugins/libi2c-sys.a
    /usr/lib/sensors-applet/plugins/libi2c-proc.so
    /usr/lib/sensors-applet/plugins/libi2c-sys.so
    /usr/lib/sensors-applet/plugins/libsmu-sys.a
    /usr/lib/sensors-applet/plugins/libi2c-proc.a
    /usr/lib/sensors-applet/plugins/libsonypi.so
    /usr/lib/sensors-applet/plugins/libpmu-sys.a
    /usr/lib/sensors-applet/plugins/libsonypi.a
    /usr/lib/sensors-applet/plugins/libi8k.a
    /usr/lib/sensors-applet/plugins/libibm-acpi.so
    /usr/lib/sensors-applet/plugins/libi8k.so
    /usr/lib/sensors-applet/plugins/libi8k.la
    /usr/lib/sensors-applet/plugins/libi2c-sys.la
    /usr/lib/sensors-applet/plugins/libomnibook.so
    /usr/lib/sensors-applet/plugins/libibm-acpi.la
    /usr/lib/sensors-applet/plugins/libacpi.so
    /usr/lib/sensors-applet/plugins/libomnibook.la
    /usr/lib/sensors-applet/plugins/libsmu-sys.so
    /usr/lib/sensors-applet/plugins/libhddtemp.a
    /usr/lib/sensors-applet/plugins/libomnibook.a
    /usr/lib/sensors-applet/plugins/libsmu-sys.la
    /usr/lib/sensors-applet/plugins/libsonypi.la
    /usr/lib/sensors-applet/plugins/libpmu-sys.so
    /usr/lib/libsensors-applet-plugin.so
    /usr/lib/libsensors-applet-plugin.a
    /usr/lib/libsensors-applet-plugin.so.0
    /usr/include/sensors-applet
    /usr/include/sensors-applet/sensors-applet-plugin.h
    /usr/include/sensors-applet/sensors-applet-sensor.h
    /usr/share/pixmaps/sensors-applet
    /usr/share/pixmaps/sensors-applet/very-low-temp-icon.png
    /usr/share/pixmaps/sensors-applet/very-high-temp-icon.png
    /usr/share/pixmaps/sensors-applet/high-temp-icon.png
    /usr/share/pixmaps/sensors-applet/normal-temp-icon.png
    /usr/share/pixmaps/sensors-applet/low-temp-icon.png
    /usr/share/doc/packages/sensors-applet
    /usr/share/doc/packages/sensors-applet/COPYING
    /usr/share/doc/packages/sensors-applet/TODO
    /usr/share/doc/packages/sensors-applet/README
    /usr/share/doc/packages/sensors-applet/ChangeLog
    /usr/share/doc/packages/sensors-applet/AUTHORS
    /usr/share/doc/packages/sensors-applet/NEWS
    /usr/share/icons/hicolor/22x22/devices/sensors-applet-case.png
    /usr/share/icons/hicolor/22x22/devices/sensors-applet-chip.png
    /usr/share/icons/hicolor/22x22/devices/sensors-applet-fan.png
    /usr/share/icons/hicolor/22x22/devices/sensors-applet-cpu.png
    /usr/share/icons/hicolor/22x22/devices/sensors-applet-gpu.png
    /usr/share/icons/hicolor/22x22/devices/sensors-applet-drive-harddisk.png
    /usr/share/icons/hicolor/22x22/devices/sensors-applet-battery.png
    /usr/share/icons/hicolor/22x22/devices/sensors-applet-memory.png
    /usr/share/icons/hicolor/48x48/apps/sensors-applet.png
    /usr/share/omf/sensors-applet
    /usr/share/omf/sensors-applet/sensors-applet-C.omf
    /usr/share/locale/ro/LC_MESSAGES/sensors-applet.mo
    /usr/share/gnome/help/sensors-applet
    /usr/share/gnome/help/sensors-applet/C
    /usr/share/gnome/help/sensors-applet/C/figures
    /usr/share/gnome/help/sensors-applet/C/figures/applet_in_panel.png
    /usr/share/gnome/help/sensors-applet/C/sensors-applet.xml
    /usr/share/gnome/help/sensors-applet/C/legal.xml

  8. #8
    Join Date
    Jul 2008
    Location
    USA
    Posts
    13

    Default Re: gnome panel sensors applet

    Just thought I would post a confirmation that this package is indeed broken with OpenSuse 11 64 bit. Ironically, it works fine with my installation of 11 32 bit though. Thus, my assumption is that this is probably a packing error. So, the running tally of known 64 bit applet bugs so far is:

    * Gnome-sensors-applet - (64 bit)
    * CPU scaling applet - (both 64 and 32 bit)
    * CPU temp applet (64 bit)

    If any one learns of further details, please post. In the mean time, I will check Bugzilla to see if these bugs have been reported.

  9. #9

    Default Re: gnome panel sensors applet

    Thanks j_black!

  10. #10
    linux-juzer NNTP User

    Default Re: gnome panel sensors applet

    Gnome sensors-applet package for 64bit isn't broken. It simply doesn't exist. Check Software.openSUSE.org site and you will find packages for 32 bit only. I tried to build my own package from src.rpm but I couldn't find gnome-applets-devel package for openSUSE 11 64bit.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •