Results 1 to 8 of 8

Thread: Printer setup - not printing

  1. #1
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Printer setup - not printing

    I just set up my HP F2100 printer and it looks like its set up correctly, but when trying to print, nothing happens.

    What could be missing?

    (running opensuse 11)

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,569
    Blog Entries
    38

    Default Re: Printer setup - not printing

    Quote Originally Posted by vinoman2 View Post
    I just set up my HP F2100 printer and it looks like its set up correctly, but when trying to print, nothing happens.
    It should work. I note this from the linux printing page:
    OpenPrinting database - Printer: HP DeskJet F2100

    Make certain you have the application "hplip" installed. Then go into yast and reconfigure the printer.

  3. #3
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,164

    Default Re: Printer setup - not printing

    I had the same problem. Seems the hplip 2.8.4 that comes with Opensuse has a problem the fix maybe hplip 2.8.6 problem solved by going here:
    HP Linux Imaging and Printing (HPLIP)
    There is a self extracting package there does everything for you & complete instructions there with screenshots. I just did it & now mine works!
    I'm just a curious cat
    My 64 bit: RADEON RX 570 |CPU AMD - Ryzen 5 1600
    MOTHERBOARD B450M D53H GGABYTE
    Opensuse Tumbleweed Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Printer setup - not printing

    I ran hplip and it shows that its set up and configured... but it doesn't print.

    How do install the new version of hplip? I just downloads a run file and what do you install it with?

  5. #5
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Printer setup - not printing

    ...well I got it to printer from Firefox, but not in OpenOffice.

    What would be the difference?

  6. #6
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,127

    Default Re: Printer setup - not printing

    This is very confusing to me, too. My HP would not print no matter what I did. CUPS would not let me add a user. I ended up ininstalling and then re-installing cups. After that, it accepted root as user and root's password. After that, I was able to add my regular user. The normal suse trick of
    lppasswd -a vinoman2

    still does not work for me. However, I am printing.

    To complicate things, the test print I was using was from the internet. It was a pdf file that opened in okular. But, I spent hours trying to get this pdf to print before I noticed that okular was ONLY printing pdf's and, sure enough, I had a load of copies of this file "printed" in my /home directory.

    My solution was to install Adobe Reader. Firefox and OpenOffice work just fine, so I can't figure out why only some apps work. Sorry to say, I can only suggest you find a workaround for each file that is not printing.... until they get this fixed.

  7. #7
    Join Date
    Jun 2008
    Location
    miami, fl
    Posts
    9

    Default Re: Printer setup - not printing

    Quote Originally Posted by vinoman2 View Post
    ...well I got it to printer from Firefox, but not in OpenOffice.

    What would be the difference?
    the difference might be configuration.
    print again in firefox. and take note on how firefox communicates with the printer. and mimic the configuration in openoffice.

  8. #8
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Printer setup - not printing [Solved]

    You're right, I have two listings and the hp2100 is the one that works! Thanks.

    [Solved]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •