Results 1 to 8 of 8

Thread: Stellarium remains black

  1. #1

    Default Stellarium remains black

    I've upgraded a SuSE 10.3 box to 11.0. The upgrade process unistalled Stellarium. Well, not a big deal; I reinstalled it (now v0.9.1). However, when I start it it displays the splash screen with all the information about modules loading, followed by a completely black screen. I've waited patiently, but nothing happens, the sky remains black.

    BTW, something in the process installed the ATI fglrx driver, so I suspected this to be the cause of the problem (it had caused problems on the box before when it was running 10.3), and removed it, but that didn't fix the problem.

    My son will kill me if I don't get Stellarium working again soon, so please help!

    -Stefan

  2. #2

    Default Re: Stellarium remains black

    Stellarium need 3d to work. So you will have to reinstall fglrx driver to get it work.

    Can I have a look of your xorg.conf?

  3. #3
    Join Date
    Jun 2008
    Location
    Porto, Portugal
    Posts
    31

    Default Re: Stellarium remains black

    Hi there!

    I'm having a similiar issue: only with me Stellarium goes white

    I have ATI drivers installed and 3D acceleration working. I've also found this thread about the subject.

    So I guess we just need to wait until a new qt4-x11 upgrade cames out. Unless someone has a better suggestion - I would really love that, since I use Stellarium A LOT!


  4. #4

    Default Re: Stellarium remains black

    I'm having a similar problem with OpenSuSE 11. In my case Stellarium show only a white screen, and only the buttons are visible.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,811
    Blog Entries
    1

    Default Re: Stellarium remains black

    Are you trying to use compiz-fusion? I have an ATI graphics chipset with the fglrx driver installed, but I have chosen to use the KWin window manager rather than compiz, and stellarium works fine for me. Maybe you need to drop the eye candy first.

  6. #6

    Default Re: Stellarium remains black

    Quote Originally Posted by sefk View Post
    Stellarium need 3d to work. So you will have to reinstall fglrx driver to get it work.

    Can I have a look of your xorg.conf?
    I had Stellarium working fine on computers (Thinkpad T series) with the fglrx driver, and on computers (Dell desktop & no-name) without the fglrx driver ("openSUSE default", so to speak). I've upgraded some of those computers from 10.3 to 11.0. On the Thinkpad with fglrx driver, I can start Stellarium, but only under a graphical root login (starting from a root shell under a different graphical login makes the screen remain black). On the updated Dell box, Stellarium remains black, same on a freshly installed (openSUSE 11.0) iAtom/mini PC box.

    For reference, here's the xorg.conf of my freshly installed openSUSE 11.0 box:

    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-07-30T00:46:41+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AIGLX" "on"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Load         "dbe"
      Load         "type1"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "de"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
      Option       "XkbVariant" "nodeadkeys"
    EndSection
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "9"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "ImExPS/2 Logitech Explorer Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
    
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  376 301
      HorizSync    30-83
      Identifier   "Monitor[0]"
      ModelName    "19DXJ"
      Option       "DPMS"
      Option       "PreferredMode" "1280x1024"
      VendorName   "YAK"
      VertRefresh  43-76
      UseModes     "Modes[0]"
    EndSection
    
    Section "Modes"
      Identifier   "Modes[0]"
      Modeline      "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    EndSection
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1280x1024" "1024x768" "800x600"
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1280x1024" "1024x768" "800x600"
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1280x1024" "1024x768" "800x600"
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1280x1024" "1024x768" "800x600"
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    Section "Device"
      BoardName    "945G"
      BusID        "0:2:0"
      Driver       "intel"
      Identifier   "Device[0]"
      Option       "monitor-VGA" "Monitor[0]"
      VendorName   "Intel"
      # StarMoney didn't start with this error:
      # X Error of failed request:  BadAlloc (insufficient resources for operation)
      # Googled, found a resolution:
      # http://forums.opensuse.org/applications/389147-x-error-failed-request-badalloc-insufficient-resources.html
      Option "Videoram" "65536"
      Option "Cachelines" "1980"
      # Advice from openSUSE support to add this line, in response to bug #......
      Option "AccelMethod" "XAA"
    EndSection
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"

  7. #7
    Psy2k NNTP User

    Default Re: Stellarium remains black

    try launching stellarium via terminal typing

    Code:
    LANG=en stellarium

  8. #8

    Default Re: Stellarium remains black

    Thanks, Penguin from Athens! :-) Someone had suggested the solution you're proposing before, and I thought I had confirmed that it actually works for me. However, I must have forgotten to report it for this bug. Sorry.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •