Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: n00b usb hard drive problem

  1. #1
    blah-blah_blah NNTP User

    Default n00b usb hard drive problem

    in opensuse 11 w/ kde 3.5 I cannot access my external USB hard drive formatted in ntfs. It always worked fine in 10.3 and also worked in 11/kde4 (but I just didn't care for 4). Anyway, I get this message:

    mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

    The only advise I can find is to run dmesg, so I ran dmesg in konsole and all I got was a lot of **** about my wireless tcp/ip. Nothing useful.

    I was careful to disconnect the drive in question before I installed the OS, so that's not the problem. Has anyone found a solution to this?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: n00b usb hard drive problem

    I experienced the same on my openSUSE-11.0 with my Seagate Free Agent 500GByte drive (formated as ntfs).

    But the drive still mounts manually with no problem.

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: n00b usb hard drive problem

    I read that it sometimes has something to do with the "clean" parameter. So try rebooting to windows and running chkdsk. Or use the "force" parameter in the line you have infstab for the mount, like this:
    /dev/sda2 /mnt/winxp ntfs-3g uid=1000,gid=100,umask=0022 0 0
    you would add it like this:
    /dev/sda2 /mnt/winxp ntfs-3g uid=1000,gid=100,umask=0022,force 0 0
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: n00b usb hard drive problem

    Quote Originally Posted by swerdna View Post
    I read that it sometimes has something to do with the "clean" parameter. So try rebooting to windows and running chkdsk.
    Thanks, will try that.

    Quote Originally Posted by swerdna View Post
    Or use the "force" parameter in the line you have in fstab for the mount
    I don't have my external drives in the fstab. It looks like 11.0 was trying to hotplug auto-mount with the ntfs driver.

    I may also try (I haven't tried yet) to put a symbolic link in the /sbin directory with:
    sudo ln -s mount.ntfs-3g mount.ntfs
    ... to force a mount with the ntfs-3g driver. If it doesn't work, or if it makes things worse, I'll remove it.

  5. #5
    blah-blah_blah NNTP User

    Default Re: n00b usb hard drive problem

    Thanks for the help.

    I did try running chkdsk in windows and everything was ok. But as far as changing anything in fstab, I wouldn't know where to begin... time to start reading

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: n00b usb hard drive problem

    You can safely look at the contents with this console command
    Code:
    cp /etc/fstab /home/your_username/Desktop/file.txt
    Then you open it and read it in a text editor like gedit or kwrite

    To actually edit/change it, you would use a command like this for KDE:
    Code:
    kdesu kwrite /etc/fstab
    or in Gnome
    Code:
    gnomesu gedit /etc/fstab
    For more on mounting NTFS FYI: HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7

    Default Re: n00b usb hard drive problem

    Quote Originally Posted by oldcpu View Post
    I experienced the same on my openSUSE-11.0 with my Seagate Free Agent 500GByte drive (formated as ntfs).

    But the drive still mounts manually with no problem.
    As you have mentioned about your Seagate Free Agent drive, i want to ask a suggestion from you. Is is worth to format this drive with other linux file systems ? (to speed up the writing process)?

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: n00b usb hard drive problem

    Quote Originally Posted by wildshekhar View Post
    As you have mentioned about your Seagate Free Agent drive, i want to ask a suggestion from you. Is is worth to format this drive with other linux file systems ? (to speed up the writing process)?
    It depends on your use. I need an external hard drive that works with any OS. Hence I need to leave it in NTFS.

  9. #9
    Rikishi 42 NNTP User

    Default Re: n00b usb hard drive problem

    On 2008-06-21, blah-blah blah <blah-blah_blah@no-mx.forums.opensuse.org> wrote:

    > I did try running chkdsk in windows and everything was ok. But as far
    > as changing anything in fstab, I wouldn't know where to begin... time
    > to start reading


    Forget about fstab, for removeable drives. It's possible to add some
    options, but the drive should be accessible without it.

    Don't know if it'll help, but try getting it mounted with ntfs-3g, rather
    than ntfs:

    cd /sbin
    sudo ln -s mount.ntfs-3g mount.ntfs



    --
    The sand remembers once there was beach and sunshine
    but chip is warm too
    -- haiku from Effector Online, Volume 1, Number 6

  10. #10
    Join Date
    Mar 2008
    Location
    San Diego (California)
    Posts
    475

    Default Re: n00b usb hard drive problem

    same problem here with both the laptops where i installed 11 kde 3.5.9.
    Two of my hard drives have a NTFS partition and a FAT32. The latter is mounted with no problems while the NTFS returns the error
    Code:
    mount: wrong fs type, bad option, bad superblock, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so
    As Oldcpu said, it can be accessed manually.
    My "lazy solution" (which is not a real solution) so far has been only adding an alias in bashrc, with the following
    Code:
    alias mountusb='sudo mount -t ntfs -o umask=0 /dev/sdc1 /media/usb_ntfs/'
    alias umountusb='sudo umount /dev/sdc1'
    This wont work in case other devices are mounted first, as that partition wont be listed as device sdc1.

    I had saved the fstab on the same machines for 10.3 and it is identical to the one in 11, so it is not a fstab problem, as pointed out here above in this thread.
    Curious issue anyway, isnt it
    ~ There are 10 types of people. Those who understand binary, and those who don't. ~

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •