Results 1 to 5 of 5

Thread: Can't boot to desktop

  1. #1

    Default Can't boot to desktop

    I'm trying to install Opensuse 11 on my desktop and am having issues. I have an ATI X1650 video card and I think that's related. First of all, the LiveCD goes to a command prompt instead of the desktop. I used the root login, and no password was required so I followed the directions in this thread:

    Console login instead of Graphical - openSUSE Forums

    I typed
    Sax2 -r -m 0=vesa

    then:
    startx

    And was able to get to the LiveCD gui just fine. I then installed and removed the CD when prompted. The computer rebooted and was told it couldn't start in graphical mode, so it installed in text mode the rest of the way.

    Now, however, when booting, it boots up to a text login: linux-zez8 login:

    I was never prompted for a root password or to create a user account. I had hoped I could again run

    Sax2 -r -m 0=vesa

    and then install my ATI driver. But I can't login because a password is required.

    What can I do?

  2. #2

    Default Re: Can't boot to desktop

    did you get a user account created when you installed it.

    At the login prompt you would type your user name. followed by the password.

    then it will let you start x

  3. #3

    Default Re: Can't boot to desktop

    Well, I did try my personal user account, but the "command was not found".

    So what I did was booted from the LiveCD, installed the ATI driver from ATI - openSUSE, and then reinstalled Opensuse. That worked just perfect and now I'm typing from my new Opensuse 11 installation.

    HOWEVER, I still wasn't prompted to set a root password. Very irritating. So I'm still trying to figure out how to set a root password.

  4. #4

    Default Re: Can't boot to desktop

    you must have missed that option in the install.

    There is now a tick that will set your root password to be the same as your user password.

    I would go and change it.

    But at the moment your root password should be identical to the user one

  5. #5

    Default Re: Can't boot to desktop

    Well, that was quick. Back again in hopes this helps someone. My root password was the same one my user password was set to. (Why didn't I think of it myself???)

    Reading this link: lostlinuxpassword.html pointed me in the right direction. Here was the golden text:

    Before we go to far with this, some systems use "sudo" and may have configured your ordinary user account to use it with your own password. Just on that chance, try typing:


    sudo su -


    at a shell prompt. If it asks for a password, just type in your usual password. If you get a "#" prompt, you are now logged in as root.
    Now I'm up and running Opensuse 11!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •