Results 1 to 4 of 4

Thread: D-link DWA-142 not working in 11.0

  1. #1
    danta NNTP User

    Default D-link DWA-142 not working in 11.0

    Hello,
    I'm struggling to get my D-link DWA-142 Wireless USB card to work in openSUSE 11.0. I have installed ndiswrapper and ndisgtk and I used the drivers v1.30(*.inf, *.cat, *.sys) in my CWindows... folder to install the drivers. After looking in Yast it seams that the hardware are OK but there is no sign of life from the card. Any suggestions on what I should do?

  2. #2
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: D-link DWA-142 not working in 11.0

    Post the output of 'uname -a', iwconfig, 'iwlist scan', route,
    and 'ndiswrapper -l', and we'll have a clue what to suggest next.

  3. #3
    danta NNTP User

    Default Re: D-link DWA-142 not working in 11.0

    OK, here is my output of those commands:

    daniel@linux-5xgs:~> uname -a
    Linux linux-5xgs 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 athlon i386 GNU/Linux
    **********************************************************
    linux-5xgs:/home/daniel # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11g ESSIDff/any
    Mode:Managed Channel:0 Access Point: Not-Associated
    Bit Rate:1 Mb/s Sensitivity=-200 dBm
    RTS thr=2346 B Fragment thr=2346 B
    Encryption keyff
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    pan0 no wireless extensions.
    *********************************************************
    linux-5xgs:/home/daniel # iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wlan0 Scan completed :
    Cell 01 - Address: 00:11:95:07:8C:F4
    ESSID:"FURUHALL"
    Protocol:IEEE 802.11g
    Mode:Managed
    Frequency:2.437 GHz (Channel 6)
    Quality:50/100 Signal level:-64 dBm Noise level:-96 dBm
    Encryption keyn
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
    48 Mb/s; 54 Mb/s
    Extra:bcn_int=100
    Extra:atim=0

    pan0 Interface doesn't support scanning.
    *********************************************************
    linux-5xgs:/home/daniel # route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    loopback * 255.0.0.0 U 0 0 0 lo
    **********************************************************
    linux-5xgs:/home/daniel # ndiswrapper -l
    netmw245 : driver installed
    device (07D1:3B10) present
    *********************************************************
    linux-5xgs:/home/daniel # ndiswrapper -v
    utils version: '1.9', utils version needed by module: '1.9'
    module details:
    filename: /lib/modules/2.6.25.5-1.1-pae/updates/ndiswrapper.ko
    version: 1.52
    vermagic: 2.6.25.5-1.1-pae SMP mod_unload 586

  4. #4
    danta NNTP User

    Default Re: D-link DWA-142 not working in 11.0

    I was able to solve this myself. I just changed from WEP to no security and connected with Knetworkmanager. Case closed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •