Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Realtek HD Audio

  1. #1

    Default Realtek HD Audio

    I have a Asus F3sa notebook with Realtek HD Audio (ALC660), but I don't know how to make it works!

    I'm not an expert on linux, so speak clearly

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Realtek HD Audio

    Quote Originally Posted by Dark_Edo View Post
    I have a Asus F3sa notebook with Realtek HD Audio (ALC660), but I don't know how to make it works!

    I'm not an expert on linux, so speak clearly
    Try working your way through the openSUSE audio troubleshooting guide:
    openSUSE AudioTroubleshooting -

    If that does not work for you, please provide us more information (for example, which openSUSE version are you using?). ... Anyway, please paste here:
    a. the output URL(s) generated by running the two diagnostic scripts in the audio troubleshooting guide: Scripts_to_run_to_obtain_detailed_information

    b. the output of typing the following commands in a terminal/xterm/konsole:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

  3. #3

    Default Re: Realtek HD Audio

    I have tried to follow step 1 with no goal ... doing rpm -q alsa alsa-utils alsa-firmware, I have:
    Code:
    alsa-1.0.16-39.1
    alsa-utils-1.0.16-35.1
    alsa-firmware-1.0.16-24.1
    I'm using openSuse 11 Gnome x86 on a Asus F3sa (intel core2duo, ati hd2600, realtek hd audio alc660) ..

    Code:
    rpm -qa | grep alsa
    alsa-oss-1.0.15-48.1
    alsa-utils-1.0.16-35.1
    alsa-firmware-1.0.16-24.1
    alsa-1.0.16-39.1
    alsa-plugins-pulse-1.0.16-57.1
    alsa-plugins-1.0.16-57.1
    
    rpm -qa | grep pulse
    pulseaudio-module-bluetooth-0.9.10-26.1
    gstreamer-0_10-pulse-0.9.5-54.1
    pulseaudio-module-lirc-0.9.10-26.1
    libpulse0-0.9.10-26.1
    pulseaudio-module-x11-0.9.10-26.1
    pulseaudio-module-zeroconf-0.9.10-26.1
    libpulse-mainloop-glib0-0.9.10-26.1
    pulseaudio-0.9.10-26.1
    pulseaudio-module-gconf-0.9.10-26.1
    pulseaudio-esound-compat-0.9.10-26.1
    alsa-plugins-pulse-1.0.16-57.1
    libpulsecore4-0.9.10-26.1
    libpulse-browse0-0.9.10-26.1
    pulseaudio-utils-0.9.10-26.1
    
    rpm -q libasound2
    libasound2-1.0.16-39.1
    
    uname -a
    Linux linux-452y 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux
    
    cat /etc/modprobe.d/sound
    options snd slots=snd-hda-intel
    # u1Nb.ULiNFUWt9WF:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel


  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Realtek HD Audio

    Quote Originally Posted by Dark_Edo View Post
    I'm using openSuse 11 Gnome x86 on a Asus F3sa (intel core2duo, ati hd2600, realtek hd audio alc660) ..

    Code:
    rpm -qa | grep pulse
    ............ snipped ...........
    
    cat /etc/modprobe.d/sound
    options snd slots=snd-hda-intel
    # u1Nb.ULiNFUWt9WF:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    How about the two diagnostic scripts? Any luck in running those, and pasting their output URLs here?

    Also, that is a lot of pulse audio applications. Are all those necessary?

    Anyway, I did a search on the ALSA web site for an ALC660, and I did not see any recent software upgrades. I note this in the ALSA-Configuration.txt file, giving guidance for asus users with an ALC660:
    Code:
    	ALC861/660
    	  3stack	3-jack
    	  3stack-dig	3-jack with SPDIF I/O
    	  6stack-dig	6-jack with SPDIF I/O
    	  3stack-660	3-jack (for ALC660)
    	  uniwill-m31	Uniwill M31 laptop
    	  toshiba	Toshiba laptop support
    	  asus		Asus laptop support
    	  asus-laptop	ASUS F2/F3 laptops
    	  auto		auto-config reading BIOS (default)
    So can you edit you PC's /etc/modprobe.d/sound file, such that it looks like this:
    Code:
    options snd slots=snd-hda-intel model=asus-laptop
    # u1Nb.ULiNFUWt9WF:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    save the change, and then restart your sound from a terminal/konsole/xterm with rcalsasound restart Then test your audio.

    If that doesn't work, then maybe try the following instead in your PCs /etc/modprobe.d/sound file:
    Code:
    options snd-hda-intel enable=1 index=0 model=asus-laptop
    # u1Nb.ULiNFUWt9WF:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    save the change, and then restart your sound from a terminal/konsole/xterm with rcalsasound restart Then test your audio.

    If that doesn't work remove those pulse audio applications, reboot your PC, and try those two /etc/modprobe.d/sound file possibilities above again.

  5. #5
    InternetNightmare NNTP User

    Default Re: Realtek HD Audio

    I have problem with my Realtek ALC660 on OpenSuSE 11.0.
    Sound works fine, but I can't mute laptop speakers.
    Even if headphones switch is on in KMix it would still produce sound from speakers.

    Changing model option in YaST doesn't work (doesn't change anything, and next time I run utility it shows now change made).

    When editing /etc/modprobe.d/sound directly I get errors:

    Starting sound driver: hda-intelWARNING: Error inserting snd (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_hwdep (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd-hwdep.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_timer (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_pcm (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    /etc/modprobe.d/sound

    options snd slots=snd-hda-intel model=3stack
    # 5Dex.IOFetRyhSn6:SBx00 Azalia
    alias snd-card-0 snd-hda-intel
    Any option gives this error.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Realtek HD Audio

    Quote Originally Posted by InternetNightmare View Post
    I have problem with my Realtek ALC660 on OpenSuSE 11.0. Sound works fine, but I can't mute laptop speakers.
    Even if headphones switch is on in KMix it would still produce sound from speakers.
    /etc/modprobe.d/sound
    options snd slots=snd-hda-intel model=3stack
    # 5Dex.IOFetRyhSn6:SBx00 Azalia
    alias snd-card-0 snd-hda-intel
    To help propose to you what model option might be best, I need more information.
    * Desktop? Laptop?
    * Which manufacturer/model#?
    * How many audio jacks on the back of your PC's sound device? (ie input/output/mic)?
    * Output of the diagnostic scripts noted above?
    * Which alsa versions? Note the specific commands are given above. Please, if you think your problem is similar, and you are thus going to tag on a thread, follow some of the suggestions in the thread and post similar output.

    Thank you for participating in our forum, and good luck with sorting your audio. I would like to try help, but I need more information.

  7. #7

    Default Re: Realtek HD Audio

    I have tried all .. nothing!

    how you enabled your sound, internetnightmare? can you help me?

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Realtek HD Audio

    Quote Originally Posted by Dark_Edo View Post
    I have tried all .. nothing!

    how you enabled your sound, internetnightmare? can you help me?
    Dark_Edo, I don't know how anyone can help you, if you can not provide information that was requested. We can not see over your shoulder as to the results you get when you type on your PC. So while it may seem to be a waste of your time having to retype and answer detailed questions, to the things you tried, a simple statement "I have tried all .. nothing!" helps no one. Especially, it does not help you.

    We need detailed answers.

    I would like to try help you, but with the dearth of information from you, I can not. Please provide answers to the questions I asked. If you don't understand what is wanted from the question, please advise.

  9. #9

    Default Re: Realtek HD Audio

    you're in right! but i'm very noob with linux and it's so difficult to follow your guides....

    i have tried your suggestions but still no sound. i have the impression that my opensuse is "corrupted" because all the attempts..possible? the sound icon from systray is disappear and the sound panel have some problems, sometimes isn't any sound card in the list..... i don't know how to return original config without reinstalling system.


    recently i have tried ubuntu and all works fine, here not may be easier with previous version of opensuse?

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Realtek HD Audio

    Quote Originally Posted by Dark_Edo View Post
    i have the impression that my opensuse is "corrupted" because all the attempts..possible? the sound icon from systray is disappear and the sound panel have some problems, sometimes isn't any sound card in the list..... i don't know how to return original config without reinstalling system.
    IMHO if you only have sound problems, then re-install is horrible overkill.

    You can always go back to a default sound setting by opening an xterm/terminal/konsole, and renaming the file /etc/modprobe.d/sound to something like /etc/modprobe.d/sound-22june08-bak

    Then either:
    a. go to YAST > HARDWARE > SOUND and try to configure your sound, or
    b. in a terminal/xterm/konsole type: alsaconf #and try to configure your sound. You NEED to pay special attention to your mixer settings, to ensure they are not blocking your sound.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •