Results 1 to 4 of 4

Thread: suspend doesn't work on thinkpad r50e

  1. #1

    Default suspend doesn't work on thinkpad r50e

    Hello !
    I have a thinkpad r50e, with an intel i855GM video card.
    It is a know "messy" video card when it's about the suspend/resume function
    https://bugzilla.redhat.com/show_bug.cgi?id=441334
    and https://bugs.launchpad.net/ubuntu/+s...ort/+bug/40621
    A solution was found for Ubuntu:
    https://bugs.launchpad.net/ubuntu/+s...21/comments/59

    But it is different for opensuse, since there is no IBM.config

    Here is the output of # /usr/sbin/s2ram -n
    Code:
    Machine unknown
    This machine can be identified by:
        sys_vendor   = "IBM"
        sys_product  = "1834BWG"
        sys_version  = "ThinkPad R50e"
        bios_version = "1WET85WW (2.05 )"

    When I choose "computer>shutdown>suspend", the screen blink a bit, then goes black, then soon after, it prompt me like I had lock the screen. (it asks for my password).

    Then, I did # /usr/sbin/s2ram -f --acpi_sleep 3 --vbe_post.
    It went to sleep fine, but when I resume, the screen stayed black. I had to hard reboot. Where is the log file, so I could print it here.

    I've seen this page: S2ram - openSUSE but I still don't get it...What should I do ?

    Thanks a lot

  2. #2

    Default Re: suspend doesn't work on thinkpad r50e

    Re !

    ok, based on what this link (https://bugs.launchpad.net/ubuntu/+s...ort/+bug/40621) suggested, here is what I did:
    # s2ram -f --pci_save --vbe_save --vbe_post
    Here is the output of the line, in a console:
    Code:
    Switching from vt7 to vt1
    Calling save_state
    Allocated buffer at 0x11000 (base is 0x0)
    ES: 0x1100 EBX: 0x0000
    saving PCI config of device 00:02.0
    fbcon fb0 state 1
    restoring PCI config of device 00:02.0
    Calling do_post
    Calling restore_state_from
    Function not supported?
    fbcon fb0 state 0
    switching back to vt7
    Is worked better then ever...except, I have now the same problem as usual with other distro's: the screen is "messy". When I scroll down, the character don't scroll, the background of icon is black, firefox doesn't show the fonts properly. Evertything work fine, except what appears on the screen.

    What advice could you give me? Do you know what parameter would do the trick?

    Thanks

  3. #3

    Default Re: suspend doesn't work on thinkpad r50e

    Hello!
    Ok, I found the nice line:

    s2ram -f --pci_save --vbe_save --vbe_post

    But I can integrate it with the "suspend" function in "Energy manager" applet.

    On this page: Powersave s2ram - openSUSE It says I need to tweak this file:/etc/powersave/sleep , but it doens't exist !
    Where is this file located on opensuse 11 ?

    Thanks !

  4. #4

    Default Re: suspend doesn't work on thinkpad r50e

    Ok, I got it:

    first, install vbetools:
    Code:
    zypper in vbetools
    Then, create a text file, called whatever you want in /etc/pm/config.d and copy this line: S2RAM_OPTS="-f --pci_save --vbe_save --vbe_mode"

    Code:
    su -
    Code:
    gedit /etc/pm/config.d/config_thinkpad_r50e
    Cppy and paste:
    Code:
    S2RAM_OPTS="-f --pci_save --vbe_save --vbe_mode"
    That's it. Now, suspend should work "ok". Now, sometimes, it doens't, so, don't hesitate to add info on this bug report:
    https://bugzilla.novell.com/show_bug.cgi?id=190481

    Thanks !

    ps: here is French tuto: Mettre un thinkpad r50e en veille sous opensuse, avec s2ram et pm-utils

    Ce tutorial permet de mettre un thinkpad r50e en veille.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •