Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Desktop Effects interfers with Video playback

  1. #1

    Default Desktop Effects interfers with Video playback

    I upgraded from openSUSE 10.3 to 11.0 using the live CD.

    Under 10.3 I had desktop effects working and DVD, WMA and MPG played fine.

    The graphics card is Intel 945 G. My system is a Dell Optiplex GX620 with 2GB RAM. 3D Acceleration is activated.

    Using GNOME Mplayer. I could start playing a MPG file, there would be sound but no picture. Using normal MPlayer, it just crashed.

    After disabling desktop effects Video files play fine. Odd behaviour, but I'd rather play video's than have, the dekstop effects, so I'll leave them switched off for the moment.

  2. #2
    Join Date
    Jun 2008
    Location
    Karlsruhe
    Posts
    27

    Default Re: Desktop Effects interfers with Video playback

    For mplayer what about trying another video output. Under preferences / video you can select the output interface. Try opengl for example. Some might work better or may cause more problems.... like slow playback. In compiz there is also a xvid comp. mode switch I think.

  3. #3
    Join Date
    Jun 2008
    Location
    Kansas City, MO
    Posts
    570

    Default Re: Desktop Effects interfers with Video playback

    i had the same problem in kde 3.5.9
    when 3d effects were enabled all i got is a blue screen on any player kaffeine, mplayer you name it all the same just sound disabled 3d effects got my video back

  4. #4

    Default Re: Desktop Effects interfers with Video playback

    Try this :

    Fix for Video Playback Problem in Compiz-Fusion -- Ubuntu Geek


    While running Compiz-Fusion, You wouldn’t be able to see any video play while either moving the window, viewing desktops in expo, 3d cube, or any other cool effect for that matter; instead you would see a blue screen, including when viewing in full screen.

    * GStreamer Users (The default video player in Ubuntu, totem-gstreamer, and any video player that is based on the gstreamer backend)

    o Open a terminal and type “gstreamer-properties”. Press Enter.

    o Click the Video tab.

    o Under Default Video Plugin select “X Window System (No Xv)”.

    o Click Test to verify that video playback is working (you should be able to see the standard TV testing colour stripes).

    o Click Close

    * VLC Users (VLC is not installed by default)

    o Start VLC and click on Settings, then Preferences.

    o Expand Video and then expand Output modules. You will notice several options for output device.

    o Select the item Output modules, and notice the checkbox at the bottom right that says Advanced options. Check the box, and now you have the option to select a different output device.

    o Pick X11 video output

    o Click on Save and you are set!

    * MPlayer Users (Mplayer is not installed by default)

    o Start Mplayer

    o Right-click on the screen and select Preferences

    o Select the Video tab and under Available Drivers select “X11 (XImage/Shm)”

    o Click Save and restart the program for the setting to take effect.

    + Some times MPlayer may not be able to show videos in full screen.

    * Xine users

    o Start xine

    o Click File, then Configure and then Preferences

    o In experience_level select “Master Of The Known Universe” so that all available settings are visible.

    o Select the tab for video.

    o Under Driver select “xshm”.

    o Restart xine.

    + The same process enables Totem that has the totem-xine backend configured.

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City, MO
    Posts
    570

    Default Re: Desktop Effects interfers with Video playback

    thxs will give them a try in a bit

  6. #6

    Default Re: Desktop Effects interfers with Video playback

    Tried the suggestions posted by wildshekhar - Changed the GStreamer and MPlayer settings.
    GNOME Mplayer and Standard MPlayer now work.
    Thanks for your help.

  7. #7

    Default Re: Desktop Effects interfers with Video playback

    no problem

  8. #8

    Default Re: Desktop Effects interfers with Video playback

    I will also try these. What about the problems with Flash player? Whenever I'm on a site with any flash, everything slows down to a halt and looks like a slide show.

  9. #9

    Default Re: Desktop Effects interfers with Video playback

    Hey guys the problem has to do with the intel driver. Novell has to update the driver for video playback to work correctly because in order to play video properly while running compiz effects you need to be using XV. XV works with aiglx and compiz but the driver is at fault. The recent Ubuntu release had the same problem but is now fixed.

    Your options are to compile your own driver, or wait for Novell to release and update.

    Lets hope Novell gets moving on this one because it is quite annoying.

  10. #10
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Desktop Effects interfers with Video playback

    Might be a nice post as sticky or tip (especially the gstreamer-properties tip). Thanks as it worked for me too!
    Have a lot of fun!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •