Results 1 to 6 of 6

Thread: Starting KDE 4 effects gives me a black screen!

  1. #1
    Join Date
    Jun 2008
    Location
    Porto, Portugal
    Posts
    31

    Unhappy Starting KDE 4 effects gives me a black screen!

    I there!

    I used 10.3 for a long time and loved it. Now I'm trying to get openSuse 11.0 running. Everything went smooth, except for one thing: KDE4 effects.

    The first time I turned on KDE4 effects, without fglrx ATI drivers, they worked, but very clumbsy. FPS was very, VERY, low! So I turned off KDE 4 effects and installed the ATI drivers from ATI openSuse repo. When I then turned effects on, my screen whent black and I could only see the mouse pointer.

    I tried Kubuntu before openSuse 11 came out and effects worked fine, although I was using KDE 4.1.

    Any ideas as why this is happening?

    Thanks in advance,
    Leandro

    :: and now the technical stuff:

    Graphic card: ATI Mobility Radeon 9600/9700
    ATI Driver: 8.49.7
    Inside xorg.conf:
    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    InputDevice "Mouse[3]" "SendCoreEvents"
    Option "Clone" "off"
    Option "Xinerama" "off"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "glx"
    Load "type1"
    Load "extmod"
    Load "dbe"
    Load "freetype"
    Load "dri"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "pt"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "Logitech M-UV69a Optical Wheel Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[3]"
    Driver "synaptics"
    Option "Buttons" "7"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "on"
    Option "HorizScrollDelta" "0"
    Option "InputFashion" "Mouse"
    Option "Name" "Synaptics;Touchpad"
    Option "Protocol" "explorerps/2"
    Option "SHMConfig" "on"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "--> LCD"
    ModelName "1280X800@60HZ"
    UseModes "Modes[0]"
    DisplaySize 313 235
    HorizSync 29.0 - 52.0
    VertRefresh 50.0 - 60.0
    Option "DPMS"
    Option "PreferredMode" "1280x800"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "radeon"
    VendorName "ATI"
    BoardName "RV350 NP"
    Option "GARTSize" "32"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 32
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

  2. #2

    Default Re: Starting KDE 4 effects gives me a black screen!

    where is the composite extension, u don't have that enabled?
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  3. #3
    Join Date
    Jun 2008
    Location
    Porto, Portugal
    Posts
    31

    Default Re: Starting KDE 4 effects gives me a black screen!

    I have no idea

    The box in sax2 is checked. I recall having to do something about that when I first tried linux (couple of years ago), but ever since Ubuntu 7.10 that I don't mess around much with config files.

    How do I do this and why isn't activated by default?

  4. #4

    Default Re: Starting KDE 4 effects gives me a black screen!

    I have no idea why it isn't on by default though it should be...

    type in konsole:

    kdesu kwrite /etc/X11/xorg.conf

    paste this at the end:

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

    If the composite extension alone doesn't work then trying putting these in the screen section right below "DefaultDepth 24"

    Option "RenderAccel" "True"
    Option "AddARGBGLXVisuals" "True"

    Please note that whenever u modify xorg.conf, u need to log out and press "ctrl"+"alt"+backspace to restart xserver for changes to take effect.

    Tell me how it goes then.
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  5. #5
    Join Date
    Jun 2008
    Location
    Porto, Portugal
    Posts
    31

    Default Re: Starting KDE 4 effects gives me a black screen!

    Thanks!

    I was already trying to paste something similar (Option "Composite" "1") that I read in another place, but I didn't knew how to edit xorg.conf with admin password (sudo kwrite wasn't working )

    Anyway, now all is smooth and working

    Thanks a bunch!

  6. #6

    Default Re: Starting KDE 4 effects gives me a black screen!

    no problem
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •