Results 1 to 5 of 5

Thread: 3D with ATI Radeon Xpress 200M ?

  1. #1

    Default 3D with ATI Radeon Xpress 200M ?

    Hi,

    i have a HP NX6325 notebook with ATI Radeon Xpress 200M. I tried to turn on the effects in KDE4 but got only a black screen. I have tried again with the fglrx ATI driver, but the same result. Is there an another driver available or anything else what can do some magic? I want to use 3d

    By the way: I'm not very familiar with Linux/OpenSuse. So the described black screen ended with a new installation of openSuse because i was not able to restore the settings. If anyone has tip to avoid this...

    Thanks!

    Greetings Nagilum

  2. #2
    Join Date
    Jun 2008
    Location
    Iowa, USA
    Posts
    24

    Default Re: 3D with ATI Radeon Xpress 200M ?

    I don't know specifically about problems with your card, but KDE 4.0 has numerous issues and is a fairly cutting edge work in progress. This just may not be suitable as a dependable day-in, day-out work machine for quite a few people. Of course, this doesn't mean you should give up without some more effort to get 3d effects working under it, just be aware that not everyone will be successful. This is the reason you get warned about choosing KDE4 as your default desktop in the installation process if you installed using the DVD, and that 3.5.9 is described in the installation as the stable KDE. KDE 4.1 is meant to be the first truly stable release of KDE4, but it will not be available until later this summer, and almost certainly will not appear as officially supported until openSUSE 11.1 (there will certainly be ways to get it working, but not with official openSUSE support).

    You will probably want to search more broadly than the laptop forum for KDE4 and black screen to see if others can lead you out of the dark, as I think this is a problem hitting more than just people with your specific card.

    As far as needing to reinstall, you should not need to take such a drastic step. First, you should be able to get out of KDE and back to the log-in by pressing Ctr-Alt-Backspace. If you can't log back into KDE 4 without instantly facing the black screen, you may need to go back to the command prompt and manually edit the KDE4 config files to turn off the 3d effects. I'm not sure which file you will want to look in, but you should be able to search for config KDE4 and effects or similar keywords and find help.

    Good luck.

  3. #3

    Default Re: 3D with ATI Radeon Xpress 200M ?

    At the end of my journey i find a one-click-Installation of suitable driver. It seems that i have to search a little bit longer in future.

    The 3D effects are working, but when i use kaffeine for watching TV (DVB-T) i haven't any longer a smooth playback, so i switched them finally off.

    Greetings
    Nagilum

  4. #4
    Join Date
    Jul 2008
    Location
    USA
    Posts
    163

    Default Re: 3D with ATI Radeon Xpress 200M ?

    I have found that the drive that comes with the opensuse 11 fresh install works. I am wondering if anyone has tried the latest ati drivers form there site. The default installed driver is 8.49 and this months driver is 8.6.

    I have no video playback when desktop effects are enabled.


    These instructions on the opensuse ATI page have work on five xpress 200m systems. (emachine, hp, gatway) fresh installs all)


    into a konsole will report that you are still not using direct acceleration or the fglrx driver.

    As root do

    init 3

    After logging in as root do

    mv /etc/X11/xorg.conf /etc/X11/xorg.conf-001
    sax2 -r -m 0=radeon
    aticonfig --initial --input=/etc/X11/xorg.conf
    sax2 -r -m 0=fglrx

    Adjust the screen settings as desired, and after you're finished type

    init 5

    to start up X again.

    You may verify the configuration with glxinfo/glxgears to ensure that fglrx is working properly.

    into a konsole will report that you are still not using direct acceleration or the fglrx driver.

    As root do

    init 3

    After logging in as root do

    mv /etc/X11/xorg.conf /etc/X11/xorg.conf-001
    sax2 -r -m 0=radeon
    aticonfig --initial --input=/etc/X11/xorg.conf
    sax2 -r -m 0=fglrx

    Adjust the screen settings as desired, and after you're finished type

    init 5

    to start up X again.

    You may verify the configuration with glxinfo/glxgears to ensure that fglrx is working properly.

  5. #5
    Join Date
    Jul 2008
    Location
    USA
    Posts
    163

    Default Re: 3D with ATI Radeon Xpress 200M ?

    Has any one else experienced a crash when they close their laptop screen or lock the desktop?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •