Results 1 to 8 of 8

Thread: How to disable Standby/Suspend

  1. #1
    Join Date
    Jun 2008
    Location
    Rio de Janeiro
    Posts
    100

    Question How to disable Standby/Suspend

    Hello,
    I am using an HP pavillion x86_64 (AMD Turion) with openSUSE 10.3.

    Yesterday I decided to enable on it the ssh to accept remote connection, so I configured accordingly the Susefirewall and my WIFI router.

    The test succeeded, but I noticed that after a certain time, the laptop enters in standby/suspend mode and consequently the connection drop down.

    I wonder to understand how can I disable this standby/suspend feature in order to let the system "always-on".

    I made many searches on this forum and through Google, but I have not found out any valid suggestion/hint.

    Thanks for your attention.

  2. #2
    Uwe Buckesfeld NNTP User

    Default Re: How to disable Standby/Suspend

    Is that KDE or Gnome or something else you are using?
    As for KDE, you can set the power management through KPowersave easily.

    Uwe

  3. #3

    Default Re: How to disable Standby/Suspend

    Hello!
    You might want to watch this:
    Powersave s2ram - openSUSE
    Code:
    If you own a machine that is capable of suspending to RAM using the s2ram tool packaged in the suspend package, but which is not yet in the whitelist, you can force the usage of the s2ram workaround with the following variables in /etc/powersave/sleep:
    
    # Set this variable to no to enable suspend to RAM.
    # If the /usr/sbin/s2ram binary is available, it will be used to detect
    # if the machine is capable of suspend to RAM. You can override this
    # detection with SUSPEND2RAM_FORCE below.
    DISABLE_USER_SUSPEND2RAM=""
    
    This should be "no" (which is default) to enable suspend to RAM at all.
    Bye !

  4. #4
    Join Date
    Jun 2008
    Location
    Rio de Janeiro
    Posts
    100

    Default Re: How to disable Standby/Suspend

    Thanks both guys,

    I have configured to "never" the suspend option when the laptop is connected to external power energy; this is possible as well using GNOME as KDE.

    However I noticed that after some time the ssh service get paused or suspended and begins impossible to connect the laptop through a remote connection, despite the system be not yet into suspend mode.

    I don't know if I have been able to explain the issue.

    Regards.

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: How to disable Standby/Suspend

    have you tried disabling the powerd service?
    It could well be you nic's power save feature is kicking in. I don't know in what measure these two are related though...
    Have a lot of fun!

  6. #6
    Uwe Buckesfeld NNTP User

    Default Re: How to disable Standby/Suspend

    On 06/23/2008 Magic31 wrote:
    > It could well be you nic's power save feature is kicking in.


    That'd be my next guess as well. Amdturion, disable the NIC powersave in the Network configuration in Yast.

    Uwe

  7. #7
    ostenzel NNTP User

    Default Re: How to disable Standby/Suspend

    Hello,
    maybe a little off topic, but I am just trying to remove the "Suspend Computer"-button in the logout-menu of KDE.
    All I tried didn't work.
    The System is a Desktop-PC with openSUSE 10.3


    Best Regards,

    Olaf Stenzel

  8. #8
    Join Date
    Jun 2008
    Location
    Rio de Janeiro
    Posts
    100

    Default Re: How to disable Standby/Suspend

    Thanks all for the valuable suggestions.

    I will try the NIC power-save feature as soon I'll be back home.

    See you.

    BR,

    amdturion

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •