Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: KDE4 + Compiz = Crashed desktop?

  1. #1
    carlbeech NNTP User

    Default KDE4 + Compiz = Crashed desktop?

    Hi,
    I've installed SuSE 11 and it appears to be working fine - I wanted to enable compiz, however, when I enable desktop effects, the KDE 4 panel, and all the window decorations disappear (assume crash?) - I.e. a useless desktop - disable effects and I get the KDE panel back and all is well again...?

    I'm going to the desktop effects application, and clicking on 'Enable desktop effects'.

    Has anyone any idea what I'm doing wrong - I've seen screenshots of KDE4 with compiz running...?

    Many thanks in advance...

    Carl.

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,716
    Blog Entries
    2

    Default Re: KDE4 + Compiz = Crashed desktop?

    This doesn't answer your question, but don't forget that the KDE4 in Suse 1 is still kinda flaky, KDE4 is still being developed.

    Hopefully someone will advise how to fix your problem -- I'm just saying don't be surprised KDE4 has MANY problems.
    Leap 42.2 & Leap 42.3 [&KDE]
    FYIs from the days of yore

  3. #3
    carlbeech NNTP User

    Default Re: KDE4 + Compiz = Crashed desktop?

    Hmm,

    Yes, it also seems that NVidia cards are having problems too (yes I'm using an NVidia)....

    Looks like I'm going to have to install KDE3 as well and see how that goes...

    Thanks

    Carl.

  4. #4

    Default Re: KDE4 + Compiz = Crashed desktop?

    post your xorg.conf, which card do u use and have u installed the 3d driver? kde 4 and compiz r actually working really well for most people.
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  5. #5
    Uwe Buckesfeld NNTP User

    Default Re: KDE4 + Compiz = Crashed desktop?

    Carl,

    you didn't upgrade to KDE 4.0.8 through the community repo violently, did you? That would cause the problems you see.

    Uwe

  6. #6
    carlbeech NNTP User

    Default Re: KDE4 + Compiz = Crashed desktop?

    Hi
    Many thanks for the replies - here's the details that you have asked for:

    I'm using an NVidia 7600 GS, with the NVidia drivers loaded, version 173.14.05 (according to the NVIDIA X server settings) - this was downloaded and installed as part of the standard default install process.

    Interestingly enough, I've also installed the KDE 3.5 version from the SuSE 11 DVD, and when I use the simple-ccsm or enable compiz, I loose all window decorations (minimise,maximise,title bar, resize etc), however, the task bar remains.

    I'm guessing that there's something amiss with a config file - please note that I've not made any manual changes to any config files - I've done all config through Yast.

    Here's my xorg.conf as requested...

    Many thanks

    Carl.

    /etc/X11> cat xorg.conf
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-06-20T19:52:00+0100.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "freetype"
    Load "type1"
    Load "dbe"
    Load "glx"
    Load "extmod"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "gb"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "Aiptek International APT-2 Tablet"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 338 270
    HorizSync 30-83
    Identifier "Monitor[0]"
    ModelName "JT178X5"
    Option "DPMS"
    Option "PreferredMode" "1280x1024"
    VendorName "JEN"
    VertRefresh 43-77
    UseModes "Modes[0]"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1280x1024" 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +HSync +VSync
    EndSection

    Section "Screen"
    DefaultDepth 16
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection

    Section "Device"
    BoardName "GeForce 7600 GS"
    BusID "3:0:0"
    Driver "nvidia"
    Identifier "Device[0]"
    Screen 0
    VendorName "NVidia"
    EndSection

    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection

  7. #7

    Default Re: KDE4 + Compiz = Crashed desktop?

    how did u enable compiz desktop effects in the first place, and have u tried kwin's own effects?
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  8. #8
    1rf4n-m4rt1n NNTP User

    Default Re: KDE4 + Compiz = Crashed desktop?

    Hi all,

    the same crash like you were happened with my notebook after using compiz in KDE4.

    thanks in advance,
    1rf4n

  9. #9
    carlbeech NNTP User

    Default Re: KDE4 + Compiz = Crashed desktop?

    "how did u enable compiz desktop effects in the first place, and have u tried kwin's own effects?"

    I enabled these by installing the 'compiz' components via software management, then using the 'desktop effects' menu entry on the main list.

    I also tried by using the kde 'session' information within the kde-components... advanced section. (as mentioned in Compiz Fusion - openSUSE)

    Both methods yield the same results... :-(

    Thanks

    Carl.

  10. #10
    Uwe Buckesfeld NNTP User

    Default Re: KDE4 + Compiz = Crashed desktop?

    On 06/22/2008 carlbeech wrote:
    > I enabled these by installing the 'compiz' components via software
    > management, then using the 'desktop effects' menu entry on the main
    > list.


    Wild guess, but I had good success with the latest compiz versions on two machines. Enable the community repository for XGL and update compiz.

    Uwe

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •