Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

  1. #1

    Default Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    I have a G4 Digital Audio, all Apple, tower with Suse 11 installed as a clean install. I also have membership in the audio and cdrom groups. I have no system bel, Yast sound test fails all settings. I have all the normal files and such for complete troubleshooting, but I don't want to publish the sound files unless someone really needs them. Reading my tsalsa results show that my Amixer pc spkr is set to zero. I think this is the problem, but I can't find any gui or any files where I would think I could change this setting. It caused my audio to be muted in the past, but now the Alsamixer gui only has two volume controls and no controls for any of the mute functions, etc. I guess all I need to know is where the config file is for the Amixer for Suse 11 PPC.

    BTW, Yast sound cfg shows AWACS (built in audio for PPC) as sound card 0. Edit only allows me to turn the system beep on and off and right now a "tput bel" on the terminal is silent. I think the setup will yield sound if I unmute the mixer.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    316

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    I do not know if it works in suse 11 to run the following commands in the failsafe mode
    1)Alsaconfig
    2)Alsamixer
    3)Alsactl store

    regards
    dobby9

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,604
    Blog Entries
    38

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    Quote Originally Posted by motsteve View Post
    I have all the normal files and such for complete troubleshooting, but I don't want to publish the sound files unless someone really needs them. Reading my tsalsa results show that my Amixer pc spkr is set to zero.
    If you post the URL(s) provided by those diagnostic scripts and paste the URL here, I am confident you will get people look at them. Please paste the URL, and do NOT clutter this thread by copying and pasting the contents. Just paste the URL.

  4. #4

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?


  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,604
    Blog Entries
    38

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    Quote Originally Posted by motsteve View Post
    Thankyou for running the scripts.

    So you have a "tumbler" ! Also, it looks to me like your mixer has the sound set to "mute". Take a look at the tsalsa script output:

    Code:
    Amixer contents for card 0 [Tumbler] _____________________________________        
    amixer set 'Master',0 70%,70% on        
    amixer set 'PCM',0 70%        
    amixer set 'Auto Mute',0 on
    I believe you should set the "auto mute" to OFF.

    Please open an xterm and type: alsamixer
    Then unmute the mixer.

    You can read of another G4 Mac users experience here:
    New PPC G4 Install No Sound - openSUSE Forums
    in particular, post#13

  6. #6

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    That's the problem I thought I had. I did open the alsamixer and the only control I have is the volume. The mute buttons and all are missing. The control I had in 10.3 had the mute buttons and that at least fixed the problem getting sound at all. My applications like Banshee and Kaffeine didn't work. Banshee blew up and Kaffeine just sat there. I decided to go for broke upgrading to 11.0 thinking that if I had no sound it was probably the same problem as in 10.3., but the alsamixer panel changed. Bummer. At least my Alsa files were up-rev'd.

    BTW, unless you install the gui panel for alsamixer it's strictly terminal for PPC. The default volume control is Pulse, but tweeking that does nothing but wear my mouse out. :-)

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,604
    Blog Entries
    38

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    Quote Originally Posted by motsteve View Post
    I did open the alsamixer and the only control I have is the volume. The mute buttons and all are missing.
    I am surprised you do not have a better alsamixer gui. Can you post the output of:
    rpm -qa | grep alsa
    rpm -q libasound2


    Reference "pulse", my understanding is it is not essential, and it can be removed without a problem. If uncertain, you could remove it, making note of the exact packages being removed, so you could re-install if necessary.

  8. #8

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    ### rpm -qa | grep alsa
    alsa-1.0.16-39.1
    alsa-oss-1.0.15-48.1
    alsa-plugins-pulse-1.0.16-57.1
    alsa-utils-1.0.16-35.1
    alsa-plugins-1.0.16-57.1

    ### rpm -q libasound2
    libasound2-1.0.16-39.1

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,604
    Blog Entries
    38

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    Quote Originally Posted by motsteve View Post
    ### rpm -qa | grep alsa
    alsa-1.0.16-39.1
    alsa-oss-1.0.15-48.1
    alsa-plugins-pulse-1.0.16-57.1
    alsa-utils-1.0.16-35.1
    alsa-plugins-1.0.16-57.1

    ### rpm -q libasound2
    libasound2-1.0.16-39.1
    Have you rebooted once since installing to ensure the alsa modules are properly loaded? Alsa-utils provides alsamixer, so I am a bit surprised you do not have a better gui. Only a volume control and nothing else? Is there not a "mixer" button you can click ON ? (kmix has such a button)

    You could also try installing alsa-firmware and alsa-tools (followed by a reboot).

    Or you could type "man amixer" and try to figure out the commands to manually unmute. I think you need to type "amixer controls" first, to see what controls you have (and get the exact syntax) Then type something like: "amixer -c 1 < specific control > unumute", substituting the name of the control (from "amixer controls") into the < specific control > . I don't know the syntax, (I'm just trying to be helpful) so you may have to explore a bit.

    You may also give consideration to un-installing all the pulse audio apps, as I have read of users experiencing problems with pulse audio.

    Good luck.

  10. #10

    Default Re: Suse 11 New Instal PPC No Sound. Alsamixer Conf?

    I'll do all of that and let you know what happened. I do think that I've rebooted several times since installing trying this and that, but I'll do it all again just in case. I too have read about pulse and alsa having problems. 10.3 installed no pulse on my Mac, but 11.0 is chalk full of pulse. This will take some time. Please be patient. I will return. Besides my boss (aka wife ) is calling.:-)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •