Results 1 to 4 of 4

Thread: Firefox 3 font rendering in KDE3

  1. #1

    Default Firefox 3 font rendering in KDE3

    I have done a clean install of openSUSE 11.0 and upgraded Firefox through YaST to 3.0 final. I normally use the KDE3 desktop. Firefox 3 seems to be doing its own font rendering under KDE3 independent of my KDE3 settings. In KDE3 I have set the hinting style at "medium". Also, in the KDE Control Center I have specified "Use my KDE fonts in GTK applications". In Firefox the fonts look like they use full hinting which I find too narrow and more difficult to read. I installed the Gnome desktop and adjusted the fonts there to use "slight" hinting. Under Gnome, fonts in Firefox look just like I expect them to (ie. "slight" hinting, almost identical to "medium" hinting in KDE3).

    Is there some setting in Firefox or elsewhere so the fonts in Firefox under KDE3 look like "medium" hinting is being used so that Firefox fonts look similar in both Gnome and KDE? Thanks.

  2. #2

    Default Re: Firefox 3 font rendering in KDE3

    I have done some further work on Firefox font rendering and have developed an unaesthetic workaround which activates font hinting in Firefox under the KDE3 desktop (you need to have the gnome desktop installed):

    1. create a symlink inside .kde/Autostart to /usr/bin/gnome-appearance-properties This will open gnome-appearance-properties when KDE3 starts.

    2. close the gnome-appearance-properties window after KDE has finished booting. This seems to activate whatever settings are necessary for gnome applications, including Firefox, under KDE.

    3. The first time you do this you need to set the fonts and font rendering in gnome-appearance-properties to conform to what you have set in the KDE Control Center, as well as the mouse icon theme. To my eye, LCD sub-pixel smoothing at "slight" seems to be very similar to KDE "medium" hinting. This only needs to be done once.

    If someone could tell me how to close the gnome-appearance-properties window automatically after KDE starts that would alleviate the unaesthetic nature of this workaround.

  3. #3

    Default Re: Firefox 3 font rendering in KDE3

    "Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." -- Benjamin Franklin

  4. #4

    Default Re: Firefox 3 font rendering in KDE3

    Excellent--that did it--the last step in the tutorial was the key. It looks like the reason that starting up gnome-appearance-properties worked was that this started gnome-settings-daemon as a background process. Starting the gnome-settings-daemon directly through a symlink in .kde/Autostart has the same effect without putting up a window which needs to be dismissed. gnome-settings daemon is now found at:

    /usr/lib/gnome-settings-daemon/gnome-settings-daemon

    I wonder why this is necessary in openSUSE 11.0 when it wasn't in 10.2 or 10.3.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •