Results 1 to 6 of 6

Thread: Display problem

  1. #1
    rodrigo_botafogo NNTP User

    Default Display problem

    I' ve just installed Suse 11.0 on a toshiba A215-S7428. Suse 10.3 worked fine (without sound or wireless - but was usable). In Suse 11.0 sound works, and I still have to check the wireless, but my display is funny. Although it got properly configured it is slow and does not update properly. It leaves garbage when windows are moved or a move the scroll bar. Any ideas on how to fix it? It is very importante, otherwise the system will be useless...

    Thanks,


    Rodrigo

  2. #2
    rodrigo_botafogo NNTP User

    Default Re: Display problem

    I forgot to give more info on the Toshiba A215 hardware:
    Athlon X2, ATI Radeon, Raltek wireless.

    Any help is greatly appreciated!

  3. #3
    Join Date
    Jun 2008
    Location
    Iowa, USA
    Posts
    24

    Default Re: Display problem

    Have you installed the proprietary ATI drivers (if your card is supported, and not supported by open source 3d drivers)? If not, go to 1-click-install - openSUSE-Community to find and install the current driver for 11.0. If you did install the drivers, there are some other possibilities. First, make sure the ATI drivers installed correctly. Open a console, and type "fglrxinfo". The OpenGL vendor string should say ATI Technologies, Inc. Getting that fixed is where you will want to focus your attention.

    Another potential problem is if you are trying to use KDE4, you should be aware that it is still experiencing growing pains and some of the effects and features may not work correctly. If you suspect this is the problem, start by turning off any effects you might have enabled. Then turn them back on one at a time and see what causes problems. You may have trouble with the default configuration, and may want to search for your video card and KDE4 to see if there are any known issues.

    KDE4 may turn out not to be a good solution for a reliable working system at this point (some find it works fine for their needs and hardware, but others do not, so YMMV). You can install KDE 3.5.9 for your default desktop environment. This is why the DVD installation warns people about making KDE4 their default desktop, and says that 3.5.9 is the stable version of KDE (installing from the KDE live CD doesn't give you this warning or the option to install KDE 3.5.9).

    If you are using Gnome, someone else will have to help.

  4. #4
    rodrigo_botafogo NNTP User

    Default Re: Display problem

    Thanks for your help... installing the proprietary ATI driver and doing sudo aticonfig --initial partially solved the problem. All is working, although using intensive video apps (such as mplayer) still has problems. With mplayer, my display flickers like crazy and it is impossible to watch anything. Maybe moving to kde3 will solve the problem... I installed from the live CD, so I didn't see the message about kde4.

  5. #5
    rodrigo_botafogo NNTP User

    Default Re: Display problem

    Just removing the desktop effect solved the flickering problem in mplayer! So thanks again!

  6. #6
    Join Date
    Jun 2008
    Location
    Davenport, IA
    Posts
    17

    Default Re: Display problem

    I have installed the proprietary ATI drivers on my desktop, and when I enabled the effects, it was acting very slow, and had lots of artifacts and such.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •