Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: VNC in OpenSUSE 11

  1. #1

    Default VNC in OpenSUSE 11

    Just upgraded from 10.3 to 11. Remote administration is activated (trhu Yast) and the firewal rules are adjusted. I can remote login with ssh but no go with VNC (on port 5901). What's wrong?

  2. #2
    isrdcas NNTP User

    Default Re: VNC in OpenSUSE 11

    Same here.

    VNC worked fine in 10.3 but does not work in 11.0
    VNC is still enabled and the firewall is open for VNC.
    I get an 'Invalid Protocol" message. Nothing has changed on the Windows side. The only thing that has changed is from 10.3 to 11.0.

    If I can not get VNC to work, I will have to go back to 10.3 has I have no monitor for the Linux computer.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,317
    Blog Entries
    15

    Default Re: VNC in OpenSUSE 11

    On Sat, 21 Jun 2008 00:16:04 GMT
    isrdcas <isrdcas@no-mx.forums.opensuse.org> wrote:

    >
    > Same here.
    >
    > VNC worked fine in 10.3 but does not work in 11.0
    > VNC is still enabled and the firewall is open for VNC.
    > I get an 'Invalid Protocol" message. Nothing has changed on the
    > Windows side. The only thing that has changed is from 10.3 to 11.0.
    >
    > If I can not get VNC to work, I will have to go back to 10.3 has I
    > have no monitor for the Linux computer.
    >
    >

    Hi
    Is something else using the vnc port? I would recommend freenx if you
    can install the client on the windows machine.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP2 x86_64 Kernel 2.6.16.60-0.23-smp
    up 9 days 20:46, 0 users, load average: 0.44, 0.53, 0.66
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.09


  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: VNC in OpenSUSE 11

    Quote Originally Posted by isrdcas View Post
    VNC worked fine in 10.3 but does not work in 11.0
    Maybe its only certain ways of running vnc that don't work, but other ways do?

    I just successfully accessed an 11.0 PC running x11vnc by the following (piping the vnc display over ssh which is reasoably secure):

    PC-1 is an openSUSE-10.3 PC
    PC-2 is an opensuse-11.0 PC

    From 1st konsole on PC-1:
    ssh -t -L 5900:localhost:5900 oldcpu@ip-address-of-pc-2 'x11vnc -localhost -nolookup -nopw -display :0'
    ... and then entered password for user "oldcpu" on PC-2:

    From 2nd konsole on PC-1
    vncviewer -encodings "tight copyrect hextile" localhost:0

    And I successfully connected to PC-2, piping its vnc desktop display back to pc-1.

  5. #5

    Default Re: VNC in OpenSUSE 11

    Using OpenSUSE 11 and VNC with Veno worked flawlessly for me after I opened the firewall port.
    My Weblog: Everything Linux
    GPG Key ID: C92EF367 / 1428 FE8E 1E07 DDA8 EFD7 195F DCCD F5B3 C92E F367

  6. #6

    Default Re: VNC in OpenSUSE 11

    Ok, I found the problem : just need to remove "-SecurityTypes None" in /etc/xinetd.d/vnc in the section vnc1 and then restart xinetd (rcxinetd restart).

    Since my computer was upgraded from 10.3, I'm not sure if this option comes from 10.3 or 11.

  7. #7
    jrepe NNTP User

    Default Re: VNC in OpenSUSE 11

    I'm sorry that I cannot help - just report the same: installed 11 out of the box, no VNC login. It's funny though - it's not that the VNC client (Chicken of the VNC, Mac OX X 10.5 - works perfectly with a Suse 10.0 server) does not connect - or that the connection would be refused.

    The connection seems to open for a very short time and it's closed again by the server.

    Have no clue. And I'm so desperate that I'm going to go back to 10.2 for this machine (since 10.3 cannot be downloaded anymore?!?).



    Ah: and the line that was quoted above my entry was not in the specified file - so ... it did not help (at least my installation) :-(

  8. #8

    Default Re: VNC in OpenSUSE 11

    Quote Originally Posted by jrepe View Post
    I'm sorry that I cannot help - just report the same: installed 11 out of the box, no VNC login. It's funny though - it's not that the VNC client (Chicken of the VNC, Mac OX X 10.5 - works perfectly with a Suse 10.0 server) does not connect - or that the connection would be refused.

    The connection seems to open for a very short time and it's closed again by the server.

    Have no clue. And I'm so desperate that I'm going to go back to 10.2 for this machine (since 10.3 cannot be downloaded anymore?!?).



    Ah: and the line that was quoted above my entry was not in the specified file - so ... it did not help (at least my installation) :-(
    I'm having the same issue with Chicken of the VNC from Leopard to openSUSE 11. It does work flawlessly with UltraVNC from a Windows XP box. In the X11 logs after a connection attempt from CotVNC, there's a mention of the version of the VNC server not supporting "screen blanking." If I figure out what the issue is, I'll post a fix.

  9. #9

    Default Re: VNC in OpenSUSE 11

    Funny, I've been having exactly the same problems. I think it's some kind of mismatch with display resolution arguments.

    The default settings within xinetd use a bit depth of 16. When I changed that to 24, I managed to get a connection with UltraVNC as well as TightVNC.

    Maybe someone else can verify ?

    D

  10. #10
    jrepe NNTP User

    Default Re: VNC in OpenSUSE 11

    Quote Originally Posted by dhawkshaw View Post
    Funny, I've been having exactly the same problems. I think it's some kind of mismatch with display resolution arguments.

    The default settings within xinetd use a bit depth of 16. When I changed that to 24, I managed to get a connection with UltraVNC as well as TightVNC.

    Maybe someone else can verify ?

    D
    Well - at least something changed: now the Chicken is not disconnected instantly. But I still cannot really connect - because I see the b/w stripes for a very long time, the window title says "nobody's x11 desktop" and I'm sitting there. After about a minute or so, the Chicken-window closes completely and is re-opened instantly; but no change.

    I also tried to change the logon-user to my on account in the vnc-file /etc/xinet.d/vnc - file (right place?), and restarted the whole thing (a "nono" in Linux, I know...) - but all to no success.

    J

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •