Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Console login instead of Graphical

  1. #1

    Smile Console login instead of Graphical

    Greetings my friends,
    Before procced to the problem, i must tell you that i've googled for hours,searched here but i did not found anything that could help me.
    I WAS an windows>ubuntu>and now suse 11 user.THe idea of open source is cool and thats why i left windows behind(and not only )
    I have downloaded the dvd,burned it,installed it with no problems (second time beacuse the first said my about some packages that coudnt be installed).As i said the opensuse was installed correctly and when the installs finishes it takes me to login but instead of a graphical interface it shows me a console wich says me to login.I dont know if this is my graphics card problem or something.(i have an x1300 card wich i NEVER managed to get it work in ubuntu,no 3d ).I can access the system in failsafe.
    I use the gnome interface (in the fist install i used KDE,but i find it too...big i prefer simple thing)
    Thanks in advance my friends and sorry for my bad english.

  2. #2

    Default Re: Console login instead of Graphical

    Uhm... first idea, as i got the same effect with my ati x1950...

    login with root
    i started sax to take the vesa-driver for gui:

    Code:
    Sax2 -r -m 0=vesa
    ...
    Code:
    startx
    that should bring you into graphics *g*
    Then you'll have to care about your graphic-driver, like i have to do NOW

  3. #3

    Arrow Re: Console login instead of Graphical

    Quote Originally Posted by Bodenseehost View Post
    Uhm... first idea, as i got the same effect with my ati x1950...

    login with root
    i started sax to take the vesa-driver for gui:

    Code:
    Sax2 -r -m 0=vesa
    ...
    Code:
    startx
    that should bring you into graphics *g*
    Then you'll have to care about your graphic-driver, like i have to do NOW
    Thank you for your reply but now the opensuse does not open!!!
    It opens only in saifmofe,when i try to load the system ti shows me a black screen after the loging in like ubuntu!!!
    **** it must be my graphic card

  4. #4

    Default Re: Console login instead of Graphical

    Or you can log in as root
    Type init 3
    sax2 -r -m 0=vesa (note 0 is zero not o)
    Type init 5
    See if it will take you on a gui login screen

  5. #5

    Default Re: Console login instead of Graphical

    Quote Originally Posted by Tsandu View Post
    Or you can log in as root
    Type init 3
    sax2 -r -m 0=vesa (note 0 is zero not o)
    Type init 5
    See if it will take you on a gui login screen
    Thanks but at this point (sudenlly,i dont know why)The pc is not loading the opensuse 11, it shows the loading screen, and the black screen apears.
    Only in Failsafe opens!!!

  6. #6
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Console login instead of Graphical

    As a first it might be good to post the contents of /etc/X11/xorg.conf

    I have a Dell here with an ATI x1300 running smoothly and 3D enabled with opensuse 10.3, so the card should work. I will have a go and install openSUSE 11 this weekend.

    Get the latest driver from the ATI site and install that, that should make a difference when using ATI x1XXX cards.
    After having installed the driver run ' aticonfig --inittial ' (as root) and reboot.

    as a install note: It might also be necessary to take out the vga=... option out of your boot string to get things running correctly.

    I don't know if you have seen this already but also have a look here : ATI - openSUSE

    Lets get it running!

    Wj
    Have a lot of fun!

  7. #7

    Default Re: Console login instead of Graphical

    If you didn't get to the point where you could try any of those commands on the command line to straighten out your computer.


    when you start it up, rather then selecting OpenSuse 11 or the failsafe.

    Type on the line down there

    level 3

    That will only try to boot you back to the command line, and it won't try to boot the GUI stuff.

    So there is a better chance you can get your system back to something

    From there you can look at the steps on sorting out Sax2 with Vesa.

    if that can work for you, it is a simple way to get back to a GUI and from there you can work on making it better when you are inside of KDE or Gnome

  8. #8

    Default Re: Console login instead of Graphical

    Quote Originally Posted by Magic31 View Post
    As a first it might be good to post the contents of /etc/X11/xorg.conf


    Wj
    Thanks man!


    It is quite big...very big


    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-06-20T17:14:19+0300.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
    	Identifier     "Layout[all]"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    	InputDevice    "Keyboard[0]" "CoreKeyboard"
    	InputDevice    "Mouse[1]" "CorePointer"
    	Option	    "Clone" "off"
    	Option	    "Xinerama" "off"
    EndSection
    
    Section "Files"
    	InputDevices   "/dev/gpmdata"
    	InputDevices   "/dev/input/mice"
    	FontPath     "/usr/share/fonts/misc:unscaled"
    	FontPath     "/usr/share/fonts/local"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/Type1"
    	FontPath     "/usr/share/fonts/URW"
    	FontPath     "/usr/share/fonts/Speedo"
    	FontPath     "/usr/share/fonts/PEX"
    	FontPath     "/usr/share/fonts/cyrillic"
    	FontPath     "/usr/share/fonts/latin2/misc:unscaled"
    	FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/latin2/Type1"
    	FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/baekmuk:unscaled"
    	FontPath     "/usr/share/fonts/japanese:unscaled"
    	FontPath     "/usr/share/fonts/kwintv"
    	FontPath     "/usr/share/fonts/truetype"
    	FontPath     "/usr/share/fonts/uni:unscaled"
    	FontPath     "/usr/share/fonts/CID"
    	FontPath     "/usr/share/fonts/ucs/misc:unscaled"
    	FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/hellas/misc:unscaled"
    	FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/hellas/Type1"
    	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
    	FontPath     "/usr/share/fonts/xtest"
    	FontPath     "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
    	Load  "freetype"
    	Load  "type1"
    	Load  "dbe"
    	Load  "glx"
    	Load  "extmod"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AllowMouseOpenFail" "on"
    	Option	    "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard[0]"
    	Driver      "kbd"
    	Option	    "Protocol" "Standard"
    	Option	    "XkbLayout" "us,gr"
    	Option	    "XkbModel" "microsoftpro"
    	Option	    "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
    	Option	    "XkbRules" "xfree86"
    	Option	    "XkbVariant" "basic,extended"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse[1]"
    	Driver      "mouse"
    	Option	    "Buttons" "5"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Name" "ImPS/2 Generic Wheel Mouse"
    	Option	    "Protocol" "explorerps/2"
    	Option	    "Vendor" "Sysp"
    	Option	    "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
    	Identifier     "Modes[0]"
    	ModeLine     "1024x768" 94.0 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor[0]"
    	VendorName   "SNY"
    	ModelName    "SONY CPD-E250"
    	UseModes     "Modes[0]"
    	DisplaySize  312	234
    	HorizSync    30.0 - 96.0
    	VertRefresh  43.0 - 170.0
    	Option	    "DPMS"
    	Option	    "PreferredMode" "1024x768"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "Device[0]"
    	Driver      "radeonhd"
    	VendorName  "ATI"
    	BoardName   "Radeon X1300/X1550"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen[0]"
    	Device     "Device[0]"
    	Monitor    "Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     15
    		Modes    "1024x768" "1024x600" "800x600" "768x576" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     16
    		Modes    "1024x768" "1024x600" "800x600" "768x576" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     24
    		Modes    "1024x768" "1024x600" "800x600" "768x576" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     8
    		Modes    "1024x768" "1024x600" "800x600" "768x576" "640x480"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        "video"
    	Mode         0660
    EndSection

  9. #9

    Default Re: Console login instead of Graphical

    Originally Posted by gregosmith
    If you didn't get to the point where you could try any of those commands on the command line to straighten out your computer.


    when you start it up, rather then selecting OpenSuse 11 or the failsafe.

    Type on the line down there

    level 3

    That will only try to boot you back to the command line, and it won't try to boot the GUI stuff.

    So there is a better chance you can get your system back to something

    From there you can look at the steps on sorting out Sax2 with Vesa.

    if that can work for you, it is a simple way to get back to a GUI and from there you can work on making it better when you are inside of KDE or Gnome

    I'll try that my friend

  10. #10
    w0nk NNTP User

    Default Re: Console login instead of Graphical

    Hi!

    Try this, i had also a Problem with my 3870 x2.
    Solution 3870 X2 no Xserver after install - openSUSE Forums

    mfg
    Visitor

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •