Results 1 to 7 of 7

Thread: Can't connect to WEP network

  1. #1
    deathwarder NNTP User

    Default Can't connect to WEP network

    Hi,
    I just installed opensuse 11 on my laptop, but cannot connect to my WEP network. Opensuse sees the network, and will try to connect, but will just keep on asking me for a key(which I provide, but it will just ask again in a few seconds).
    Any suggestions?

  2. #2
    deathwarder NNTP User

    Default Re: Can't connect to WEP network

    I tried to edit the previous post, but I guess I was too late. I tried disabling the security on the network, which didn't help. I tried installing a different os to make sure that the wireless card(cisco aironet) wasn't broken, and it wasn't. I tried several configuration changes, still no luck. What do I do?

  3. #3
    Larry Finger NNTP User

    Default Re: Can't connect to WEP network

    deathwarder wrote:
    > I tried to edit the previous post, but I guess I was too late. I tried
    > disabling the security on the network, which didn't help. I tried
    > installing a different os to make sure that the wireless card(cisco
    > aironet) wasn't broken, and it wasn't. I tried several configuration
    > changes, still no luck. What do I do?


    How are you putting in the key? You do know that there are several
    ways to convert from a passphrase to a hex key.

    FYI, NetworkManager works just fine with WEP. What does dmesg have to
    say about the problem?


  4. #4

    Default Re: Can't connect to WEP network

    Try updating your system. There was a KNetworkManager update or something like that which went through.

    Yesterday I couldn't get WEP to work under OpenSuse so I shut down WEP on my router and just ran it open for a day. The update came for KNetworkManager today and after I put up the WEP encryption and it would work again.

  5. #5
    lionel47 NNTP User

    Default Re: Can't connect to WEP network

    The same thing is happening to me with Suse 11 in Gnome. Does anybody have a fix for this?

  6. #6

    Default Re: Can't connect to WEP network

    perhaps your card is not set up properly. this is obviously not an encryption problem, since the machine still wouldn't connect when the security (WEP) was disabled. there have been problems with certain cards with networkmanager, possibly try traditional method ifup, and try using kinternet, it's basic but works with wep. ensure ipv6 is disabled too, since this can hamper a connection. check correct drivers are installed also, under module name, perhaps do a little google search for that driver which is installed and see if there are any issues with it. when i get more time i will try to help more if i can.

    Ross.

  7. #7
    Join Date
    Jun 2008
    Location
    Dublin, Ireland
    Posts
    298

    Default Re: Can't connect to WEP network

    Ok, I had a problem with KNetworkManager and got my wireless working by doing this. It might be of help:

    First, configure the network card using the Traditional option in Yast

    This should install KInternet. When that's finished start KInternet from the application launcher. You should see a little icon like a plug on the taskbar.

    Then open a terminal. Change to root access, type 'su' and password.
    Then do this:

    Bring up the network
    # ifconfig wlan0 up

    Scan for your wireless network.
    # iwlist wlan0 scan

    Associate your wireless network with the card
    # iwconfig wlan0 essid [your network name]

    Associate your WEP key
    # iwconfig wlan0 key [your key in hex]

    Try and connect
    # dhclient wlan0

    Try pinging Google
    If that works you should have a connection. You can also configure the network using KInternet.

    Hope this helps..
    /jlar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •