Results 1 to 7 of 7

Thread: Pulseaudio and its problems

  1. #1
    Join Date
    Jun 2008
    Location
    Karlsruhe
    Posts
    27

    Default Pulseaudio and its problems

    Hi,

    I just made a new install of opensuse 11.0 and the issue that annoys me most is pulseaudio. Not that I know that there are always problems when having a new distro, but this makes me really mad and I can't find the problem:

    Pulseaudio causes my gnome sound to have serious delay, e.g. when sending a message with pidgin it is about 1 second till I can hear the sound.

    Then in apps that dont use pa natively I still have delay and the sound appears very noisy, like having a bad micro input.
    I tired pasuspender in that case, with no change.

    Also there were times when I did not have audio at all.

    I even installed the newest pa version with one repo i found, but it does not change anything.

    Has someone the same probs or someone out there who can help me?
    Or does it mean I have to kick pa and get back to good old alsa and esound? I didnt have those probs with fedora and ubuntu which rely on pa too. Maybe the wrong sink ?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Pulseaudio and its problems

    You can always remove pulse audio, if you find the layer it introduces is not conducive to your enjoying your openSUSE experience.

  3. #3
    Join Date
    Jun 2008
    Location
    Karlsruhe
    Posts
    27

    Default Re: Pulseaudio and its problems

    I already removed it, because if I wanted to play something like q3 the sounddelay was just unbearable.

    I hope that will get fixed in the future. Pulseaudio is a great idea, but I think for gamers not yet usable.

    Or has someone a solution for the delay issue?

  4. #4
    Join Date
    Jun 2008
    Location
    Friesland
    Posts
    207

    Default Re: Pulseaudio and its problems

    pulseaudio shows a lot of promise but I too think it is not ready for prime time yet. I have removed it as well because it would die on me twice an hour and cause a 20 second boot delay. For now I am happy with the previous sound system besides I do not really need multichannel multilayer sound anyway.

    stefan
    "The day Microsoft makes something that doesn't suck is the day they make a vacuum cleaner"
    OS: Fedora9, RHEL5, CENTOS5, Arch, OpenSuSe11
    Hardware: Dell Precision M65

  5. #5

    Default Re: Pulseaudio and its problems

    What is the alternative to Pulse Audio? Just want to know what packages to look out for as I also want to remove it.

  6. #6
    Join Date
    Jun 2008
    Location
    Friesland
    Posts
    207

    Default Re: Pulseaudio and its problems

    when you remove pulseaudio ALSA automatically kicks in so you should be fine.

    stefan
    "The day Microsoft makes something that doesn't suck is the day they make a vacuum cleaner"
    OS: Fedora9, RHEL5, CENTOS5, Arch, OpenSuSe11
    Hardware: Dell Precision M65

  7. #7

    Default Re: Pulseaudio and its problems

    pulseaudio glitch-free branch will be great, but previous versions aren't.

    I don't use Gnome (KDE doesn't uses PulseAudio). But from my understanding Gnome NEEDS a sound server, doesn't? Since I don't think ESD is any better than PulseAudio what I would do is:
    a) Remove alsa-plugins-pulse package. So ALSA apps will not use PulseAudio, just the Gnome ones that use esound.
    b) For Gnome apps adjust the delay to the one you prefer. And set PulseAudio to use "default" device instead of "hw"... so ALSA apps will not complain about the sound card being busy.

    Not sure about how the configuration works. Probably PulseAudio - Trac explain it. At worst you will have to edit a config file, probably located at /etc/pulseaudio.conf ;-) and set some parameter named "delay" or "buffer size".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •