Results 1 to 5 of 5

Thread: WEBDAV

  1. #1
    NM78 NNTP User

    Default WEBDAV

    Hi, i try to say it in a shot list:

    • 5 PCs should use a WebDAV Server (in local Network)
    • every PC should save an own calendar on the server (Thunderbird, Lightning)
    • the server should been accessible from internet too for extern workers
    • the server is an OpenSuse 10.3


    The access by DynDNS on the webserver works fine. I can see there the WebDAV directory. But there is no authentification if i try to open directory in browser f.e.
    Code:
    http://192.168.1.55/webdav or http://www.something.de/webdav (from internet)
    I can only see the directory in the browser:

    Code:
    Index of /webdav
    
    Icon  Name                    Last modified      Size  Description[DIR] Parent Directory                             -   
    
    Apache/2.2.4 (Linux/SUSE) Server at 192.168.1.55 Port 80
    When i want to add an save a new calendar in Thunderbird(Lightning), i must insert an username and password. But it wont work with pw from the user that iam add in tutorial. root pw wont work too.

    The tutorial:

    Webdav - openSUSE

    Can you say me the error?

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: WEBDAV

    Lots of things could be wrong, hard to say without any clues. Maybe you made a typo in the authentication section of the config and it doesn't enforce authentication. You should be asked for a username and password, even if coming in from a web browser. It should prompt you with the string in AuthName.

  3. #3
    NM78 NNTP User

    Default Re: WEBDAV

    Here is my config file:

    Code:
    <IfModule mod_dav_fs.c>
    	#Location of the WebDAV lock database
    	DavLockDB /var/lib/apache2/dav/lockdb
    </IfModule>
    
    <IfModule mod_dav.c>
    	#XML request bodies are loaded into memory;
    	#limit to 128K by default
    	LimitXMLRequestBody 131072
    
    	#Location of the WebDAV Respository.
    	Alias /webdav "/srv/www/webdav"
    
    	<Directory /srv/www/webdav>
    		#enable webdav for this directory
    		Dav On
    		Options +Indexes
    		IndexOptions FancyIndexing
    		AddDefaultCharset UTF-8
    		AuthType Basic
    		AuthName "WebDAV Server"
    
    		#htpasswd2 -c /etc/apache2/dav_users.db <username>
    		AuthUserFile /etc/apache2/dav_users.db
    		<LimitExcept GET OPTIONS>
    			Require vaild-user
    		</LimitExcept>
    		Order allow,deny
    		Allow from all
    	</Directory>
    </IfModule>
    I hope there is no error?!?

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: WEBDAV

    Did you do this step and restart apache?

    Code:
    Edit /etc/sysconfig/apache2 and add dav and dav_fs to the APACHE_MODULES variable.
    Do a:

    Code:
    /usr/sbin/httpd2 -M 2>&1 | grep dav
    and post the result.

  5. #5
    cimbo NNTP User

    Default Re: WEBDAV

    I have the same Problem:

    Code:
    Horst:~ # /usr/sbin/httpd2 -M 2>&1 | grep dav
     dav_module (shared)
     dav_fs_module (shared)
    Horst:~ #
    can you help me?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •